%global _empty_manifest_terminate_build 0
Name:		python-diffios
Version:	0.0.9
Release:	1
Summary:	Compare Cisco IOS configurations against a template.
License:	MIT
URL:		https://github.com/robphoenix/diffios
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/5a/ca/db4e7f5ec12d06416fbbff3d33491e774bc61d861908628c90cbec1c6f39/diffios-0.0.9.tar.gz
BuildArch:	noarch


%description
Install via pip
    pip install diffios

%package -n python3-diffios
Summary:	Compare Cisco IOS configurations against a template.
Provides:	python-diffios
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-diffios
Install via pip
    pip install diffios

%package help
Summary:	Development documents and examples for diffios
Provides:	python3-diffios-doc
%description help
Install via pip
    pip install diffios

%prep
%autosetup -n diffios-0.0.9

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-diffios -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.9-1
- Package Spec generated