%global _empty_manifest_terminate_build 0 Name: python-deeptrack Version: 1.5.6 Release: 1 Summary: A deep learning oriented microscopy image simulation package License: MIT License URL: https://github.com/softmatterlab/DeepTrack-2.0/ Source0: https://mirrors.aliyun.com/pypi/web/packages/07/f1/94a7590397af7f18248e993418f87f9cd932618d3e1717132f830da18788/deeptrack-1.5.6.tar.gz BuildArch: noarch Requires: python3-tensorflow Requires: python3-numpy Requires: python3-matplotlib Requires: python3-scipy Requires: python3-numpydoc Requires: python3-scikit-image Requires: python3-tensorflow-probability Requires: python3-tensorflow-datasets Requires: python3-more-itertools Requires: python3-pint Requires: python3-pandas Requires: python3-tqdm Requires: python3-tensorflow-addons %description

A comprehensive deep learning framework for digital microscopy.

PyPI version PyPI version Python version

Installation • Examples • Basics • Cite us • License

We provide tools to create physical simulations of optical systems, to generate and train neural network models, and to analyze experimental data. # Installation DeepTrack 2.1 requires at least python 3.6. To install DeepTrack 2.1, open a terminal or command prompt and run: pip install deeptrack If you have a very recent version of python, you may need to install numpy _before_ DeepTrack. This is a known issue with scikit-image. ### Updating to 2.1 from 2.0 If you are already using DeepTrack 2.0 (pypi version 0.x.x), updating to DeepTrack 2.1 (pypi version 1.x.x) is painless. If you have followed deprecation warnings, no change to your code is needed. There are two breaking changes: - The deprecated operator `+` to chain features has been removed. It is now only possible using the `>>` operator. - The deprecated operator `**` to duplicate a feature has been removed. It is now only possible using the `^` operator. If you notice any other changes in behavior, please report it to us in the issues tab. # Examples of applications using DeepTrack DeepTrack is a general purpose deep learning framework for microscopy, meaning you can use it for any task you like. Here, we show some common applications!

Single particle tracking


Training a CNN-based single particle tracker using simulated data
Unsupervised training of a single particle tracker using LodeSTAR


Multi-particle tracking


Training LodeSTAR to detect multiple cells from a single image
Training a UNet-based multi-particle tracker using simulated data


Particle tracing


Training MAGIK to trace migrating cells

# Basics to learn DeepTrack 2.1 Everybody learns in different ways! Depending on your preferences, and what you want to do with DeepTrack, you may want to check out one or more of these resources. ## Getting-started guides We have two separate series of notebooks which aims to teach you all you need to know to use DeepTrack to its fullest. The first is a set of six notebooks with a focus on the application. 1. deeptrack_introduction_tutorial gives an overview of how to use DeepTrack 2.1. 2. tracking_particle_cnn_tutorial demonstrates how to track a point particle with a convolutional neural network (CNN). 3. tracking_particle_cnn_tutorial demonstrates how to track multiple particles using a U-net. 4. characterizing_aberrations_tutorial demonstrates how to add and characterize aberrations of an optical device. 5. distinguishing_particles_in_brightfield_tutorial demonstrates how to use a U-net to track and distinguish particles of different sizes in brightfield microscopy. 6. analyzing_video_tutorial demonstrates how to create videos and how to train a neural network to analyze them. The second series focuses on individual topics, introducing them in a natural order. 1. Introducing how to create simulation pipelines and train models. 2. Demonstrating data generators. 3. Demonstrating how to customize models using layer-blocks. ## DeepTrack 2.1 in action Additionally, we have seven more case studies which are less documented, but gives additional insight in how to use DeepTrack with real datasets 1. [MNIST](examples/paper-examples/1-MNIST.ipynb) classifies handwritted digits. 2. [single particle tracking](examples/paper-examples/2-single_particle_tracking.ipynb) tracks experimentally captured videos of a single particle. (Requires opencv-python compiled with ffmpeg to open and read a video.) 3. [single particle sizing](examples/paper-examples/3-particle_sizing.ipynb) extracts the radius and refractive index of particles. 4. [multi-particle tracking](examples/paper-examples/4-multi-molecule-tracking.ipynb) detects quantum dots in a low SNR image. 5. [3-dimensional tracking](examples/paper-examples/5-inline_holography_3d_tracking.ipynb) tracks particles in three dimensions. 6. [cell counting](examples/paper-examples/6-cell_counting.ipynb) counts the number of cells in fluorescence images. 7. [GAN image generation](examples/paper-examples/7-GAN_image_generation.ipynb) uses a GAN to create cell image from masks. ## Model-specific examples We also have examples that are specific for certain models. This includes - [*LodeSTAR*](examples/LodeSTAR) for label-free particle tracking. - [*MAGIK*](deeptrack/models/gnns/) for graph-based particle linking and trace characterization. ## Documentation The detailed documentation of DeepTrack 2.1 is available at the following link: https://softmatterlab.github.io/DeepTrack2/deeptrack.html ## Video Tutorials Videos are currently being updated to match with the current version of DeepTrack. ## Cite us! If you use DeepTrack 2.1 in your project, please cite us here: ``` Benjamin Midtvedt, Saga Helgadottir, Aykut Argun, Jesús Pineda, Daniel Midtvedt, Giovanni Volpe. "Quantitative Digital Microscopy with Deep Learning." Applied Physics Reviews 8 (2021), 011310. https://doi.org/10.1063/5.0034891 ``` See also: : ``` Midtvedt, B., Pineda, J., Skärberg, F. et al. "Single-shot self-supervised object detection in microscopy." Nat Commun 13, 7492 (2022). ``` : ``` Jesús Pineda, Benjamin Midtvedt, Harshith Bachimanchi, Sergio Noé, Daniel Midtvedt, Giovanni Volpe,1 and Carlo Manzo "Geometric deep learning reveals the spatiotemporal fingerprint ofmicroscopic motion." arXiv 2202.06355 (2022). ``` : ``` Saga Helgadottir, Aykut Argun, and Giovanni Volpe. "Digital video microscopy enhanced by deep learning." Optica 6.4 (2019): 506-513. ``` : ``` Saga Helgadottir, Aykut Argun, and Giovanni Volpe. "DeepTrack." (2019) ``` ## Funding This work was supported by the ERC Starting Grant ComplexSwimmers (Grant No. 677511), the ERC Starting Grant MAPEI (101001267), and the Knut and Alice Wallenberg Foundation. %package -n python3-deeptrack Summary: A deep learning oriented microscopy image simulation package Provides: python-deeptrack BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-deeptrack

A comprehensive deep learning framework for digital microscopy.

PyPI version PyPI version Python version

Installation • Examples • Basics • Cite us • License

We provide tools to create physical simulations of optical systems, to generate and train neural network models, and to analyze experimental data. # Installation DeepTrack 2.1 requires at least python 3.6. To install DeepTrack 2.1, open a terminal or command prompt and run: pip install deeptrack If you have a very recent version of python, you may need to install numpy _before_ DeepTrack. This is a known issue with scikit-image. ### Updating to 2.1 from 2.0 If you are already using DeepTrack 2.0 (pypi version 0.x.x), updating to DeepTrack 2.1 (pypi version 1.x.x) is painless. If you have followed deprecation warnings, no change to your code is needed. There are two breaking changes: - The deprecated operator `+` to chain features has been removed. It is now only possible using the `>>` operator. - The deprecated operator `**` to duplicate a feature has been removed. It is now only possible using the `^` operator. If you notice any other changes in behavior, please report it to us in the issues tab. # Examples of applications using DeepTrack DeepTrack is a general purpose deep learning framework for microscopy, meaning you can use it for any task you like. Here, we show some common applications!

Single particle tracking


Training a CNN-based single particle tracker using simulated data
Unsupervised training of a single particle tracker using LodeSTAR


Multi-particle tracking


Training LodeSTAR to detect multiple cells from a single image
Training a UNet-based multi-particle tracker using simulated data


Particle tracing


Training MAGIK to trace migrating cells

# Basics to learn DeepTrack 2.1 Everybody learns in different ways! Depending on your preferences, and what you want to do with DeepTrack, you may want to check out one or more of these resources. ## Getting-started guides We have two separate series of notebooks which aims to teach you all you need to know to use DeepTrack to its fullest. The first is a set of six notebooks with a focus on the application. 1. deeptrack_introduction_tutorial gives an overview of how to use DeepTrack 2.1. 2. tracking_particle_cnn_tutorial demonstrates how to track a point particle with a convolutional neural network (CNN). 3. tracking_particle_cnn_tutorial demonstrates how to track multiple particles using a U-net. 4. characterizing_aberrations_tutorial demonstrates how to add and characterize aberrations of an optical device. 5. distinguishing_particles_in_brightfield_tutorial demonstrates how to use a U-net to track and distinguish particles of different sizes in brightfield microscopy. 6. analyzing_video_tutorial demonstrates how to create videos and how to train a neural network to analyze them. The second series focuses on individual topics, introducing them in a natural order. 1. Introducing how to create simulation pipelines and train models. 2. Demonstrating data generators. 3. Demonstrating how to customize models using layer-blocks. ## DeepTrack 2.1 in action Additionally, we have seven more case studies which are less documented, but gives additional insight in how to use DeepTrack with real datasets 1. [MNIST](examples/paper-examples/1-MNIST.ipynb) classifies handwritted digits. 2. [single particle tracking](examples/paper-examples/2-single_particle_tracking.ipynb) tracks experimentally captured videos of a single particle. (Requires opencv-python compiled with ffmpeg to open and read a video.) 3. [single particle sizing](examples/paper-examples/3-particle_sizing.ipynb) extracts the radius and refractive index of particles. 4. [multi-particle tracking](examples/paper-examples/4-multi-molecule-tracking.ipynb) detects quantum dots in a low SNR image. 5. [3-dimensional tracking](examples/paper-examples/5-inline_holography_3d_tracking.ipynb) tracks particles in three dimensions. 6. [cell counting](examples/paper-examples/6-cell_counting.ipynb) counts the number of cells in fluorescence images. 7. [GAN image generation](examples/paper-examples/7-GAN_image_generation.ipynb) uses a GAN to create cell image from masks. ## Model-specific examples We also have examples that are specific for certain models. This includes - [*LodeSTAR*](examples/LodeSTAR) for label-free particle tracking. - [*MAGIK*](deeptrack/models/gnns/) for graph-based particle linking and trace characterization. ## Documentation The detailed documentation of DeepTrack 2.1 is available at the following link: https://softmatterlab.github.io/DeepTrack2/deeptrack.html ## Video Tutorials Videos are currently being updated to match with the current version of DeepTrack. ## Cite us! If you use DeepTrack 2.1 in your project, please cite us here: ``` Benjamin Midtvedt, Saga Helgadottir, Aykut Argun, Jesús Pineda, Daniel Midtvedt, Giovanni Volpe. "Quantitative Digital Microscopy with Deep Learning." Applied Physics Reviews 8 (2021), 011310. https://doi.org/10.1063/5.0034891 ``` See also: : ``` Midtvedt, B., Pineda, J., Skärberg, F. et al. "Single-shot self-supervised object detection in microscopy." Nat Commun 13, 7492 (2022). ``` : ``` Jesús Pineda, Benjamin Midtvedt, Harshith Bachimanchi, Sergio Noé, Daniel Midtvedt, Giovanni Volpe,1 and Carlo Manzo "Geometric deep learning reveals the spatiotemporal fingerprint ofmicroscopic motion." arXiv 2202.06355 (2022). ``` : ``` Saga Helgadottir, Aykut Argun, and Giovanni Volpe. "Digital video microscopy enhanced by deep learning." Optica 6.4 (2019): 506-513. ``` : ``` Saga Helgadottir, Aykut Argun, and Giovanni Volpe. "DeepTrack." (2019) ``` ## Funding This work was supported by the ERC Starting Grant ComplexSwimmers (Grant No. 677511), the ERC Starting Grant MAPEI (101001267), and the Knut and Alice Wallenberg Foundation. %package help Summary: Development documents and examples for deeptrack Provides: python3-deeptrack-doc %description help

A comprehensive deep learning framework for digital microscopy.

PyPI version PyPI version Python version

Installation • Examples • Basics • Cite us • License

We provide tools to create physical simulations of optical systems, to generate and train neural network models, and to analyze experimental data. # Installation DeepTrack 2.1 requires at least python 3.6. To install DeepTrack 2.1, open a terminal or command prompt and run: pip install deeptrack If you have a very recent version of python, you may need to install numpy _before_ DeepTrack. This is a known issue with scikit-image. ### Updating to 2.1 from 2.0 If you are already using DeepTrack 2.0 (pypi version 0.x.x), updating to DeepTrack 2.1 (pypi version 1.x.x) is painless. If you have followed deprecation warnings, no change to your code is needed. There are two breaking changes: - The deprecated operator `+` to chain features has been removed. It is now only possible using the `>>` operator. - The deprecated operator `**` to duplicate a feature has been removed. It is now only possible using the `^` operator. If you notice any other changes in behavior, please report it to us in the issues tab. # Examples of applications using DeepTrack DeepTrack is a general purpose deep learning framework for microscopy, meaning you can use it for any task you like. Here, we show some common applications!

Single particle tracking


Training a CNN-based single particle tracker using simulated data
Unsupervised training of a single particle tracker using LodeSTAR


Multi-particle tracking


Training LodeSTAR to detect multiple cells from a single image
Training a UNet-based multi-particle tracker using simulated data


Particle tracing


Training MAGIK to trace migrating cells

# Basics to learn DeepTrack 2.1 Everybody learns in different ways! Depending on your preferences, and what you want to do with DeepTrack, you may want to check out one or more of these resources. ## Getting-started guides We have two separate series of notebooks which aims to teach you all you need to know to use DeepTrack to its fullest. The first is a set of six notebooks with a focus on the application. 1. deeptrack_introduction_tutorial gives an overview of how to use DeepTrack 2.1. 2. tracking_particle_cnn_tutorial demonstrates how to track a point particle with a convolutional neural network (CNN). 3. tracking_particle_cnn_tutorial demonstrates how to track multiple particles using a U-net. 4. characterizing_aberrations_tutorial demonstrates how to add and characterize aberrations of an optical device. 5. distinguishing_particles_in_brightfield_tutorial demonstrates how to use a U-net to track and distinguish particles of different sizes in brightfield microscopy. 6. analyzing_video_tutorial demonstrates how to create videos and how to train a neural network to analyze them. The second series focuses on individual topics, introducing them in a natural order. 1. Introducing how to create simulation pipelines and train models. 2. Demonstrating data generators. 3. Demonstrating how to customize models using layer-blocks. ## DeepTrack 2.1 in action Additionally, we have seven more case studies which are less documented, but gives additional insight in how to use DeepTrack with real datasets 1. [MNIST](examples/paper-examples/1-MNIST.ipynb) classifies handwritted digits. 2. [single particle tracking](examples/paper-examples/2-single_particle_tracking.ipynb) tracks experimentally captured videos of a single particle. (Requires opencv-python compiled with ffmpeg to open and read a video.) 3. [single particle sizing](examples/paper-examples/3-particle_sizing.ipynb) extracts the radius and refractive index of particles. 4. [multi-particle tracking](examples/paper-examples/4-multi-molecule-tracking.ipynb) detects quantum dots in a low SNR image. 5. [3-dimensional tracking](examples/paper-examples/5-inline_holography_3d_tracking.ipynb) tracks particles in three dimensions. 6. [cell counting](examples/paper-examples/6-cell_counting.ipynb) counts the number of cells in fluorescence images. 7. [GAN image generation](examples/paper-examples/7-GAN_image_generation.ipynb) uses a GAN to create cell image from masks. ## Model-specific examples We also have examples that are specific for certain models. This includes - [*LodeSTAR*](examples/LodeSTAR) for label-free particle tracking. - [*MAGIK*](deeptrack/models/gnns/) for graph-based particle linking and trace characterization. ## Documentation The detailed documentation of DeepTrack 2.1 is available at the following link: https://softmatterlab.github.io/DeepTrack2/deeptrack.html ## Video Tutorials Videos are currently being updated to match with the current version of DeepTrack. ## Cite us! If you use DeepTrack 2.1 in your project, please cite us here: ``` Benjamin Midtvedt, Saga Helgadottir, Aykut Argun, Jesús Pineda, Daniel Midtvedt, Giovanni Volpe. "Quantitative Digital Microscopy with Deep Learning." Applied Physics Reviews 8 (2021), 011310. https://doi.org/10.1063/5.0034891 ``` See also: : ``` Midtvedt, B., Pineda, J., Skärberg, F. et al. "Single-shot self-supervised object detection in microscopy." Nat Commun 13, 7492 (2022). ``` : ``` Jesús Pineda, Benjamin Midtvedt, Harshith Bachimanchi, Sergio Noé, Daniel Midtvedt, Giovanni Volpe,1 and Carlo Manzo "Geometric deep learning reveals the spatiotemporal fingerprint ofmicroscopic motion." arXiv 2202.06355 (2022). ``` : ``` Saga Helgadottir, Aykut Argun, and Giovanni Volpe. "Digital video microscopy enhanced by deep learning." Optica 6.4 (2019): 506-513. ``` : ``` Saga Helgadottir, Aykut Argun, and Giovanni Volpe. "DeepTrack." (2019) ``` ## Funding This work was supported by the ERC Starting Grant ComplexSwimmers (Grant No. 677511), the ERC Starting Grant MAPEI (101001267), and the Knut and Alice Wallenberg Foundation. %prep %autosetup -n deeptrack-1.5.6 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-deeptrack -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Thu Jun 08 2023 Python_Bot - 1.5.6-1 - Package Spec generated