%global _empty_manifest_terminate_build 0
Name: python-storm
Version: 0.25
Release: 1
Summary: Storm is an object-relational mapper (ORM) for Python developed at Canonical.
License: LGPL
URL: https://storm.canonical.com
Source0: https://mirrors.aliyun.com/pypi/web/packages/c0/f6/4b30697087af83edbc25584938fff7de08645ea6c2addf22420b4a1c70c9/storm-0.25.tar.gz
BuildArch: noarch
%description
The project was in development for more than a year for use in
Canonical projects such as Launchpad and Landscape before being
released as free software on July 9th, 2007.
Design:
* Clean and lightweight API offers a short learning curve and
long-term maintainability.
* Storm is developed in a test-driven manner. An untested line of
code is considered a bug.
* Storm needs no special class constructors, nor imperative base
classes.
* Storm is well designed (different classes have very clear
boundaries, with small and clean public APIs).
* Designed from day one to work both with thin relational
databases, such as SQLite, and big iron systems like PostgreSQL
and MySQL.
* Storm is easy to debug, since its code is written with a KISS
principle, and thus is easy to understand.
* Designed from day one to work both at the low end, with trivial
small databases, and the high end, with applications accessing
billion row tables and committing to multiple database backends.
* It's very easy to write and support backends for Storm (current
backends have around 100 lines of code).
Features:
* Storm is fast.
* Storm lets you efficiently access and update large datasets by
allowing you to formulate complex queries spanning multiple
tables using Python.
* Storm allows you to fallback to SQL if needed (or if you just
prefer), allowing you to mix "old school" code and ORM code
* Storm handles composed primary keys with ease (no need for
surrogate keys).
* Storm doesn't do schema management, and as a result you're free
to manage the schema as wanted, and creating classes that work
with Storm is clean and simple.
* Storm works very well connecting to several databases and using
the same Python types (or different ones) with all of them.
* Storm can handle obj.attr = assignments, when
that's really needed (the expression is executed at INSERT/UPDATE
time).
* Storm handles relationships between objects even before they were
added to a database.
* Storm works well with existing database schemas.
* Storm will flush changes to the database automatically when
needed, so that queries made affect recently modified objects.
%package -n python3-storm
Summary: Storm is an object-relational mapper (ORM) for Python developed at Canonical.
Provides: python-storm
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-storm
The project was in development for more than a year for use in
Canonical projects such as Launchpad and Landscape before being
released as free software on July 9th, 2007.
Design:
* Clean and lightweight API offers a short learning curve and
long-term maintainability.
* Storm is developed in a test-driven manner. An untested line of
code is considered a bug.
* Storm needs no special class constructors, nor imperative base
classes.
* Storm is well designed (different classes have very clear
boundaries, with small and clean public APIs).
* Designed from day one to work both with thin relational
databases, such as SQLite, and big iron systems like PostgreSQL
and MySQL.
* Storm is easy to debug, since its code is written with a KISS
principle, and thus is easy to understand.
* Designed from day one to work both at the low end, with trivial
small databases, and the high end, with applications accessing
billion row tables and committing to multiple database backends.
* It's very easy to write and support backends for Storm (current
backends have around 100 lines of code).
Features:
* Storm is fast.
* Storm lets you efficiently access and update large datasets by
allowing you to formulate complex queries spanning multiple
tables using Python.
* Storm allows you to fallback to SQL if needed (or if you just
prefer), allowing you to mix "old school" code and ORM code
* Storm handles composed primary keys with ease (no need for
surrogate keys).
* Storm doesn't do schema management, and as a result you're free
to manage the schema as wanted, and creating classes that work
with Storm is clean and simple.
* Storm works very well connecting to several databases and using
the same Python types (or different ones) with all of them.
* Storm can handle obj.attr = assignments, when
that's really needed (the expression is executed at INSERT/UPDATE
time).
* Storm handles relationships between objects even before they were
added to a database.
* Storm works well with existing database schemas.
* Storm will flush changes to the database automatically when
needed, so that queries made affect recently modified objects.
%package help
Summary: Development documents and examples for storm
Provides: python3-storm-doc
%description help
The project was in development for more than a year for use in
Canonical projects such as Launchpad and Landscape before being
released as free software on July 9th, 2007.
Design:
* Clean and lightweight API offers a short learning curve and
long-term maintainability.
* Storm is developed in a test-driven manner. An untested line of
code is considered a bug.
* Storm needs no special class constructors, nor imperative base
classes.
* Storm is well designed (different classes have very clear
boundaries, with small and clean public APIs).
* Designed from day one to work both with thin relational
databases, such as SQLite, and big iron systems like PostgreSQL
and MySQL.
* Storm is easy to debug, since its code is written with a KISS
principle, and thus is easy to understand.
* Designed from day one to work both at the low end, with trivial
small databases, and the high end, with applications accessing
billion row tables and committing to multiple database backends.
* It's very easy to write and support backends for Storm (current
backends have around 100 lines of code).
Features:
* Storm is fast.
* Storm lets you efficiently access and update large datasets by
allowing you to formulate complex queries spanning multiple
tables using Python.
* Storm allows you to fallback to SQL if needed (or if you just
prefer), allowing you to mix "old school" code and ORM code
* Storm handles composed primary keys with ease (no need for
surrogate keys).
* Storm doesn't do schema management, and as a result you're free
to manage the schema as wanted, and creating classes that work
with Storm is clean and simple.
* Storm works very well connecting to several databases and using
the same Python types (or different ones) with all of them.
* Storm can handle obj.attr = assignments, when
that's really needed (the expression is executed at INSERT/UPDATE
time).
* Storm handles relationships between objects even before they were
added to a database.
* Storm works well with existing database schemas.
* Storm will flush changes to the database automatically when
needed, so that queries made affect recently modified objects.
%prep
%autosetup -n storm-0.25
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-storm -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.25-1
- Package Spec generated