%global _empty_manifest_terminate_build 0
Name:		python-sphinx-better-theme
Version:	0.1.5
Release:	1
Summary:	A nice-looking, customizable Sphinx theme
License:	LICENSE
URL:		http://github.com/irskep/sphinx-better-theme
Source0:	https://mirrors.aliyun.com/pypi/web/packages/70/a3/5b54286499282ec1e18e48674bebe38803c07ba6615445848993fe90ecb4/sphinx-better-theme-0.1.5.tar.gz
BuildArch:	noarch


%description
`Read the documentation`_
`See a demo`_
What is this?
^^^^^^^^^^^^^
This is a modified version of the default Sphinx theme with the following
goals:
1. Remove frivolous colors, especially hard-coded ones
2. Improve readability by limiting width and using more whitespace
3. Encourage visual customization through CSS, not themeconf
4. Use semantic markup
v0.1 meets goals one and two. Goal three is partially complete; it's simple to
add your own CSS file without creating a whole new theme. `Open a ticket` if
you'd like something changed.
Compatibility
"""""""""""""
sphinx-better-theme is compatible with Sphinx 0.6.4+ and Jinja 2.3.1+. Older
versions may work but have not been tested.
Installation
^^^^^^^^^^^^
Method 1: Adding to your source tree
""""""""""""""""""""""""""""""""""""
This method is preferred due to the frequency with which sphinx-better-theme is
improved.
1. Put the theme in your source tree. If you use git, you can add
   ``sphinx-better-theme``'s repository as a submodule. Otherwise you can
   `download the zip file`_ and expand it somewhere predictable. Here's an
   example using git::
        > git submodule add \
            https://github.com/irskep/sphinx-better-theme.git \
            docs/sphinx-better-theme
        > git submodule update --init
2. Add the parent folder of the theme to your ``conf.py``. If you use the
   folder structure in the block above, you'd do it like this::
        html_theme_path = ['sphinx-better-theme']
   (because the theme path is ``sphinx-better-theme/better``.)
3. Set ``html_theme`` to ``'better'`` in your ``conf.py``.
Method 2: Installing to site-packages
"""""""""""""""""""""""""""""""""""""
If adding the theme to your source tree is impractical, if you need to share it
among several repositories, or if you prefer a more serene frequency of
updates, you can install it like a regular Python package.
`Download the zip file`_ and run the usual command::
    > python setup.py install
Or install from PyPI::
    > pip install sphinx-better-theme
To use the theme, set ``html_theme_path`` to contain
``better.better_theme_path``, and set ``html_theme`` to ``'better'``::
    from better import better_theme_path
    html_theme_path = [better_theme_path]
    html_theme = 'better'

%package -n python3-sphinx-better-theme
Summary:	A nice-looking, customizable Sphinx theme
Provides:	python-sphinx-better-theme
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sphinx-better-theme
`Read the documentation`_
`See a demo`_
What is this?
^^^^^^^^^^^^^
This is a modified version of the default Sphinx theme with the following
goals:
1. Remove frivolous colors, especially hard-coded ones
2. Improve readability by limiting width and using more whitespace
3. Encourage visual customization through CSS, not themeconf
4. Use semantic markup
v0.1 meets goals one and two. Goal three is partially complete; it's simple to
add your own CSS file without creating a whole new theme. `Open a ticket` if
you'd like something changed.
Compatibility
"""""""""""""
sphinx-better-theme is compatible with Sphinx 0.6.4+ and Jinja 2.3.1+. Older
versions may work but have not been tested.
Installation
^^^^^^^^^^^^
Method 1: Adding to your source tree
""""""""""""""""""""""""""""""""""""
This method is preferred due to the frequency with which sphinx-better-theme is
improved.
1. Put the theme in your source tree. If you use git, you can add
   ``sphinx-better-theme``'s repository as a submodule. Otherwise you can
   `download the zip file`_ and expand it somewhere predictable. Here's an
   example using git::
        > git submodule add \
            https://github.com/irskep/sphinx-better-theme.git \
            docs/sphinx-better-theme
        > git submodule update --init
2. Add the parent folder of the theme to your ``conf.py``. If you use the
   folder structure in the block above, you'd do it like this::
        html_theme_path = ['sphinx-better-theme']
   (because the theme path is ``sphinx-better-theme/better``.)
3. Set ``html_theme`` to ``'better'`` in your ``conf.py``.
Method 2: Installing to site-packages
"""""""""""""""""""""""""""""""""""""
If adding the theme to your source tree is impractical, if you need to share it
among several repositories, or if you prefer a more serene frequency of
updates, you can install it like a regular Python package.
`Download the zip file`_ and run the usual command::
    > python setup.py install
Or install from PyPI::
    > pip install sphinx-better-theme
To use the theme, set ``html_theme_path`` to contain
``better.better_theme_path``, and set ``html_theme`` to ``'better'``::
    from better import better_theme_path
    html_theme_path = [better_theme_path]
    html_theme = 'better'

%package help
Summary:	Development documents and examples for sphinx-better-theme
Provides:	python3-sphinx-better-theme-doc
%description help
`Read the documentation`_
`See a demo`_
What is this?
^^^^^^^^^^^^^
This is a modified version of the default Sphinx theme with the following
goals:
1. Remove frivolous colors, especially hard-coded ones
2. Improve readability by limiting width and using more whitespace
3. Encourage visual customization through CSS, not themeconf
4. Use semantic markup
v0.1 meets goals one and two. Goal three is partially complete; it's simple to
add your own CSS file without creating a whole new theme. `Open a ticket` if
you'd like something changed.
Compatibility
"""""""""""""
sphinx-better-theme is compatible with Sphinx 0.6.4+ and Jinja 2.3.1+. Older
versions may work but have not been tested.
Installation
^^^^^^^^^^^^
Method 1: Adding to your source tree
""""""""""""""""""""""""""""""""""""
This method is preferred due to the frequency with which sphinx-better-theme is
improved.
1. Put the theme in your source tree. If you use git, you can add
   ``sphinx-better-theme``'s repository as a submodule. Otherwise you can
   `download the zip file`_ and expand it somewhere predictable. Here's an
   example using git::
        > git submodule add \
            https://github.com/irskep/sphinx-better-theme.git \
            docs/sphinx-better-theme
        > git submodule update --init
2. Add the parent folder of the theme to your ``conf.py``. If you use the
   folder structure in the block above, you'd do it like this::
        html_theme_path = ['sphinx-better-theme']
   (because the theme path is ``sphinx-better-theme/better``.)
3. Set ``html_theme`` to ``'better'`` in your ``conf.py``.
Method 2: Installing to site-packages
"""""""""""""""""""""""""""""""""""""
If adding the theme to your source tree is impractical, if you need to share it
among several repositories, or if you prefer a more serene frequency of
updates, you can install it like a regular Python package.
`Download the zip file`_ and run the usual command::
    > python setup.py install
Or install from PyPI::
    > pip install sphinx-better-theme
To use the theme, set ``html_theme_path`` to contain
``better.better_theme_path``, and set ``html_theme`` to ``'better'``::
    from better import better_theme_path
    html_theme_path = [better_theme_path]
    html_theme = 'better'

%prep
%autosetup -n sphinx-better-theme-0.1.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sphinx-better-theme -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.5-1
- Package Spec generated