%global _empty_manifest_terminate_build 0
Name: python-conversation-analytics-toolkit
Version: 1.9.1
Release: 1
Summary: Dialog Flow Analysis Tool for Watson Assistant
License: Apache 2.0
URL: https://github.com/watson-developer-cloud/assistant-dialog-flow-analysis
Source0: https://mirrors.aliyun.com/pypi/web/packages/b8/43/18ba9e84285e121889dc6f31784cdad4d71d6d3ac8609e77043918db97ae/conversation_analytics_toolkit-1.9.1.tar.gz
BuildArch: noarch
Requires: python3-pandas
Requires: python3-nltk
Requires: python3-textblob
Requires: python3-scikit-learn
Requires: python3-tqdm
Requires: python3-ipywidgets
Requires: python3-ibm-watson
Requires: python3-plotly
Requires: python3-requests
%description
# Watson Assistant Dialog Flow Analysis
> Note: help us stay in touch and improve this notebook by clicking on the :star: star icon (top right).
This repository hosts the the Watson Assistant Dialog Flow Analysis Notebook and the underlying conversation analytics toolkit library.
Table of Contents
[Introduction](#introduction)
[Getting Started](#getting-started)
[Guides](#guides)
[Frequently Asked Questions](#frequently-asked-questions)
[License](#license)
[Contributing](#contributing)
## Introduction
The Watson Assistant Dialog Flow Analysis Notebook can help you assess and analyze user journeys and issues related to the dialog flow of ineffective (low quality) conversations based on production logs. The notebook can help you with questions such as:
- What are the common conversation steps and flows within the assistant
- Which flows have low task completion rates and high abandonment (ineffective conversations)
- Where along the dialog steps users lose engagement with your assistant
- What are common terms and steps that may lead to abandonment
This notebook extends the [Measure and Analyze notebooks](https://github.com/watson-developer-cloud/assistant-improve-recommendations-notebook) by providing additional capabilities to assess and analyze effectiveness - focused more on issues related to the dialog flow. For more details, check out [IBM Watson Assistant Continuous Improvement Best Practices](https://github.com/watson-developer-cloud/assistant-improve-recommendations-notebook/raw/master/notebook/IBM%20Watson%20Assistant%20Continuous%20Improvement%20Best%20Practices.pdf).
## Getting Started
The notebook requires a Jupyter Notebook environment and Python 3.6+. You can either install Jupyter Notebook to run locally or you can use Watson Studio on the cloud.
### Using Jupyter Notebook
1. Install Python 3.6+
2. Install Jupyter notebook. Checkout the [Jupyter/IPython Notebook Quick Start Guide](https://jupyter-notebook-beginner-guide.readthedocs.io/en/latest/install.html) for more details
3. Download the [notebooks/Dialog Flow Analysis Notebook.ipynb](https://github.com/watson-developer-cloud/assistant-dialog-flow-analysis/blob/master/notebooks/Dialog%20Flow%20Analysis%20Notebook.ipynb) file.
4. Start jupyter server `jupyter notebook`
5. Run the `Dialog Flow Analysis Notebook.ipynb`
### Using Watson Studio
1. In Watson Studio, select `Add to Project`-->`Notebook`. Choose `From URL` and paste this [url](https://raw.githubusercontent.com/watson-developer-cloud/assistant-dialog-flow-analysis/master/notebooks/Dialog%20Flow%20Analysis%20Notebook.ipynb). Alternately you can select `From file` and upload the `notebooks/Dialog Flow Analysis Notebook.ipynb` file.
Alternately, you can import and modify the [sample notebook on Watson Studio Gallery](https://dataplatform.cloud.ibm.com/exchange/public/entry/view/013c690997e27f3a8d9133265327a9e5?context=wdp).
## Guides
* Learn more about the Dialog Flow Analysis in this [blog](https://medium.com/ibm-watson/do-you-know-where-and-why-users-drop-off-the-conversation-6246e99baddc)
* See a live example output of the notebook on [Watson Studio Gallery](https://dataplatform.cloud.ibm.com/exchange/public/entry/view/013c690997e27f3a8d9133265327a9e5?context=wdp)
## Frequently Asked Questions
See [FAQ.md](FAQ.md) for frequently asked questions
## License
This library is licensed under the [Apache 2.0 license](http://www.apache.org/licenses/LICENSE-2.0).
## Contributing
See [CONTRIBUTING.md](CONTRIBUTING.md) and [DEVELOPER.MD](DEVELOPER.MD) for more details on how to contribute
## Contributor List
| | | | | |
:-------------------------:|:-------------------------:|:-------------------------:|:-------------------------:|:-------------------------:|
[Avi Yaeli](https://github.com/ayaeli) |
[Sergey Zeltyn](https://github.com/Sergey-Zeltyn) |
[Zhe Zhang](https://github.com/zzhang13) |
[Eric Wayne](https://github.com/eric-wayne) |
[David Boaz](https://github.com/boazdavid) |
%package -n python3-conversation-analytics-toolkit
Summary: Dialog Flow Analysis Tool for Watson Assistant
Provides: python-conversation-analytics-toolkit
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-conversation-analytics-toolkit
# Watson Assistant Dialog Flow Analysis
> Note: help us stay in touch and improve this notebook by clicking on the :star: star icon (top right).
This repository hosts the the Watson Assistant Dialog Flow Analysis Notebook and the underlying conversation analytics toolkit library.
Table of Contents
[Introduction](#introduction)
[Getting Started](#getting-started)
[Guides](#guides)
[Frequently Asked Questions](#frequently-asked-questions)
[License](#license)
[Contributing](#contributing)
## Introduction
The Watson Assistant Dialog Flow Analysis Notebook can help you assess and analyze user journeys and issues related to the dialog flow of ineffective (low quality) conversations based on production logs. The notebook can help you with questions such as:
- What are the common conversation steps and flows within the assistant
- Which flows have low task completion rates and high abandonment (ineffective conversations)
- Where along the dialog steps users lose engagement with your assistant
- What are common terms and steps that may lead to abandonment
This notebook extends the [Measure and Analyze notebooks](https://github.com/watson-developer-cloud/assistant-improve-recommendations-notebook) by providing additional capabilities to assess and analyze effectiveness - focused more on issues related to the dialog flow. For more details, check out [IBM Watson Assistant Continuous Improvement Best Practices](https://github.com/watson-developer-cloud/assistant-improve-recommendations-notebook/raw/master/notebook/IBM%20Watson%20Assistant%20Continuous%20Improvement%20Best%20Practices.pdf).
## Getting Started
The notebook requires a Jupyter Notebook environment and Python 3.6+. You can either install Jupyter Notebook to run locally or you can use Watson Studio on the cloud.
### Using Jupyter Notebook
1. Install Python 3.6+
2. Install Jupyter notebook. Checkout the [Jupyter/IPython Notebook Quick Start Guide](https://jupyter-notebook-beginner-guide.readthedocs.io/en/latest/install.html) for more details
3. Download the [notebooks/Dialog Flow Analysis Notebook.ipynb](https://github.com/watson-developer-cloud/assistant-dialog-flow-analysis/blob/master/notebooks/Dialog%20Flow%20Analysis%20Notebook.ipynb) file.
4. Start jupyter server `jupyter notebook`
5. Run the `Dialog Flow Analysis Notebook.ipynb`
### Using Watson Studio
1. In Watson Studio, select `Add to Project`-->`Notebook`. Choose `From URL` and paste this [url](https://raw.githubusercontent.com/watson-developer-cloud/assistant-dialog-flow-analysis/master/notebooks/Dialog%20Flow%20Analysis%20Notebook.ipynb). Alternately you can select `From file` and upload the `notebooks/Dialog Flow Analysis Notebook.ipynb` file.
Alternately, you can import and modify the [sample notebook on Watson Studio Gallery](https://dataplatform.cloud.ibm.com/exchange/public/entry/view/013c690997e27f3a8d9133265327a9e5?context=wdp).
## Guides
* Learn more about the Dialog Flow Analysis in this [blog](https://medium.com/ibm-watson/do-you-know-where-and-why-users-drop-off-the-conversation-6246e99baddc)
* See a live example output of the notebook on [Watson Studio Gallery](https://dataplatform.cloud.ibm.com/exchange/public/entry/view/013c690997e27f3a8d9133265327a9e5?context=wdp)
## Frequently Asked Questions
See [FAQ.md](FAQ.md) for frequently asked questions
## License
This library is licensed under the [Apache 2.0 license](http://www.apache.org/licenses/LICENSE-2.0).
## Contributing
See [CONTRIBUTING.md](CONTRIBUTING.md) and [DEVELOPER.MD](DEVELOPER.MD) for more details on how to contribute
## Contributor List
| | | | | |
:-------------------------:|:-------------------------:|:-------------------------:|:-------------------------:|:-------------------------:|
[Avi Yaeli](https://github.com/ayaeli) |
[Sergey Zeltyn](https://github.com/Sergey-Zeltyn) |
[Zhe Zhang](https://github.com/zzhang13) |
[Eric Wayne](https://github.com/eric-wayne) |
[David Boaz](https://github.com/boazdavid) |
%package help
Summary: Development documents and examples for conversation-analytics-toolkit
Provides: python3-conversation-analytics-toolkit-doc
%description help
# Watson Assistant Dialog Flow Analysis
> Note: help us stay in touch and improve this notebook by clicking on the :star: star icon (top right).
This repository hosts the the Watson Assistant Dialog Flow Analysis Notebook and the underlying conversation analytics toolkit library.
Table of Contents
[Introduction](#introduction)
[Getting Started](#getting-started)
[Guides](#guides)
[Frequently Asked Questions](#frequently-asked-questions)
[License](#license)
[Contributing](#contributing)
## Introduction
The Watson Assistant Dialog Flow Analysis Notebook can help you assess and analyze user journeys and issues related to the dialog flow of ineffective (low quality) conversations based on production logs. The notebook can help you with questions such as:
- What are the common conversation steps and flows within the assistant
- Which flows have low task completion rates and high abandonment (ineffective conversations)
- Where along the dialog steps users lose engagement with your assistant
- What are common terms and steps that may lead to abandonment
This notebook extends the [Measure and Analyze notebooks](https://github.com/watson-developer-cloud/assistant-improve-recommendations-notebook) by providing additional capabilities to assess and analyze effectiveness - focused more on issues related to the dialog flow. For more details, check out [IBM Watson Assistant Continuous Improvement Best Practices](https://github.com/watson-developer-cloud/assistant-improve-recommendations-notebook/raw/master/notebook/IBM%20Watson%20Assistant%20Continuous%20Improvement%20Best%20Practices.pdf).
## Getting Started
The notebook requires a Jupyter Notebook environment and Python 3.6+. You can either install Jupyter Notebook to run locally or you can use Watson Studio on the cloud.
### Using Jupyter Notebook
1. Install Python 3.6+
2. Install Jupyter notebook. Checkout the [Jupyter/IPython Notebook Quick Start Guide](https://jupyter-notebook-beginner-guide.readthedocs.io/en/latest/install.html) for more details
3. Download the [notebooks/Dialog Flow Analysis Notebook.ipynb](https://github.com/watson-developer-cloud/assistant-dialog-flow-analysis/blob/master/notebooks/Dialog%20Flow%20Analysis%20Notebook.ipynb) file.
4. Start jupyter server `jupyter notebook`
5. Run the `Dialog Flow Analysis Notebook.ipynb`
### Using Watson Studio
1. In Watson Studio, select `Add to Project`-->`Notebook`. Choose `From URL` and paste this [url](https://raw.githubusercontent.com/watson-developer-cloud/assistant-dialog-flow-analysis/master/notebooks/Dialog%20Flow%20Analysis%20Notebook.ipynb). Alternately you can select `From file` and upload the `notebooks/Dialog Flow Analysis Notebook.ipynb` file.
Alternately, you can import and modify the [sample notebook on Watson Studio Gallery](https://dataplatform.cloud.ibm.com/exchange/public/entry/view/013c690997e27f3a8d9133265327a9e5?context=wdp).
## Guides
* Learn more about the Dialog Flow Analysis in this [blog](https://medium.com/ibm-watson/do-you-know-where-and-why-users-drop-off-the-conversation-6246e99baddc)
* See a live example output of the notebook on [Watson Studio Gallery](https://dataplatform.cloud.ibm.com/exchange/public/entry/view/013c690997e27f3a8d9133265327a9e5?context=wdp)
## Frequently Asked Questions
See [FAQ.md](FAQ.md) for frequently asked questions
## License
This library is licensed under the [Apache 2.0 license](http://www.apache.org/licenses/LICENSE-2.0).
## Contributing
See [CONTRIBUTING.md](CONTRIBUTING.md) and [DEVELOPER.MD](DEVELOPER.MD) for more details on how to contribute
## Contributor List
| | | | | |
:-------------------------:|:-------------------------:|:-------------------------:|:-------------------------:|:-------------------------:|
[Avi Yaeli](https://github.com/ayaeli) |
[Sergey Zeltyn](https://github.com/Sergey-Zeltyn) |
[Zhe Zhang](https://github.com/zzhang13) |
[Eric Wayne](https://github.com/eric-wayne) |
[David Boaz](https://github.com/boazdavid) |
%prep
%autosetup -n conversation_analytics_toolkit-1.9.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-conversation-analytics-toolkit -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.9.1-1
- Package Spec generated