%global _empty_manifest_terminate_build 0
Name:		python-Flask-Ask
Version:	0.9.8
Release:	1
Summary:	Rapid Alexa Skills Kit Development for Amazon Echo Devices in Python
License:	Apache 2.0
URL:		https://github.com/johnwheeler/flask-ask
Source0:	https://mirrors.aliyun.com/pypi/web/packages/6a/f5/d4709ae94584a0b1541e9b52b2d25a8a1bdb6e2da9d6870f23fdd0523a30/Flask-Ask-0.9.8.tar.gz
BuildArch:	noarch


%description
Easy Alexa Skills Kit integration for Flask

%package -n python3-Flask-Ask
Summary:	Rapid Alexa Skills Kit Development for Amazon Echo Devices in Python
Provides:	python-Flask-Ask
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Flask-Ask
Easy Alexa Skills Kit integration for Flask

%package help
Summary:	Development documents and examples for Flask-Ask
Provides:	python3-Flask-Ask-doc
%description help
Easy Alexa Skills Kit integration for Flask

%prep
%autosetup -n Flask-Ask-0.9.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Flask-Ask -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.8-1
- Package Spec generated