%global _empty_manifest_terminate_build 0
Name:		python-Rabbyt
Version:	0.8.3
Release:	1
Summary:	A fast 2D sprite engine using OpenGL
License:	MIT
URL:		http://matthewmarshall.org/projects/rabbyt/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/a6/27/3e708b61fcf9714f092ae4b894e2f7b25ee558f06b1ac2ad06cf0a4080d6/Rabbyt-0.8.3.zip
BuildArch:	noarch


%description
* Fixed Sprite.left (etc.) incorrectly applying independant axis scaling to
  absolute coords instead of rotated relative to the sprite.
* Sprite.bounding_radius now reflects Sprite.scale.  (previously ignored.)
* Fixed a segfault when anims have circular dependencies.
* Optimized ``swizzle``.
* Fixed ``aabb_collide()`` not always reporting immediately overlapping rects.
* Fixed a memory leak caused by an extra underscore at the end of ``__dealloc___``

%package -n python3-Rabbyt
Summary:	A fast 2D sprite engine using OpenGL
Provides:	python-Rabbyt
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Rabbyt
* Fixed Sprite.left (etc.) incorrectly applying independant axis scaling to
  absolute coords instead of rotated relative to the sprite.
* Sprite.bounding_radius now reflects Sprite.scale.  (previously ignored.)
* Fixed a segfault when anims have circular dependencies.
* Optimized ``swizzle``.
* Fixed ``aabb_collide()`` not always reporting immediately overlapping rects.
* Fixed a memory leak caused by an extra underscore at the end of ``__dealloc___``

%package help
Summary:	Development documents and examples for Rabbyt
Provides:	python3-Rabbyt-doc
%description help
* Fixed Sprite.left (etc.) incorrectly applying independant axis scaling to
  absolute coords instead of rotated relative to the sprite.
* Sprite.bounding_radius now reflects Sprite.scale.  (previously ignored.)
* Fixed a segfault when anims have circular dependencies.
* Optimized ``swizzle``.
* Fixed ``aabb_collide()`` not always reporting immediately overlapping rects.
* Fixed a memory leak caused by an extra underscore at the end of ``__dealloc___``

%prep
%autosetup -n Rabbyt-0.8.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Rabbyt -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.3-1
- Package Spec generated