%global _empty_manifest_terminate_build 0 Name: python-django-bakery Version: 0.13.2 Release: 1 Summary: A set of helpers for baking your Django site out as flat files License: MIT URL: http://www.github.com/palewire/django-bakery/ Source0: https://mirrors.aliyun.com/pypi/web/packages/86/7b/5270a130e8a6a4e20e0159dab7b67ca73a01a424c969510684fcc82ccc25/django-bakery-0.13.2.tar.gz BuildArch: noarch Requires: python3-six Requires: python3-boto3 Requires: python3-fs %description
                   
                # # # # #
              __#_#_#_#_#__
             {_` ` ` ` ` `_}
            _{_._._._._._._}_
           {_  D J A N G O  _}
          _{_._._._._._._._._}_
         {_    B A K E R Y    _}
     .---{_._._._._._._._._._._}---.
    (   `"""""""""""""""""""""""`   )
     `~~~~~~~~~~~~~~~~~~~~~~~~~~~~~`
A set of helpers for baking your Django site out as flat files * Documentation: [palewi.re/docs/django-bakery](https://palewi.re/docs/django-bakery/) * Issues: [https://github.com/datadesk/django-bakery/issues](https://github.com/datadesk/django-bakery/issues) * Packaging: [https://pypi.python.org/pypi/django-bakery](https://pypi.python.org/pypi/django-bakery) * The dream, in Powerpoint form: [palewi.re/docs/django-bakery/_static/the-dream.pdf](https://palewi.re/docs/django-bakery/_static/the-dream.pdf) ## Features * Models, views and management commands that will build your site as flat files. * Management commands to sync your flat files with a bucket on Amazon S3. * Optional integration of a Celery job queue to automatically build and publish model objects when they are saved %package -n python3-django-bakery Summary: A set of helpers for baking your Django site out as flat files Provides: python-django-bakery BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-django-bakery
                   
                # # # # #
              __#_#_#_#_#__
             {_` ` ` ` ` `_}
            _{_._._._._._._}_
           {_  D J A N G O  _}
          _{_._._._._._._._._}_
         {_    B A K E R Y    _}
     .---{_._._._._._._._._._._}---.
    (   `"""""""""""""""""""""""`   )
     `~~~~~~~~~~~~~~~~~~~~~~~~~~~~~`
A set of helpers for baking your Django site out as flat files * Documentation: [palewi.re/docs/django-bakery](https://palewi.re/docs/django-bakery/) * Issues: [https://github.com/datadesk/django-bakery/issues](https://github.com/datadesk/django-bakery/issues) * Packaging: [https://pypi.python.org/pypi/django-bakery](https://pypi.python.org/pypi/django-bakery) * The dream, in Powerpoint form: [palewi.re/docs/django-bakery/_static/the-dream.pdf](https://palewi.re/docs/django-bakery/_static/the-dream.pdf) ## Features * Models, views and management commands that will build your site as flat files. * Management commands to sync your flat files with a bucket on Amazon S3. * Optional integration of a Celery job queue to automatically build and publish model objects when they are saved %package help Summary: Development documents and examples for django-bakery Provides: python3-django-bakery-doc %description help
                   
                # # # # #
              __#_#_#_#_#__
             {_` ` ` ` ` `_}
            _{_._._._._._._}_
           {_  D J A N G O  _}
          _{_._._._._._._._._}_
         {_    B A K E R Y    _}
     .---{_._._._._._._._._._._}---.
    (   `"""""""""""""""""""""""`   )
     `~~~~~~~~~~~~~~~~~~~~~~~~~~~~~`
A set of helpers for baking your Django site out as flat files * Documentation: [palewi.re/docs/django-bakery](https://palewi.re/docs/django-bakery/) * Issues: [https://github.com/datadesk/django-bakery/issues](https://github.com/datadesk/django-bakery/issues) * Packaging: [https://pypi.python.org/pypi/django-bakery](https://pypi.python.org/pypi/django-bakery) * The dream, in Powerpoint form: [palewi.re/docs/django-bakery/_static/the-dream.pdf](https://palewi.re/docs/django-bakery/_static/the-dream.pdf) ## Features * Models, views and management commands that will build your site as flat files. * Management commands to sync your flat files with a bucket on Amazon S3. * Optional integration of a Celery job queue to automatically build and publish model objects when they are saved %prep %autosetup -n django-bakery-0.13.2 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-django-bakery -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Thu Jun 08 2023 Python_Bot - 0.13.2-1 - Package Spec generated