%global _empty_manifest_terminate_build 0
Name:		python-oidcmsg
Version:	1.6.0
Release:	1
Summary:	Python implementation of OAuth2 and OpenID Connect messages
License:	Apache 2.0
URL:		https://github.com/IdentityPython/oidcmsg/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/af/c9/fa43d097c3952b835649b32f908c23d2147327916d5d9e5dba1b39452956/oidcmsg-1.6.0.tar.gz
BuildArch:	noarch

Requires:	python3-cryptojwt
Requires:	python3-pyOpenSSL
Requires:	python3-filelock
Requires:	python3-pyyaml

%description
# oidcmsg

![CI build](https://github.com/IdentityPython/oidcmsg/workflows/oidcmsg/badge.svg)
![pypi](https://img.shields.io/pypi/v/oidcmsg.svg)
[![Downloads](https://pepy.tech/badge/oidcmsg)](https://pepy.tech/project/oidcmsg)
[![Downloads](https://pepy.tech/badge/oidcmsg/week)](https://pepy.tech/project/oidcmsg)
![License](https://img.shields.io/badge/license-Apache%202-blue.svg)

Implementation of OIDC protocol messages.

oidcmsg is the 2nd layer in the
JwtConnect stack (cryptojwt, oidcmsg, oidcservice, oidcrp)

Handles serialising into a couple of formats (jwt, json, urlencoded and dict) and deserialising from said formats.

It also does verification of messages , that is :

+ verifies that all the required parameters are present and has a value
+ verifies that the parameter values are of the right type
+ verifies that if there is a list of permitted values, a parameter value is on
that list.

and finally if the value is a signed and/or encrypted JWT this package
will perform the necessary decryption and signature verification.


Also implements a **KeyJar** which keeps keys belonging to
different owners. One owner may have many keys.
If some of these keys have a common origin, like described in a JWKS.
Such a set will be kept in a **keyBundle**.
Also implemented in this package.

Please read the [Official Documentation](https://oidcmsg.readthedocs.io/) for getting usage examples and further informations.




%package -n python3-oidcmsg
Summary:	Python implementation of OAuth2 and OpenID Connect messages
Provides:	python-oidcmsg
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-oidcmsg
# oidcmsg

![CI build](https://github.com/IdentityPython/oidcmsg/workflows/oidcmsg/badge.svg)
![pypi](https://img.shields.io/pypi/v/oidcmsg.svg)
[![Downloads](https://pepy.tech/badge/oidcmsg)](https://pepy.tech/project/oidcmsg)
[![Downloads](https://pepy.tech/badge/oidcmsg/week)](https://pepy.tech/project/oidcmsg)
![License](https://img.shields.io/badge/license-Apache%202-blue.svg)

Implementation of OIDC protocol messages.

oidcmsg is the 2nd layer in the
JwtConnect stack (cryptojwt, oidcmsg, oidcservice, oidcrp)

Handles serialising into a couple of formats (jwt, json, urlencoded and dict) and deserialising from said formats.

It also does verification of messages , that is :

+ verifies that all the required parameters are present and has a value
+ verifies that the parameter values are of the right type
+ verifies that if there is a list of permitted values, a parameter value is on
that list.

and finally if the value is a signed and/or encrypted JWT this package
will perform the necessary decryption and signature verification.


Also implements a **KeyJar** which keeps keys belonging to
different owners. One owner may have many keys.
If some of these keys have a common origin, like described in a JWKS.
Such a set will be kept in a **keyBundle**.
Also implemented in this package.

Please read the [Official Documentation](https://oidcmsg.readthedocs.io/) for getting usage examples and further informations.




%package help
Summary:	Development documents and examples for oidcmsg
Provides:	python3-oidcmsg-doc
%description help
# oidcmsg

![CI build](https://github.com/IdentityPython/oidcmsg/workflows/oidcmsg/badge.svg)
![pypi](https://img.shields.io/pypi/v/oidcmsg.svg)
[![Downloads](https://pepy.tech/badge/oidcmsg)](https://pepy.tech/project/oidcmsg)
[![Downloads](https://pepy.tech/badge/oidcmsg/week)](https://pepy.tech/project/oidcmsg)
![License](https://img.shields.io/badge/license-Apache%202-blue.svg)

Implementation of OIDC protocol messages.

oidcmsg is the 2nd layer in the
JwtConnect stack (cryptojwt, oidcmsg, oidcservice, oidcrp)

Handles serialising into a couple of formats (jwt, json, urlencoded and dict) and deserialising from said formats.

It also does verification of messages , that is :

+ verifies that all the required parameters are present and has a value
+ verifies that the parameter values are of the right type
+ verifies that if there is a list of permitted values, a parameter value is on
that list.

and finally if the value is a signed and/or encrypted JWT this package
will perform the necessary decryption and signature verification.


Also implements a **KeyJar** which keeps keys belonging to
different owners. One owner may have many keys.
If some of these keys have a common origin, like described in a JWKS.
Such a set will be kept in a **keyBundle**.
Also implemented in this package.

Please read the [Official Documentation](https://oidcmsg.readthedocs.io/) for getting usage examples and further informations.




%prep
%autosetup -n oidcmsg-1.6.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-oidcmsg -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.0-1
- Package Spec generated