%global _empty_manifest_terminate_build 0
Name:		python-PySDDP
Version:	0.0.39
Release:	1
Summary:	PySDDP package
License:	MIT
URL:		https://github.com/AndreMarcato/PySDDP
Source0:	https://mirrors.aliyun.com/pypi/web/packages/6a/0d/352a005883d337ec5a3709227625525a0cd81b9912e03c551de2e469b283/PySDDP-0.0.39.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-matplotlib
Requires:	python3-cvxopt
Requires:	python3-pyswarm
Requires:	python3-scipy
Requires:	python3-typing
Requires:	python3-pandas

%description
PySDDP
###################
Python package applied to the planning of the operation of energy systems in the medium term horizon. This package also has classes applied to rain-to-flow

USAGE
###################

from PySDDP import sistema

EXAMPLE
###################

from PySDDP import sistema

q = sistema.PySDDP('pmo/')

Classroom
###################
from PySDDP import sistema

q = sistema.Classroom()

q.sistema["DGer"]["Nr_Disc"] = 41

resultado_pdd41 = q.pdd(0, imprime=False)

resultado_plu = q.pl_unico(0, imprime=False)

resultado_pddd = q.pddd(0, imprime=False)




%package -n python3-PySDDP
Summary:	PySDDP package
Provides:	python-PySDDP
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-PySDDP
PySDDP
###################
Python package applied to the planning of the operation of energy systems in the medium term horizon. This package also has classes applied to rain-to-flow

USAGE
###################

from PySDDP import sistema

EXAMPLE
###################

from PySDDP import sistema

q = sistema.PySDDP('pmo/')

Classroom
###################
from PySDDP import sistema

q = sistema.Classroom()

q.sistema["DGer"]["Nr_Disc"] = 41

resultado_pdd41 = q.pdd(0, imprime=False)

resultado_plu = q.pl_unico(0, imprime=False)

resultado_pddd = q.pddd(0, imprime=False)




%package help
Summary:	Development documents and examples for PySDDP
Provides:	python3-PySDDP-doc
%description help
PySDDP
###################
Python package applied to the planning of the operation of energy systems in the medium term horizon. This package also has classes applied to rain-to-flow

USAGE
###################

from PySDDP import sistema

EXAMPLE
###################

from PySDDP import sistema

q = sistema.PySDDP('pmo/')

Classroom
###################
from PySDDP import sistema

q = sistema.Classroom()

q.sistema["DGer"]["Nr_Disc"] = 41

resultado_pdd41 = q.pdd(0, imprime=False)

resultado_plu = q.pl_unico(0, imprime=False)

resultado_pddd = q.pddd(0, imprime=False)




%prep
%autosetup -n PySDDP-0.0.39

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-PySDDP -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.39-1
- Package Spec generated