%global _empty_manifest_terminate_build 0
Name:		python-pydoods
Version:	1.0.2
Release:	1
Summary:	A Python wrapper for the DOODS image detection service
License:	MIT License
URL:		https://github.com/snowzach/pydoods
Source0:	https://mirrors.aliyun.com/pypi/web/packages/ea/8a/67138b6194ec75dade4eab6e3d29372395cdf0d9d7804040f73522d3775b/pydoods-1.0.2.tar.gz
BuildArch:	noarch


%description
# PyDOODS - Python for Distributed Open Object Detection Service

This is a simple Python wrapper for the [DOODS](https://github.com/snowzach/doods) service. 
DOODS allows you to do remote object detection in images easily. 

A simple example using this library:

```
import PyDOODS from pydoods

try:
    pd = PyDOODS("http://docker:8080",
                    auth_key="abc1234", timeout=90)
except OSError as err:
    print("OS error: {0}".format(err))
    exit
image = open("grace_hopper.png", "rb").read()
print(pd.detect(image))
```




%package -n python3-pydoods
Summary:	A Python wrapper for the DOODS image detection service
Provides:	python-pydoods
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pydoods
# PyDOODS - Python for Distributed Open Object Detection Service

This is a simple Python wrapper for the [DOODS](https://github.com/snowzach/doods) service. 
DOODS allows you to do remote object detection in images easily. 

A simple example using this library:

```
import PyDOODS from pydoods

try:
    pd = PyDOODS("http://docker:8080",
                    auth_key="abc1234", timeout=90)
except OSError as err:
    print("OS error: {0}".format(err))
    exit
image = open("grace_hopper.png", "rb").read()
print(pd.detect(image))
```




%package help
Summary:	Development documents and examples for pydoods
Provides:	python3-pydoods-doc
%description help
# PyDOODS - Python for Distributed Open Object Detection Service

This is a simple Python wrapper for the [DOODS](https://github.com/snowzach/doods) service. 
DOODS allows you to do remote object detection in images easily. 

A simple example using this library:

```
import PyDOODS from pydoods

try:
    pd = PyDOODS("http://docker:8080",
                    auth_key="abc1234", timeout=90)
except OSError as err:
    print("OS error: {0}".format(err))
    exit
image = open("grace_hopper.png", "rb").read()
print(pd.detect(image))
```




%prep
%autosetup -n pydoods-1.0.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pydoods -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.2-1
- Package Spec generated