%global _empty_manifest_terminate_build 0
Name: python-agnpy
Version: 0.4.0
Release: 1
Summary: Modelling jetted Active Galactic Nuclei radiative processes with python
License: BSD License
URL: https://github.com/cosimoNigro/agnpy
Source0: https://mirrors.aliyun.com/pypi/web/packages/c8/ed/3cbc741a0329dc7c1f730e67c7f8632debc3146ac668f51763b12fc94b63/agnpy-0.4.0.tar.gz
BuildArch: noarch
Requires: python3-astropy
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-matplotlib
%description
# agnpy
Modelling Active Galactic Nuclei radiative processes with python.
[![astropy](http://img.shields.io/badge/powered%20by-AstroPy-orange.svg?style=flat)](http://www.astropy.org/)
## descritpion
`agnpy` focuses on the numerical computation of the photon spectra produced by leptonic radiative processes in jetted Active Galactic Nuclei (AGN).
## agnpy binder
Run this repository in binder
[![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/cosimoNigro/agnpy/HEAD)
## acknowledging and citing agnpy
As a general acknowledgement of `agnpy` usage, we recommend citing the agnpy release paper.
Additionaly, to specify which version of `agnpy` is being used, that version's zenodo record can be cited.
We recommend citing both.
At the following links you can find:
* [the agnpy release paper (for a general citation)](https://ui.adsabs.harvard.edu/abs/2022A%26A...660A..18N/abstract);
* the zenodo record (for citing a specific version) [![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.4055175.svg)](https://doi.org/10.5281/zenodo.4055175)
## documentation and quickstart
You are invited to check the documentation at https://agnpy.readthedocs.io/en/latest/.
To get familiar with the code you can run the notebooks in the `tutorials` section
of the documentation.
## dependencies
The only dependencies are:
* [numpy](https://numpy.org) managing the numerical computation;
* [astropy](https://www.astropy.org) managing physical units and astronomical distances.
* [matplotlib](https://matplotlib.org) for visualisation and reproduction of the tutorials.
* [scipy](https://www.scipy.org/) for interpolation
## installation
The code is available in the [python package index](https://pypi.org/project/agnpy/) and can be installed via `pip`
```bash
pip install agnpy
```
The code can also be installed using `conda`
```bash
conda install -c conda-forge agnpy
```
## tests
A test suite is available in [`agnpy/tests`](https://github.com/cosimoNigro/agnpy/tree/master/agnpy/tests), to run it just type
`pytest` in the main directory.
## shields
[![CI test](https://github.com/cosimoNigro/agnpy/actions/workflows/test.yml/badge.svg)](https://github.com/cosimoNigro/agnpy/actions/workflows/test.yml)
[![Upload to PIP](https://github.com/cosimoNigro/agnpy/actions/workflows/pip-upload.yml/badge.svg)](https://github.com/cosimoNigro/agnpy/actions/workflows/pip-upload.yml)
[![Documentation Status](https://readthedocs.org/projects/agnpy/badge/?version=latest)](https://agnpy.readthedocs.io/en/latest/?badge=latest)
![](https://codecov.io/gh/cosimoNigro/agnpy/branch/master/graph/badge.svg)
![](http://img.shields.io/pypi/v/agnpy.svg?text=version)
%package -n python3-agnpy
Summary: Modelling jetted Active Galactic Nuclei radiative processes with python
Provides: python-agnpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-agnpy
# agnpy
Modelling Active Galactic Nuclei radiative processes with python.
[![astropy](http://img.shields.io/badge/powered%20by-AstroPy-orange.svg?style=flat)](http://www.astropy.org/)
## descritpion
`agnpy` focuses on the numerical computation of the photon spectra produced by leptonic radiative processes in jetted Active Galactic Nuclei (AGN).
## agnpy binder
Run this repository in binder
[![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/cosimoNigro/agnpy/HEAD)
## acknowledging and citing agnpy
As a general acknowledgement of `agnpy` usage, we recommend citing the agnpy release paper.
Additionaly, to specify which version of `agnpy` is being used, that version's zenodo record can be cited.
We recommend citing both.
At the following links you can find:
* [the agnpy release paper (for a general citation)](https://ui.adsabs.harvard.edu/abs/2022A%26A...660A..18N/abstract);
* the zenodo record (for citing a specific version) [![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.4055175.svg)](https://doi.org/10.5281/zenodo.4055175)
## documentation and quickstart
You are invited to check the documentation at https://agnpy.readthedocs.io/en/latest/.
To get familiar with the code you can run the notebooks in the `tutorials` section
of the documentation.
## dependencies
The only dependencies are:
* [numpy](https://numpy.org) managing the numerical computation;
* [astropy](https://www.astropy.org) managing physical units and astronomical distances.
* [matplotlib](https://matplotlib.org) for visualisation and reproduction of the tutorials.
* [scipy](https://www.scipy.org/) for interpolation
## installation
The code is available in the [python package index](https://pypi.org/project/agnpy/) and can be installed via `pip`
```bash
pip install agnpy
```
The code can also be installed using `conda`
```bash
conda install -c conda-forge agnpy
```
## tests
A test suite is available in [`agnpy/tests`](https://github.com/cosimoNigro/agnpy/tree/master/agnpy/tests), to run it just type
`pytest` in the main directory.
## shields
[![CI test](https://github.com/cosimoNigro/agnpy/actions/workflows/test.yml/badge.svg)](https://github.com/cosimoNigro/agnpy/actions/workflows/test.yml)
[![Upload to PIP](https://github.com/cosimoNigro/agnpy/actions/workflows/pip-upload.yml/badge.svg)](https://github.com/cosimoNigro/agnpy/actions/workflows/pip-upload.yml)
[![Documentation Status](https://readthedocs.org/projects/agnpy/badge/?version=latest)](https://agnpy.readthedocs.io/en/latest/?badge=latest)
![](https://codecov.io/gh/cosimoNigro/agnpy/branch/master/graph/badge.svg)
![](http://img.shields.io/pypi/v/agnpy.svg?text=version)
%package help
Summary: Development documents and examples for agnpy
Provides: python3-agnpy-doc
%description help
# agnpy
Modelling Active Galactic Nuclei radiative processes with python.
[![astropy](http://img.shields.io/badge/powered%20by-AstroPy-orange.svg?style=flat)](http://www.astropy.org/)
## descritpion
`agnpy` focuses on the numerical computation of the photon spectra produced by leptonic radiative processes in jetted Active Galactic Nuclei (AGN).
## agnpy binder
Run this repository in binder
[![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/cosimoNigro/agnpy/HEAD)
## acknowledging and citing agnpy
As a general acknowledgement of `agnpy` usage, we recommend citing the agnpy release paper.
Additionaly, to specify which version of `agnpy` is being used, that version's zenodo record can be cited.
We recommend citing both.
At the following links you can find:
* [the agnpy release paper (for a general citation)](https://ui.adsabs.harvard.edu/abs/2022A%26A...660A..18N/abstract);
* the zenodo record (for citing a specific version) [![DOI](https://zenodo.org/badge/DOI/10.5281/zenodo.4055175.svg)](https://doi.org/10.5281/zenodo.4055175)
## documentation and quickstart
You are invited to check the documentation at https://agnpy.readthedocs.io/en/latest/.
To get familiar with the code you can run the notebooks in the `tutorials` section
of the documentation.
## dependencies
The only dependencies are:
* [numpy](https://numpy.org) managing the numerical computation;
* [astropy](https://www.astropy.org) managing physical units and astronomical distances.
* [matplotlib](https://matplotlib.org) for visualisation and reproduction of the tutorials.
* [scipy](https://www.scipy.org/) for interpolation
## installation
The code is available in the [python package index](https://pypi.org/project/agnpy/) and can be installed via `pip`
```bash
pip install agnpy
```
The code can also be installed using `conda`
```bash
conda install -c conda-forge agnpy
```
## tests
A test suite is available in [`agnpy/tests`](https://github.com/cosimoNigro/agnpy/tree/master/agnpy/tests), to run it just type
`pytest` in the main directory.
## shields
[![CI test](https://github.com/cosimoNigro/agnpy/actions/workflows/test.yml/badge.svg)](https://github.com/cosimoNigro/agnpy/actions/workflows/test.yml)
[![Upload to PIP](https://github.com/cosimoNigro/agnpy/actions/workflows/pip-upload.yml/badge.svg)](https://github.com/cosimoNigro/agnpy/actions/workflows/pip-upload.yml)
[![Documentation Status](https://readthedocs.org/projects/agnpy/badge/?version=latest)](https://agnpy.readthedocs.io/en/latest/?badge=latest)
![](https://codecov.io/gh/cosimoNigro/agnpy/branch/master/graph/badge.svg)
![](http://img.shields.io/pypi/v/agnpy.svg?text=version)
%prep
%autosetup -n agnpy-0.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-agnpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.4.0-1
- Package Spec generated