%global _empty_manifest_terminate_build 0
Name:		python-ACMPlus
Version:	0.0.3
Release:	1
Summary:	Read, save and send by Mqtt data from FSI ACM-Plus
License:	MIT
URL:		http://git.redmic.net/oag/buoy
Source0:	https://mirrors.aliyun.com/pypi/web/packages/69/02/c19a12a8397a788bb1a869f4c7b4f7fdfa6f7e165b08890b88b17dcbbc67/ACMPlus-0.0.3.tar.gz
BuildArch:	noarch

Requires:	python3-pynmea2
Requires:	python3-Buoy-Base
Requires:	python3-check-manifest
Requires:	python3-coverage

%description
Read, save and send by Mqtt data from FSI ACM-Plus




%package -n python3-ACMPlus
Summary:	Read, save and send by Mqtt data from FSI ACM-Plus
Provides:	python-ACMPlus
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ACMPlus
Read, save and send by Mqtt data from FSI ACM-Plus




%package help
Summary:	Development documents and examples for ACMPlus
Provides:	python3-ACMPlus-doc
%description help
Read, save and send by Mqtt data from FSI ACM-Plus




%prep
%autosetup -n ACMPlus-0.0.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ACMPlus -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.3-1
- Package Spec generated