%global _empty_manifest_terminate_build 0 Name: python-drfpasswordless Version: 1.5.8 Release: 1 Summary: Passwordless auth for Django Rest Framework Token Authentication. License: MIT URL: https://github.com/aaronn/django-rest-framework-passwordless Source0: https://mirrors.aliyun.com/pypi/web/packages/3d/7b/06346d046ac6d7a6fbf3c5f8c4eff42803a0b735e792eabcac6ef9d69aa5/drfpasswordless-1.5.8.tar.gz BuildArch: noarch Requires: python3-Django Requires: python3-djangorestframework %description ```bash curl -X POST -d “email=aaron@email.com” localhost:8000/auth/email/ ``` Email to aaron@email.com: ```

Your login token is 815381.

``` Return Stage ```bash curl -X POST -d "email=aaron@example.com&token=815381" localhost:8000/auth/token/ > HTTP/1.0 200 OK > {"token":"76be2d9ecfaf5fa4226d722bzdd8a4fff207ed0e”} ``` %package -n python3-drfpasswordless Summary: Passwordless auth for Django Rest Framework Token Authentication. Provides: python-drfpasswordless BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-drfpasswordless ```bash curl -X POST -d “email=aaron@email.com” localhost:8000/auth/email/ ``` Email to aaron@email.com: ```

Your login token is 815381.

``` Return Stage ```bash curl -X POST -d "email=aaron@example.com&token=815381" localhost:8000/auth/token/ > HTTP/1.0 200 OK > {"token":"76be2d9ecfaf5fa4226d722bzdd8a4fff207ed0e”} ``` %package help Summary: Development documents and examples for drfpasswordless Provides: python3-drfpasswordless-doc %description help ```bash curl -X POST -d “email=aaron@email.com” localhost:8000/auth/email/ ``` Email to aaron@email.com: ```

Your login token is 815381.

``` Return Stage ```bash curl -X POST -d "email=aaron@example.com&token=815381" localhost:8000/auth/token/ > HTTP/1.0 200 OK > {"token":"76be2d9ecfaf5fa4226d722bzdd8a4fff207ed0e”} ``` %prep %autosetup -n drfpasswordless-1.5.8 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-drfpasswordless -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Thu Jun 08 2023 Python_Bot - 1.5.8-1 - Package Spec generated