%global _empty_manifest_terminate_build 0
Name:		python-acumos
Version:	1.0.1
Release:	1
Summary:	Acumos client library for building and pushing Python models
License:	Apache License 2.0
URL:		https://gerrit.acumos.org/r/gitweb?p=acumos-python-client.git
Source0:	https://mirrors.aliyun.com/pypi/web/packages/25/d3/6832f4456acebfb59e92cee4990f572e423bd23f67457aefea77cc516668/acumos-1.0.1.tar.gz
BuildArch:	noarch

Requires:	python3-protobuf
Requires:	python3-requests
Requires:	python3-numpy
Requires:	python3-dill
Requires:	python3-appdirs
Requires:	python3-filelock
Requires:	python3-grpcio
Requires:	python3-zipp
Requires:	python3-typing-inspect

%description


%package -n python3-acumos
Summary:	Acumos client library for building and pushing Python models
Provides:	python-acumos
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-acumos


%package help
Summary:	Development documents and examples for acumos
Provides:	python3-acumos-doc
%description help


%prep
%autosetup -n acumos-1.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-acumos -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1-1
- Package Spec generated