%global _empty_manifest_terminate_build 0
Name:		python-funing
Version:	0.2.65
Release:	1
Summary:	A face recognition gui
License:	MIT License
URL:		https://github.com/larryw3i/Funing
Source0:	https://mirrors.aliyun.com/pypi/web/packages/b5/2d/8298a6ebd43abd00c0826a44e83643f29616941af0fbcee156c05c3580d2/funing-0.2.65.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-Pillow
Requires:	python3-appdirs
Requires:	python3-pygubu
Requires:	python3-isort

%description
# Funing  
A **simple** face recognition GUI, try it just enter:  
```bash
pip3 install funing; funing
```



%package -n python3-funing
Summary:	A face recognition gui
Provides:	python-funing
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-funing
# Funing  
A **simple** face recognition GUI, try it just enter:  
```bash
pip3 install funing; funing
```



%package help
Summary:	Development documents and examples for funing
Provides:	python3-funing-doc
%description help
# Funing  
A **simple** face recognition GUI, try it just enter:  
```bash
pip3 install funing; funing
```



%prep
%autosetup -n funing-0.2.65

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-funing -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.65-1
- Package Spec generated