%global _empty_manifest_terminate_build 0
Name: python-clkhash
Version: 0.18.3
Release: 1
Summary: Encoding utility to create Cryptographic Linkage Keys
License: Apache
URL: https://github.com/data61/clkhash
Source0: https://mirrors.aliyun.com/pypi/web/packages/9e/8e/771093c8c2621a3e368e0761044df71c9a4c6841eef8f7f8537aa2565526/clkhash-0.18.3.tar.gz
BuildArch: noarch
Requires: python3-bitarray
Requires: python3-cryptography
Requires: python3-jsonschema
Requires: python3-mypy_extensions
Requires: python3-pyblake2
Requires: python3-tqdm
%description
# CLK Hash
[![codecov](https://codecov.io/gh/data61/clkhash/branch/main/graph/badge.svg)](https://codecov.io/gh/data61/clkhash)
[![Documentation Status](https://readthedocs.org/projects/clkhash/badge/?version=latest)](http://clkhash.readthedocs.io/en/latest/?badge=latest)
[![Unit Testing](https://github.com/data61/clkhash/actions/workflows/unittests.yml/badge.svg)](https://github.com/data61/clkhash/actions/workflows/unittests.yml)
[![Typechecking](https://github.com/data61/clkhash/actions/workflows/typechecking.yml/badge.svg)](https://github.com/data61/clkhash/actions/workflows/typechecking.yml)
[![Downloads](https://pepy.tech/badge/clkhash)](https://pepy.tech/project/clkhash)
**clkhash** is a Python implementation of cryptographic linkage key hashing as described by _Rainer Schnell, Tobias Bachteler, and Jörg Reiher_ in
[A Novel Error-Tolerant Anonymous Linking Code](https://papers.ssrn.com/sol3/papers.cfm?abstract_id=3549247).
## Installation
Install clkhash with all dependencies using pip:
pip install clkhash
## Documentation
[https://clkhash.readthedocs.io](https://clkhash.readthedocs.io/en/latest/)
## Python API
To hash a CSV file of entities using the default schema:
```python
from clkhash import clk, randomnames
fake_pii_schema = randomnames.NameList.SCHEMA
clks = clk.generate_clk_from_csv(open('fake-pii-out.csv','r'), 'secret', fake_pii_schema)
```
## Command Line Interface
See [Anonlink Client](https://github.com/data61/anonlink-client) for a command line interface to clkhash.
## Citing
Clkhash, and the wider Anonlink project is designed, developed and supported by
[CSIRO's Data61](https://www.data61.csiro.au). If you use any part of this library in your research, please
cite it using the following BibTex entry::
@misc{Anonlink,
author = {CSIRO's Data61},
title = {Anonlink Private Record Linkage System},
year = {2017},
publisher = {GitHub},
journal = {GitHub Repository},
howpublished = {\url{https://github.com/data61/clkhash}},
}
%package -n python3-clkhash
Summary: Encoding utility to create Cryptographic Linkage Keys
Provides: python-clkhash
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-clkhash
# CLK Hash
[![codecov](https://codecov.io/gh/data61/clkhash/branch/main/graph/badge.svg)](https://codecov.io/gh/data61/clkhash)
[![Documentation Status](https://readthedocs.org/projects/clkhash/badge/?version=latest)](http://clkhash.readthedocs.io/en/latest/?badge=latest)
[![Unit Testing](https://github.com/data61/clkhash/actions/workflows/unittests.yml/badge.svg)](https://github.com/data61/clkhash/actions/workflows/unittests.yml)
[![Typechecking](https://github.com/data61/clkhash/actions/workflows/typechecking.yml/badge.svg)](https://github.com/data61/clkhash/actions/workflows/typechecking.yml)
[![Downloads](https://pepy.tech/badge/clkhash)](https://pepy.tech/project/clkhash)
**clkhash** is a Python implementation of cryptographic linkage key hashing as described by _Rainer Schnell, Tobias Bachteler, and Jörg Reiher_ in
[A Novel Error-Tolerant Anonymous Linking Code](https://papers.ssrn.com/sol3/papers.cfm?abstract_id=3549247).
## Installation
Install clkhash with all dependencies using pip:
pip install clkhash
## Documentation
[https://clkhash.readthedocs.io](https://clkhash.readthedocs.io/en/latest/)
## Python API
To hash a CSV file of entities using the default schema:
```python
from clkhash import clk, randomnames
fake_pii_schema = randomnames.NameList.SCHEMA
clks = clk.generate_clk_from_csv(open('fake-pii-out.csv','r'), 'secret', fake_pii_schema)
```
## Command Line Interface
See [Anonlink Client](https://github.com/data61/anonlink-client) for a command line interface to clkhash.
## Citing
Clkhash, and the wider Anonlink project is designed, developed and supported by
[CSIRO's Data61](https://www.data61.csiro.au). If you use any part of this library in your research, please
cite it using the following BibTex entry::
@misc{Anonlink,
author = {CSIRO's Data61},
title = {Anonlink Private Record Linkage System},
year = {2017},
publisher = {GitHub},
journal = {GitHub Repository},
howpublished = {\url{https://github.com/data61/clkhash}},
}
%package help
Summary: Development documents and examples for clkhash
Provides: python3-clkhash-doc
%description help
# CLK Hash
[![codecov](https://codecov.io/gh/data61/clkhash/branch/main/graph/badge.svg)](https://codecov.io/gh/data61/clkhash)
[![Documentation Status](https://readthedocs.org/projects/clkhash/badge/?version=latest)](http://clkhash.readthedocs.io/en/latest/?badge=latest)
[![Unit Testing](https://github.com/data61/clkhash/actions/workflows/unittests.yml/badge.svg)](https://github.com/data61/clkhash/actions/workflows/unittests.yml)
[![Typechecking](https://github.com/data61/clkhash/actions/workflows/typechecking.yml/badge.svg)](https://github.com/data61/clkhash/actions/workflows/typechecking.yml)
[![Downloads](https://pepy.tech/badge/clkhash)](https://pepy.tech/project/clkhash)
**clkhash** is a Python implementation of cryptographic linkage key hashing as described by _Rainer Schnell, Tobias Bachteler, and Jörg Reiher_ in
[A Novel Error-Tolerant Anonymous Linking Code](https://papers.ssrn.com/sol3/papers.cfm?abstract_id=3549247).
## Installation
Install clkhash with all dependencies using pip:
pip install clkhash
## Documentation
[https://clkhash.readthedocs.io](https://clkhash.readthedocs.io/en/latest/)
## Python API
To hash a CSV file of entities using the default schema:
```python
from clkhash import clk, randomnames
fake_pii_schema = randomnames.NameList.SCHEMA
clks = clk.generate_clk_from_csv(open('fake-pii-out.csv','r'), 'secret', fake_pii_schema)
```
## Command Line Interface
See [Anonlink Client](https://github.com/data61/anonlink-client) for a command line interface to clkhash.
## Citing
Clkhash, and the wider Anonlink project is designed, developed and supported by
[CSIRO's Data61](https://www.data61.csiro.au). If you use any part of this library in your research, please
cite it using the following BibTex entry::
@misc{Anonlink,
author = {CSIRO's Data61},
title = {Anonlink Private Record Linkage System},
year = {2017},
publisher = {GitHub},
journal = {GitHub Repository},
howpublished = {\url{https://github.com/data61/clkhash}},
}
%prep
%autosetup -n clkhash-0.18.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-clkhash -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.18.3-1
- Package Spec generated