%global _empty_manifest_terminate_build 0
Name: python-RPIO
Version: 0.10.0
Release: 1
Summary: Advanced GPIO for the Raspberry Pi. Extends RPi.GPIO with PWM, GPIO interrups, TCP socket interrupts, command line tools and more
License: LGPLv3+
URL: https://github.com/metachris/RPIO
Source0: https://mirrors.aliyun.com/pypi/web/packages/29/05/6884572923c57ff488fdf5c4ab887deb9edb2515afbcb49be087c95ac698/RPIO-0.10.0.tar.gz
BuildArch: noarch
%description
The easiest way to install/update RPIO on a Raspberry Pi is with either ``easy_install`` or ``pip``::
$ sudo apt-get install python-setuptools
$ sudo easy_install -U RPIO
After the installation you can use ``import RPIO`` as well as the command-line tools ``rpio`` and ``rpio-curses``.
Debian packages are available at `metachris.github.com/rpio/download `_.
%package -n python3-RPIO
Summary: Advanced GPIO for the Raspberry Pi. Extends RPi.GPIO with PWM, GPIO interrups, TCP socket interrupts, command line tools and more
Provides: python-RPIO
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-RPIO
The easiest way to install/update RPIO on a Raspberry Pi is with either ``easy_install`` or ``pip``::
$ sudo apt-get install python-setuptools
$ sudo easy_install -U RPIO
After the installation you can use ``import RPIO`` as well as the command-line tools ``rpio`` and ``rpio-curses``.
Debian packages are available at `metachris.github.com/rpio/download `_.
%package help
Summary: Development documents and examples for RPIO
Provides: python3-RPIO-doc
%description help
The easiest way to install/update RPIO on a Raspberry Pi is with either ``easy_install`` or ``pip``::
$ sudo apt-get install python-setuptools
$ sudo easy_install -U RPIO
After the installation you can use ``import RPIO`` as well as the command-line tools ``rpio`` and ``rpio-curses``.
Debian packages are available at `metachris.github.com/rpio/download `_.
%prep
%autosetup -n RPIO-0.10.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-RPIO -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.10.0-1
- Package Spec generated