%global _empty_manifest_terminate_build 0
Name: python-nailgun
Version: 0.32.0
Release: 1
Summary: A library that facilitates easy usage of the Satellite 6 API
License: GPLv3
URL: https://github.com/SatelliteQE/nailgun
Source0: https://mirrors.aliyun.com/pypi/web/packages/be/55/21b92737123a5c89252b1d17d9b6d0956e18226cf55f226feccb5feedbe3/nailgun-0.32.0.tar.gz
BuildArch: noarch
Requires: python3-inflection
Requires: python3-packaging
Requires: python3-pyxdg
Requires: python3-requests
Requires: python3-blinker-herald
Requires: python3-fauxfactory
%description
NailGun is a GPL-licensed Python library that facilitates easy usage of the
Satellite 6 API.
The `full documentation `_ is
available on ReadTheDocs. It can also be generated locally::
pip install -r requirements.txt -r requirements-dev.txt
make docs-html
%package -n python3-nailgun
Summary: A library that facilitates easy usage of the Satellite 6 API
Provides: python-nailgun
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-nailgun
NailGun is a GPL-licensed Python library that facilitates easy usage of the
Satellite 6 API.
The `full documentation `_ is
available on ReadTheDocs. It can also be generated locally::
pip install -r requirements.txt -r requirements-dev.txt
make docs-html
%package help
Summary: Development documents and examples for nailgun
Provides: python3-nailgun-doc
%description help
NailGun is a GPL-licensed Python library that facilitates easy usage of the
Satellite 6 API.
The `full documentation `_ is
available on ReadTheDocs. It can also be generated locally::
pip install -r requirements.txt -r requirements-dev.txt
make docs-html
%prep
%autosetup -n nailgun-0.32.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-nailgun -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.32.0-1
- Package Spec generated