%global _empty_manifest_terminate_build 0
Name:		python-coconutpy
Version:	3.0.0
Release:	1
Summary:	A python wrapper around the Coconut API
License:	MIT License
URL:		https://coconut.co
Source0:	https://mirrors.aliyun.com/pypi/web/packages/77/c0/1ed76aae05df0ca0e4dea3d3b72cf76d4d1158ce586908ea685d173d141f/coconutpy-3.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-httplib2

%description
Client Library for encoding Videos with Coconut

Coconut is a Video Encoding Web Service built for developers.

For more information:

* Coconut: https://coconut.co
* API Documentation: https://docs.coconut.co
* Twitter: @openCoconut

Changelogs

3.0.0
New pytonh library compatible with Coconut APIv2

2.4.3
Fix Authorization Header:
"TypeError: a bytes-like object is required, not 'str'" was returned before

2.4.2
Don't wait for a 401 challenge to pass the auth token to Coconut APIs.

2.4.0
Implements new Job methods to get info about a job and get metadata (new metadata API).

2.2.0
Added a new method #config to generate a full configuration based on the given parameters. It's especially useful to handle dynamic settings like source or variables that can be set directly in code.

2.0.0
New version of the client library which uses the HeyWatch API v2. This library is not compatible with 1.x

1.0.0
First version





%package -n python3-coconutpy
Summary:	A python wrapper around the Coconut API
Provides:	python-coconutpy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-coconutpy
Client Library for encoding Videos with Coconut

Coconut is a Video Encoding Web Service built for developers.

For more information:

* Coconut: https://coconut.co
* API Documentation: https://docs.coconut.co
* Twitter: @openCoconut

Changelogs

3.0.0
New pytonh library compatible with Coconut APIv2

2.4.3
Fix Authorization Header:
"TypeError: a bytes-like object is required, not 'str'" was returned before

2.4.2
Don't wait for a 401 challenge to pass the auth token to Coconut APIs.

2.4.0
Implements new Job methods to get info about a job and get metadata (new metadata API).

2.2.0
Added a new method #config to generate a full configuration based on the given parameters. It's especially useful to handle dynamic settings like source or variables that can be set directly in code.

2.0.0
New version of the client library which uses the HeyWatch API v2. This library is not compatible with 1.x

1.0.0
First version





%package help
Summary:	Development documents and examples for coconutpy
Provides:	python3-coconutpy-doc
%description help
Client Library for encoding Videos with Coconut

Coconut is a Video Encoding Web Service built for developers.

For more information:

* Coconut: https://coconut.co
* API Documentation: https://docs.coconut.co
* Twitter: @openCoconut

Changelogs

3.0.0
New pytonh library compatible with Coconut APIv2

2.4.3
Fix Authorization Header:
"TypeError: a bytes-like object is required, not 'str'" was returned before

2.4.2
Don't wait for a 401 challenge to pass the auth token to Coconut APIs.

2.4.0
Implements new Job methods to get info about a job and get metadata (new metadata API).

2.2.0
Added a new method #config to generate a full configuration based on the given parameters. It's especially useful to handle dynamic settings like source or variables that can be set directly in code.

2.0.0
New version of the client library which uses the HeyWatch API v2. This library is not compatible with 1.x

1.0.0
First version





%prep
%autosetup -n coconutpy-3.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-coconutpy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.0-1
- Package Spec generated