%global _empty_manifest_terminate_build 0
Name:		python-scvelo
Version:	0.2.5
Release:	1
Summary:	RNA velocity generalized through dynamical modeling
License:	BSD
URL:		https://github.com/theislab/scvelo
Source0:	https://mirrors.aliyun.com/pypi/web/packages/d7/ca/6669ad5c6765493ea9db0fb54b766d043b09db5a146f178c106b7162d1ef/scvelo-0.2.5.tar.gz
BuildArch:	noarch

Requires:	python3-typing-extensions
Requires:	python3-anndata
Requires:	python3-scanpy
Requires:	python3-loompy
Requires:	python3-umap-learn
Requires:	python3-numba
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-pandas
Requires:	python3-scikit-learn
Requires:	python3-matplotlib
Requires:	python3-black
Requires:	python3-hnswlib
Requires:	python3-hypothesis
Requires:	python3-flake8
Requires:	python3-isort
Requires:	python3-louvain
Requires:	python3-magic-impute
Requires:	python3-pre-commit
Requires:	python3-pybind11
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-igraph
Requires:	python3-scanpy
Requires:	python3-setuptools
Requires:	python3-setuptools-scm
Requires:	python3-typing-extensions
Requires:	python3-importlib-metadata
Requires:	python3-sphinx-rtd-theme
Requires:	python3-sphinx-autodoc-typehints
Requires:	python3-Jinja2
Requires:	python3-ipykernel
Requires:	python3-sphinx
Requires:	python3-nbsphinx
Requires:	python3-pybind11
Requires:	python3-hnswlib
Requires:	python3-igraph
Requires:	python3-louvain

%description
**scVelo** is a scalable toolkit for RNA velocity analysis in single cells, based on
`Bergen et al. (Nature Biotech, 2020) <https://doi.org/10.1038/s41587-020-0591-3>`_.
RNA velocity enables the recovery of directed dynamic information by leveraging splicing kinetics.
scVelo generalizes the concept of RNA velocity
(`La Manno et al., Nature, 2018 <https://doi.org/10.1038/s41586-018-0414-6>`_)
by relaxing previously made assumptions with a stochastic and a dynamical model that solves the full
transcriptional dynamics. It thereby adapts RNA velocity to widely varying specifications such as non-stationary populations.
scVelo is compatible with scanpy_ and hosts efficient implementations of all RNA velocity models.
scVelo's key applications
^^^^^^^^^^^^^^^^^^^^^^^^^
- estimate RNA velocity to study cellular dynamics.
- identify putative driver genes and regimes of regulatory changes.
- infer a latent time to reconstruct the temporal sequence of transcriptomic events.
- estimate reaction rates of transcription, splicing and degradation.
- use statistical tests, e.g., to detect different kinetics regimes.
scVelo has, for instance, recently been used to study immune response in COVID-19
patients and dynamic processes in human lung regeneration. Find out more in this list of
`application examples <https://scholar.google.com/scholar?cites=18195185735875895912>`_.
Latest news
^^^^^^^^^^^
- Aug/2021: `Perspectives paper out in MSB <https://doi.org/10.15252/msb.202110282>`_
- Feb/2021: scVelo goes multi-core
- Dec/2020: Cover of `Nature Biotechnology <https://www.nature.com/nbt/volumes/38>`_
- Nov/2020: Talk at `Single Cell Biology <https://coursesandconferences.wellcomegenomecampus.org/our-events/single-cell-biology-2020/>`_
- Oct/2020: `Helmholtz Best Paper Award <https://twitter.com/ICBmunich/status/1318611467722199041>`_
- Oct/2020: Map cell fates with `CellRank <https://cellrank.org>`_
- Sep/2020: Talk at `Single Cell Omics <https://twitter.com/fabian_theis/status/1305621028056465412>`_
- Aug/2020: `scVelo out in Nature Biotech <https://www.helmholtz-muenchen.de/en/aktuelles/latest-news/press-information-news/article/48658/index.html>`_
References
^^^^^^^^^^
La Manno *et al.* (2018), RNA velocity of single cells, `Nature <https://doi.org/10.1038/s41586-018-0414-6>`_.
Bergen *et al.* (2020), Generalizing RNA velocity to transient cell states through dynamical modeling,
`Nature Biotech <https://doi.org/10.1038/s41587-020-0591-3>`_.
Bergen *et al.* (2021), RNA velocity - current challenges and future perspectives,
`Molecular Systems Biology <https://doi.org/10.15252/msb.202110282>`_.
Support
^^^^^^^
Found a bug or would like to see a feature implemented? Feel free to submit an
`issue <https://github.com/theislab/scvelo/issues/new/choose>`_.
Have a question or would like to start a new discussion? Head over to
`GitHub discussions <https://github.com/theislab/scvelo/discussions>`_.
In either case, you can also always send us an `email <mailto:mail@scvelo.org>`_.
Your help to improve scVelo is highly appreciated.
For further information visit `scvelo.org <https://scvelo.org>`_.

%package -n python3-scvelo
Summary:	RNA velocity generalized through dynamical modeling
Provides:	python-scvelo
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-scvelo
**scVelo** is a scalable toolkit for RNA velocity analysis in single cells, based on
`Bergen et al. (Nature Biotech, 2020) <https://doi.org/10.1038/s41587-020-0591-3>`_.
RNA velocity enables the recovery of directed dynamic information by leveraging splicing kinetics.
scVelo generalizes the concept of RNA velocity
(`La Manno et al., Nature, 2018 <https://doi.org/10.1038/s41586-018-0414-6>`_)
by relaxing previously made assumptions with a stochastic and a dynamical model that solves the full
transcriptional dynamics. It thereby adapts RNA velocity to widely varying specifications such as non-stationary populations.
scVelo is compatible with scanpy_ and hosts efficient implementations of all RNA velocity models.
scVelo's key applications
^^^^^^^^^^^^^^^^^^^^^^^^^
- estimate RNA velocity to study cellular dynamics.
- identify putative driver genes and regimes of regulatory changes.
- infer a latent time to reconstruct the temporal sequence of transcriptomic events.
- estimate reaction rates of transcription, splicing and degradation.
- use statistical tests, e.g., to detect different kinetics regimes.
scVelo has, for instance, recently been used to study immune response in COVID-19
patients and dynamic processes in human lung regeneration. Find out more in this list of
`application examples <https://scholar.google.com/scholar?cites=18195185735875895912>`_.
Latest news
^^^^^^^^^^^
- Aug/2021: `Perspectives paper out in MSB <https://doi.org/10.15252/msb.202110282>`_
- Feb/2021: scVelo goes multi-core
- Dec/2020: Cover of `Nature Biotechnology <https://www.nature.com/nbt/volumes/38>`_
- Nov/2020: Talk at `Single Cell Biology <https://coursesandconferences.wellcomegenomecampus.org/our-events/single-cell-biology-2020/>`_
- Oct/2020: `Helmholtz Best Paper Award <https://twitter.com/ICBmunich/status/1318611467722199041>`_
- Oct/2020: Map cell fates with `CellRank <https://cellrank.org>`_
- Sep/2020: Talk at `Single Cell Omics <https://twitter.com/fabian_theis/status/1305621028056465412>`_
- Aug/2020: `scVelo out in Nature Biotech <https://www.helmholtz-muenchen.de/en/aktuelles/latest-news/press-information-news/article/48658/index.html>`_
References
^^^^^^^^^^
La Manno *et al.* (2018), RNA velocity of single cells, `Nature <https://doi.org/10.1038/s41586-018-0414-6>`_.
Bergen *et al.* (2020), Generalizing RNA velocity to transient cell states through dynamical modeling,
`Nature Biotech <https://doi.org/10.1038/s41587-020-0591-3>`_.
Bergen *et al.* (2021), RNA velocity - current challenges and future perspectives,
`Molecular Systems Biology <https://doi.org/10.15252/msb.202110282>`_.
Support
^^^^^^^
Found a bug or would like to see a feature implemented? Feel free to submit an
`issue <https://github.com/theislab/scvelo/issues/new/choose>`_.
Have a question or would like to start a new discussion? Head over to
`GitHub discussions <https://github.com/theislab/scvelo/discussions>`_.
In either case, you can also always send us an `email <mailto:mail@scvelo.org>`_.
Your help to improve scVelo is highly appreciated.
For further information visit `scvelo.org <https://scvelo.org>`_.

%package help
Summary:	Development documents and examples for scvelo
Provides:	python3-scvelo-doc
%description help
**scVelo** is a scalable toolkit for RNA velocity analysis in single cells, based on
`Bergen et al. (Nature Biotech, 2020) <https://doi.org/10.1038/s41587-020-0591-3>`_.
RNA velocity enables the recovery of directed dynamic information by leveraging splicing kinetics.
scVelo generalizes the concept of RNA velocity
(`La Manno et al., Nature, 2018 <https://doi.org/10.1038/s41586-018-0414-6>`_)
by relaxing previously made assumptions with a stochastic and a dynamical model that solves the full
transcriptional dynamics. It thereby adapts RNA velocity to widely varying specifications such as non-stationary populations.
scVelo is compatible with scanpy_ and hosts efficient implementations of all RNA velocity models.
scVelo's key applications
^^^^^^^^^^^^^^^^^^^^^^^^^
- estimate RNA velocity to study cellular dynamics.
- identify putative driver genes and regimes of regulatory changes.
- infer a latent time to reconstruct the temporal sequence of transcriptomic events.
- estimate reaction rates of transcription, splicing and degradation.
- use statistical tests, e.g., to detect different kinetics regimes.
scVelo has, for instance, recently been used to study immune response in COVID-19
patients and dynamic processes in human lung regeneration. Find out more in this list of
`application examples <https://scholar.google.com/scholar?cites=18195185735875895912>`_.
Latest news
^^^^^^^^^^^
- Aug/2021: `Perspectives paper out in MSB <https://doi.org/10.15252/msb.202110282>`_
- Feb/2021: scVelo goes multi-core
- Dec/2020: Cover of `Nature Biotechnology <https://www.nature.com/nbt/volumes/38>`_
- Nov/2020: Talk at `Single Cell Biology <https://coursesandconferences.wellcomegenomecampus.org/our-events/single-cell-biology-2020/>`_
- Oct/2020: `Helmholtz Best Paper Award <https://twitter.com/ICBmunich/status/1318611467722199041>`_
- Oct/2020: Map cell fates with `CellRank <https://cellrank.org>`_
- Sep/2020: Talk at `Single Cell Omics <https://twitter.com/fabian_theis/status/1305621028056465412>`_
- Aug/2020: `scVelo out in Nature Biotech <https://www.helmholtz-muenchen.de/en/aktuelles/latest-news/press-information-news/article/48658/index.html>`_
References
^^^^^^^^^^
La Manno *et al.* (2018), RNA velocity of single cells, `Nature <https://doi.org/10.1038/s41586-018-0414-6>`_.
Bergen *et al.* (2020), Generalizing RNA velocity to transient cell states through dynamical modeling,
`Nature Biotech <https://doi.org/10.1038/s41587-020-0591-3>`_.
Bergen *et al.* (2021), RNA velocity - current challenges and future perspectives,
`Molecular Systems Biology <https://doi.org/10.15252/msb.202110282>`_.
Support
^^^^^^^
Found a bug or would like to see a feature implemented? Feel free to submit an
`issue <https://github.com/theislab/scvelo/issues/new/choose>`_.
Have a question or would like to start a new discussion? Head over to
`GitHub discussions <https://github.com/theislab/scvelo/discussions>`_.
In either case, you can also always send us an `email <mailto:mail@scvelo.org>`_.
Your help to improve scVelo is highly appreciated.
For further information visit `scvelo.org <https://scvelo.org>`_.

%prep
%autosetup -n scvelo-0.2.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-scvelo -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.5-1
- Package Spec generated