%global _empty_manifest_terminate_build 0
Name:		python-a5dev
Version:	0.9.2
Release:	1
Summary:	Helper library for day to day task in a ml engineer's life.
License:	MIT License
URL:		https://github.com/ankitsainidev/a5dev
Source0:	https://mirrors.aliyun.com/pypi/web/packages/e2/86/e5b772508a8f44d944ba58a3c54f24883d48c2035ffe4206f6978dd30ee0/a5dev-0.9.2.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-opencv-python
Requires:	python3-kaggle
Requires:	python3-torch
Requires:	python3-wget
Requires:	python3-requests

%description
Basic package contains common day-to-day ml usage functions.




%package -n python3-a5dev
Summary:	Helper library for day to day task in a ml engineer's life.
Provides:	python-a5dev
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-a5dev
Basic package contains common day-to-day ml usage functions.




%package help
Summary:	Development documents and examples for a5dev
Provides:	python3-a5dev-doc
%description help
Basic package contains common day-to-day ml usage functions.




%prep
%autosetup -n a5dev-0.9.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-a5dev -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.2-1
- Package Spec generated