%global _empty_manifest_terminate_build 0
Name:		python-rerun
Version:	1.0.30
Release:	1
Summary:	Command-line script to re-run the given command when files change.
License:	BSD License
URL:		http://pypi.python.org/pypi/rerun/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/95/d9/dd0334d2517b8ab0b3de0fff3e0370902c14057b47d2e15207a327a433a2/rerun-1.0.30.zip
BuildArch:	noarch


%description
    pip install rerun

%package -n python3-rerun
Summary:	Command-line script to re-run the given command when files change.
Provides:	python-rerun
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-rerun
    pip install rerun

%package help
Summary:	Development documents and examples for rerun
Provides:	python3-rerun-doc
%description help
    pip install rerun

%prep
%autosetup -n rerun-1.0.30

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-rerun -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.30-1
- Package Spec generated