%global _empty_manifest_terminate_build 0
Name: python-pkg-info
Version: 0.1.2
Release: 1
Summary: Tiny library to fetch package info from PyPI.
License: BSD
URL: https://github.com/acifani/pkg-info
Source0: https://mirrors.aliyun.com/pypi/web/packages/67/2d/86523094403b293e22fe7357cf59d4aaa1d47153b741db22ae91d39a0325/pkg-info-0.1.2.tar.gz
BuildArch: noarch
Requires: python3-requests
%description
Tiny library to fetch package info from `PyPI `_.
%package -n python3-pkg-info
Summary: Tiny library to fetch package info from PyPI.
Provides: python-pkg-info
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pkg-info
Tiny library to fetch package info from `PyPI `_.
%package help
Summary: Development documents and examples for pkg-info
Provides: python3-pkg-info-doc
%description help
Tiny library to fetch package info from `PyPI `_.
%prep
%autosetup -n pkg-info-0.1.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pkg-info -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.1.2-1
- Package Spec generated