%global _empty_manifest_terminate_build 0
Name:		python-profiling
Version:	0.1.3
Release:	1
Summary:	An interactive continuous Python profiler.
License:	BSD
URL:		https://github.com/what-studio/profiling
Source0:	https://mirrors.aliyun.com/pypi/web/packages/46/0e/6a58c06479b458a043a8ca217096328218606d9f2f84ae4ce58c67ca70fb/profiling-0.1.3.tar.gz
BuildArch:	noarch


%description
profiling
~~~~~~~~~

.. image:: https://img.shields.io/travis/what-studio/profiling.svg
   :target: https://travis-ci.org/what-studio/profiling

.. image:: https://img.shields.io/coveralls/what-studio/profiling.svg
   :target: https://coveralls.io/r/what-studio/profiling

The profiling package is an interactive continuous Python profiler.  It is
inspired from `Unity 3D <http://unity3d.com/>`_ profiler.  This package
provides these features:

- Profiling statistics keep the frame stack.
- An interactive TUI profiling statistics viewer.
- Provides both of statistical and deterministic profiling.
- Utilities for remote profiling.
- Thread or greenlet aware CPU timer.
- Supports Python 2.7, 3.3, 3.4 and 3.5.
- Currently supports only Linux.

Links
'''''

GitHub:
   https://github.com/what-studio/profiling
Demo:
   https://asciinema.org/a/25394

%package -n python3-profiling
Summary:	An interactive continuous Python profiler.
Provides:	python-profiling
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-profiling
profiling
~~~~~~~~~

.. image:: https://img.shields.io/travis/what-studio/profiling.svg
   :target: https://travis-ci.org/what-studio/profiling

.. image:: https://img.shields.io/coveralls/what-studio/profiling.svg
   :target: https://coveralls.io/r/what-studio/profiling

The profiling package is an interactive continuous Python profiler.  It is
inspired from `Unity 3D <http://unity3d.com/>`_ profiler.  This package
provides these features:

- Profiling statistics keep the frame stack.
- An interactive TUI profiling statistics viewer.
- Provides both of statistical and deterministic profiling.
- Utilities for remote profiling.
- Thread or greenlet aware CPU timer.
- Supports Python 2.7, 3.3, 3.4 and 3.5.
- Currently supports only Linux.

Links
'''''

GitHub:
   https://github.com/what-studio/profiling
Demo:
   https://asciinema.org/a/25394

%package help
Summary:	Development documents and examples for profiling
Provides:	python3-profiling-doc
%description help
profiling
~~~~~~~~~

.. image:: https://img.shields.io/travis/what-studio/profiling.svg
   :target: https://travis-ci.org/what-studio/profiling

.. image:: https://img.shields.io/coveralls/what-studio/profiling.svg
   :target: https://coveralls.io/r/what-studio/profiling

The profiling package is an interactive continuous Python profiler.  It is
inspired from `Unity 3D <http://unity3d.com/>`_ profiler.  This package
provides these features:

- Profiling statistics keep the frame stack.
- An interactive TUI profiling statistics viewer.
- Provides both of statistical and deterministic profiling.
- Utilities for remote profiling.
- Thread or greenlet aware CPU timer.
- Supports Python 2.7, 3.3, 3.4 and 3.5.
- Currently supports only Linux.

Links
'''''

GitHub:
   https://github.com/what-studio/profiling
Demo:
   https://asciinema.org/a/25394

%prep
%autosetup -n profiling-0.1.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-profiling -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.3-1
- Package Spec generated