%global _empty_manifest_terminate_build 0
Name: python-pyvespa
Version: 0.34.0
Release: 1
Summary: Python API for vespa.ai
License: Apache Software License
URL: https://pyvespa.readthedocs.io/
Source0: https://mirrors.aliyun.com/pypi/web/packages/28/5c/fa1ef8e30470daed5ca7d529c2c5c4e9424febfff39aba3ceea08fe0a44a/pyvespa-0.34.0.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-pandas
Requires: python3-docker
Requires: python3-jinja2
Requires: python3-cryptography
Requires: python3-aiohttp
Requires: python3-tenacity
Requires: python3-typing-extensions
%description
# pyvespa
![Vespa logo](https://vespa.ai/assets/vespa-logo-color.png)
[![Documentation Status](https://readthedocs.org/projects/pyvespa/badge/?version=latest)](https://pyvespa.readthedocs.io/en/latest/?badge=latest)
[pyvespa site / documentation](https://pyvespa.readthedocs.io/en/latest/index.html)
[Vespa](https://vespa.ai/) is the scalable open-sourced serving engine that enables users to store,
compute and rank big data at user serving time.
`pyvespa` provides a python API to Vespa.
It allows users to create, modify, deploy and interact with running Vespa instances.
The main goal of the library is to allow for faster prototyping
and to facilitate Machine Learning experiments for Vespa applications -
also see [learntorank](https://github.com/vespa-engine/learntorank).
## License
Code licensed under the Apache 2.0 license. See [LICENSE](LICENSE) for terms.
## Development environment
Check [screwdriver.yaml](screwdriver.yaml) to see which packages and environment variables
need to be set to run unit and integration tests.
## Releases
Find releases and release notes on [GitHub](https://github.com/vespa-engine/pyvespa/releases).
### Release instructions
* Check out master branch
* Temporarily change library version number in `get_target_version()` in [setup.py](setup.py) to the new version,
e.g. "0.16.0".
* Run from the pyvespa root directory to create the library files:
```
python3 -m pip install --upgrade pip
python3 -m pip install twine wheel
python3 setup.py sdist bdist_wheel
```
With write access to [pypi.org/project/pyvespa/](https://pypi.org/project/pyvespa/),
upload, this requires username and password:
```
python3 -m twine upload dist/*
```
At this point, the package has been released.
Create a new release tag at [github.com/vespa-engine/pyvespa/releases/new](https://github.com/vespa-engine/pyvespa/releases/new)
with a summary of the code changes.
%package -n python3-pyvespa
Summary: Python API for vespa.ai
Provides: python-pyvespa
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyvespa
# pyvespa
![Vespa logo](https://vespa.ai/assets/vespa-logo-color.png)
[![Documentation Status](https://readthedocs.org/projects/pyvespa/badge/?version=latest)](https://pyvespa.readthedocs.io/en/latest/?badge=latest)
[pyvespa site / documentation](https://pyvespa.readthedocs.io/en/latest/index.html)
[Vespa](https://vespa.ai/) is the scalable open-sourced serving engine that enables users to store,
compute and rank big data at user serving time.
`pyvespa` provides a python API to Vespa.
It allows users to create, modify, deploy and interact with running Vespa instances.
The main goal of the library is to allow for faster prototyping
and to facilitate Machine Learning experiments for Vespa applications -
also see [learntorank](https://github.com/vespa-engine/learntorank).
## License
Code licensed under the Apache 2.0 license. See [LICENSE](LICENSE) for terms.
## Development environment
Check [screwdriver.yaml](screwdriver.yaml) to see which packages and environment variables
need to be set to run unit and integration tests.
## Releases
Find releases and release notes on [GitHub](https://github.com/vespa-engine/pyvespa/releases).
### Release instructions
* Check out master branch
* Temporarily change library version number in `get_target_version()` in [setup.py](setup.py) to the new version,
e.g. "0.16.0".
* Run from the pyvespa root directory to create the library files:
```
python3 -m pip install --upgrade pip
python3 -m pip install twine wheel
python3 setup.py sdist bdist_wheel
```
With write access to [pypi.org/project/pyvespa/](https://pypi.org/project/pyvespa/),
upload, this requires username and password:
```
python3 -m twine upload dist/*
```
At this point, the package has been released.
Create a new release tag at [github.com/vespa-engine/pyvespa/releases/new](https://github.com/vespa-engine/pyvespa/releases/new)
with a summary of the code changes.
%package help
Summary: Development documents and examples for pyvespa
Provides: python3-pyvespa-doc
%description help
# pyvespa
![Vespa logo](https://vespa.ai/assets/vespa-logo-color.png)
[![Documentation Status](https://readthedocs.org/projects/pyvespa/badge/?version=latest)](https://pyvespa.readthedocs.io/en/latest/?badge=latest)
[pyvespa site / documentation](https://pyvespa.readthedocs.io/en/latest/index.html)
[Vespa](https://vespa.ai/) is the scalable open-sourced serving engine that enables users to store,
compute and rank big data at user serving time.
`pyvespa` provides a python API to Vespa.
It allows users to create, modify, deploy and interact with running Vespa instances.
The main goal of the library is to allow for faster prototyping
and to facilitate Machine Learning experiments for Vespa applications -
also see [learntorank](https://github.com/vespa-engine/learntorank).
## License
Code licensed under the Apache 2.0 license. See [LICENSE](LICENSE) for terms.
## Development environment
Check [screwdriver.yaml](screwdriver.yaml) to see which packages and environment variables
need to be set to run unit and integration tests.
## Releases
Find releases and release notes on [GitHub](https://github.com/vespa-engine/pyvespa/releases).
### Release instructions
* Check out master branch
* Temporarily change library version number in `get_target_version()` in [setup.py](setup.py) to the new version,
e.g. "0.16.0".
* Run from the pyvespa root directory to create the library files:
```
python3 -m pip install --upgrade pip
python3 -m pip install twine wheel
python3 setup.py sdist bdist_wheel
```
With write access to [pypi.org/project/pyvespa/](https://pypi.org/project/pyvespa/),
upload, this requires username and password:
```
python3 -m twine upload dist/*
```
At this point, the package has been released.
Create a new release tag at [github.com/vespa-engine/pyvespa/releases/new](https://github.com/vespa-engine/pyvespa/releases/new)
with a summary of the code changes.
%prep
%autosetup -n pyvespa-0.34.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyvespa -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.34.0-1
- Package Spec generated