%global _empty_manifest_terminate_build 0
Name:		python-Moildev
Version:	3.1.0
Release:	1
Summary:	Moildev is a sophisticated fisheye image processing library
License:	MIT License
URL:		https://github.com/MoilOrg/moildev
Source0:	https://mirrors.aliyun.com/pypi/web/packages/86/41/7bb521db4c32acee9c54437cde8c1b8b5e048fc5ec79648154a45d3ee2de/Moildev-3.1.0.tar.gz
BuildArch:	noarch

Requires:	python3-opencv-python
Requires:	python3-numpy
Requires:	python3-setuptools

%description
## Moildev Library

Moildev Library is a collection of functions that support the development of fisheye image applications based on python programing language. You can visit this [documentation](https://github.com/MoilOrg/moildev) to going deep on this library.

### Support cross-platform and multiple python version

This library can support both Linux OS and Windows OS for python version 3.6 ~ 3.10.

### Installation

The easiest  way to install is using PyPI distribution, you can use this command:

```python
pip install moildev
```
or you can download from GitHub [repository](https://github.com/MoilOrg/moildev) and install it by pip command:

```python
cd moildev/
pip install moildev.tar.gz
```

#### 1. Import Library
You can Import library by copy and paste this code to your python file.

```python
from Moildev import Moildev
```
Above code will give you information about moildev version and other information

#### 2. Create object

To create the object from Moildev, you have to provide the parameter. The camera parameter is the result from camera calibration process by MOIL laboratory 

   There 3 way to create object of moildev
   1. Create object using **input keyword arguments**
   2. Create object using **one parameter** with json file format extension 
   3. Create object using **multiple parameter** with json file format extension

**Example**:

```python
# Create object using input keyword arguments
moildev_1 = Moildev(cameraName="Raspi", cameraFov=220, sensorWidth=1.4, sensorHeight=1.4, icx=1298, icy=966, ratio=1,
                    imageWidth=2592, imageHeight=1944, calibrationRatio=4.05, parameter0=0, parameter1=0, parameter2=0,
                    parameter3=0, parameter4=-47.96, parameter5=222.86)
```

**List of camera parameters keyword used to create Moildev objects:**

- cameraName = the name of the camera used
- cameraFov = camera field of view (FOV)
- sensorWidth = size of sensor width
- sensorHeight = size of sensor height
- icx = center image in x-axis
- icy = center image in y-axis
- ratio = the value of the ratio image
- imageWidth = the size of width image
- imageHeight = the size of height image
- calibrationRatio = the value of calibration ratio
- parameter0 .. parameter5= intrinsic fisheye camera parameter get from calibration

*See example [here](https://github.com/MoilOrg/moildev/tree/main/examples/getting_started)*

#### 3. Anypoint image

Python code show bellow:
```python
anypoint_image = moildev.anypoint(image, alpha, beta, zoom, mode=1)
```

- **image**: source image
- **alpha**: the value of alpha
- **beta**: the value of beta
- **zoom**: decimal zoom factor, normally 1..12
- **mode**: mode anypoint view (by default it will be mode 1 and other mode 2)

*See example [here](https://github.com/MoilOrg/moildev/tree/main/examples/anypoint)*

#### 4. Panorama Image

Python code show bellow
```python
panorama_image = moildev.panorama(image, alpha_min, alpha_max)
```

- **image** = the original image  
- **alpha_min** = the minimum alpha 
- **alpha_max** : max of alpha. The recommended vaule is half of camera FOV.

*See example [here](https://github.com/MoilOrg/moildev/tree/main/examples/panorama)*

##### Detail about Moildev library, you can read this [Repository](https://github.com/MoilOrg/moildev)



%package -n python3-Moildev
Summary:	Moildev is a sophisticated fisheye image processing library
Provides:	python-Moildev
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Moildev
## Moildev Library

Moildev Library is a collection of functions that support the development of fisheye image applications based on python programing language. You can visit this [documentation](https://github.com/MoilOrg/moildev) to going deep on this library.

### Support cross-platform and multiple python version

This library can support both Linux OS and Windows OS for python version 3.6 ~ 3.10.

### Installation

The easiest  way to install is using PyPI distribution, you can use this command:

```python
pip install moildev
```
or you can download from GitHub [repository](https://github.com/MoilOrg/moildev) and install it by pip command:

```python
cd moildev/
pip install moildev.tar.gz
```

#### 1. Import Library
You can Import library by copy and paste this code to your python file.

```python
from Moildev import Moildev
```
Above code will give you information about moildev version and other information

#### 2. Create object

To create the object from Moildev, you have to provide the parameter. The camera parameter is the result from camera calibration process by MOIL laboratory 

   There 3 way to create object of moildev
   1. Create object using **input keyword arguments**
   2. Create object using **one parameter** with json file format extension 
   3. Create object using **multiple parameter** with json file format extension

**Example**:

```python
# Create object using input keyword arguments
moildev_1 = Moildev(cameraName="Raspi", cameraFov=220, sensorWidth=1.4, sensorHeight=1.4, icx=1298, icy=966, ratio=1,
                    imageWidth=2592, imageHeight=1944, calibrationRatio=4.05, parameter0=0, parameter1=0, parameter2=0,
                    parameter3=0, parameter4=-47.96, parameter5=222.86)
```

**List of camera parameters keyword used to create Moildev objects:**

- cameraName = the name of the camera used
- cameraFov = camera field of view (FOV)
- sensorWidth = size of sensor width
- sensorHeight = size of sensor height
- icx = center image in x-axis
- icy = center image in y-axis
- ratio = the value of the ratio image
- imageWidth = the size of width image
- imageHeight = the size of height image
- calibrationRatio = the value of calibration ratio
- parameter0 .. parameter5= intrinsic fisheye camera parameter get from calibration

*See example [here](https://github.com/MoilOrg/moildev/tree/main/examples/getting_started)*

#### 3. Anypoint image

Python code show bellow:
```python
anypoint_image = moildev.anypoint(image, alpha, beta, zoom, mode=1)
```

- **image**: source image
- **alpha**: the value of alpha
- **beta**: the value of beta
- **zoom**: decimal zoom factor, normally 1..12
- **mode**: mode anypoint view (by default it will be mode 1 and other mode 2)

*See example [here](https://github.com/MoilOrg/moildev/tree/main/examples/anypoint)*

#### 4. Panorama Image

Python code show bellow
```python
panorama_image = moildev.panorama(image, alpha_min, alpha_max)
```

- **image** = the original image  
- **alpha_min** = the minimum alpha 
- **alpha_max** : max of alpha. The recommended vaule is half of camera FOV.

*See example [here](https://github.com/MoilOrg/moildev/tree/main/examples/panorama)*

##### Detail about Moildev library, you can read this [Repository](https://github.com/MoilOrg/moildev)



%package help
Summary:	Development documents and examples for Moildev
Provides:	python3-Moildev-doc
%description help
## Moildev Library

Moildev Library is a collection of functions that support the development of fisheye image applications based on python programing language. You can visit this [documentation](https://github.com/MoilOrg/moildev) to going deep on this library.

### Support cross-platform and multiple python version

This library can support both Linux OS and Windows OS for python version 3.6 ~ 3.10.

### Installation

The easiest  way to install is using PyPI distribution, you can use this command:

```python
pip install moildev
```
or you can download from GitHub [repository](https://github.com/MoilOrg/moildev) and install it by pip command:

```python
cd moildev/
pip install moildev.tar.gz
```

#### 1. Import Library
You can Import library by copy and paste this code to your python file.

```python
from Moildev import Moildev
```
Above code will give you information about moildev version and other information

#### 2. Create object

To create the object from Moildev, you have to provide the parameter. The camera parameter is the result from camera calibration process by MOIL laboratory 

   There 3 way to create object of moildev
   1. Create object using **input keyword arguments**
   2. Create object using **one parameter** with json file format extension 
   3. Create object using **multiple parameter** with json file format extension

**Example**:

```python
# Create object using input keyword arguments
moildev_1 = Moildev(cameraName="Raspi", cameraFov=220, sensorWidth=1.4, sensorHeight=1.4, icx=1298, icy=966, ratio=1,
                    imageWidth=2592, imageHeight=1944, calibrationRatio=4.05, parameter0=0, parameter1=0, parameter2=0,
                    parameter3=0, parameter4=-47.96, parameter5=222.86)
```

**List of camera parameters keyword used to create Moildev objects:**

- cameraName = the name of the camera used
- cameraFov = camera field of view (FOV)
- sensorWidth = size of sensor width
- sensorHeight = size of sensor height
- icx = center image in x-axis
- icy = center image in y-axis
- ratio = the value of the ratio image
- imageWidth = the size of width image
- imageHeight = the size of height image
- calibrationRatio = the value of calibration ratio
- parameter0 .. parameter5= intrinsic fisheye camera parameter get from calibration

*See example [here](https://github.com/MoilOrg/moildev/tree/main/examples/getting_started)*

#### 3. Anypoint image

Python code show bellow:
```python
anypoint_image = moildev.anypoint(image, alpha, beta, zoom, mode=1)
```

- **image**: source image
- **alpha**: the value of alpha
- **beta**: the value of beta
- **zoom**: decimal zoom factor, normally 1..12
- **mode**: mode anypoint view (by default it will be mode 1 and other mode 2)

*See example [here](https://github.com/MoilOrg/moildev/tree/main/examples/anypoint)*

#### 4. Panorama Image

Python code show bellow
```python
panorama_image = moildev.panorama(image, alpha_min, alpha_max)
```

- **image** = the original image  
- **alpha_min** = the minimum alpha 
- **alpha_max** : max of alpha. The recommended vaule is half of camera FOV.

*See example [here](https://github.com/MoilOrg/moildev/tree/main/examples/panorama)*

##### Detail about Moildev library, you can read this [Repository](https://github.com/MoilOrg/moildev)



%prep
%autosetup -n Moildev-3.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Moildev -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.0-1
- Package Spec generated