%global _empty_manifest_terminate_build 0
Name:		python-snps
Version:	2.7.2
Release:	1
Summary:	tools for reading, writing, merging, and remapping SNPs
License:	BSD 3-Clause License
URL:		https://github.com/apriha/snps
Source0:	https://mirrors.aliyun.com/pypi/web/packages/d8/8b/5fbb581adfeb5b97d7871291751b390be983e1eb685c97c2ee17dc9efeab/snps-2.7.2.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-pandas
Requires:	python3-atomicwrites
Requires:	python3-ezancestry

%description
tools for reading, writing, merging, and remapping SNPs 🧬
``snps`` *strives to be an easy-to-use and accessible open-source library for working with
genotype data*

%package -n python3-snps
Summary:	tools for reading, writing, merging, and remapping SNPs
Provides:	python-snps
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-snps
tools for reading, writing, merging, and remapping SNPs 🧬
``snps`` *strives to be an easy-to-use and accessible open-source library for working with
genotype data*

%package help
Summary:	Development documents and examples for snps
Provides:	python3-snps-doc
%description help
tools for reading, writing, merging, and remapping SNPs 🧬
``snps`` *strives to be an easy-to-use and accessible open-source library for working with
genotype data*

%prep
%autosetup -n snps-2.7.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-snps -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 2.7.2-1
- Package Spec generated