%global _empty_manifest_terminate_build 0
Name:		python-util2
Version:	0.0.0.4
Release:	1
Summary:	This is utils library for Python.
License:	MIT License
URL:		https://github.com/tanaka0079/libs/python/util2/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/77/14/c29022e29a1de7646d9307f0129ba6d18e693e64e41d8f650190268d937b/util2-0.0.0.4.tar.gz
BuildArch:	noarch


%description
# DatetimeExtender
his Python library can perform various calculations for datetime.  
このPythonライブラリは時刻の各種計算を行うことができます。

[Github](https://github.com/tanaka0079/libs/tree/master/python/datetime_extender-python)   
[Document](https://tanaka0079.github.io/libs/python/datetime_extender-python/docs/html/index.html)   

## Getting started(導入)
Install with `pip`.  
pipで簡単にインストールできます。

```
pip install util2 
```

## License(ライセンス)
This sample code is licensed under the MIT License.
サンプルコードはMITライセンスで公開しています。

%package -n python3-util2
Summary:	This is utils library for Python.
Provides:	python-util2
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-util2
# DatetimeExtender
his Python library can perform various calculations for datetime.  
このPythonライブラリは時刻の各種計算を行うことができます。

[Github](https://github.com/tanaka0079/libs/tree/master/python/datetime_extender-python)   
[Document](https://tanaka0079.github.io/libs/python/datetime_extender-python/docs/html/index.html)   

## Getting started(導入)
Install with `pip`.  
pipで簡単にインストールできます。

```
pip install util2 
```

## License(ライセンス)
This sample code is licensed under the MIT License.
サンプルコードはMITライセンスで公開しています。

%package help
Summary:	Development documents and examples for util2
Provides:	python3-util2-doc
%description help
# DatetimeExtender
his Python library can perform various calculations for datetime.  
このPythonライブラリは時刻の各種計算を行うことができます。

[Github](https://github.com/tanaka0079/libs/tree/master/python/datetime_extender-python)   
[Document](https://tanaka0079.github.io/libs/python/datetime_extender-python/docs/html/index.html)   

## Getting started(導入)
Install with `pip`.  
pipで簡単にインストールできます。

```
pip install util2 
```

## License(ライセンス)
This sample code is licensed under the MIT License.
サンプルコードはMITライセンスで公開しています。

%prep
%autosetup -n util2-0.0.0.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-util2 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.0.4-1
- Package Spec generated