%global _empty_manifest_terminate_build 0
Name:		python-pi3d
Version:	2.49
Release:	1
Summary:	pi3d OpenGLES2 3D graphics library
License:	MIT generally but see docstrings in specific files
URL:		http://pi3d.github.com/html/index.html
Source0:	https://mirrors.aliyun.com/pypi/web/packages/f3/42/16acb65a2fbc4e483de29aa20e895d3797024293bf798dc2f19252337309/pi3d-2.49.tar.gz
BuildArch:	noarch

Requires:	python3-Pillow
Requires:	python3-numpy

%description
pi3d is a Python module that aims to greatly simplify writing 3D in Python
whilst giving access to the power of the Raspberry Pi GPU. It enables both
3D and 2D rendering and aims to provide a host of exciting commands to load
in textured/animated models, create fractal landscapes, shaders and much more.
The pi3d module runs on platforms other than the Raspberry Pi (On Windows
using pygame, on linux using the X server directly and on Android using
python-for-android) and runs with python 3 as well as 2.
The OpenGLES2.0 functionality of the Raspberry Pi or Android is used directly
or via mesa or ANGLE on 'big' machines. This makes it generally *faster*
and opens up the world of *shaders* that allow effects such as normal and 
reflection maps, blurring and many others. It has various demos of built-in
shapes, landscapes, model loading, walk-about camera and much more! See the demos
on github.com/pi3d/pi3d_demos and experiment with them ..
Documentation (instalation instructions): https://pi3d.github.io/html/ReadMe.html
FAQ: https://pi3d.github.io/html/FAQ.html
Demo programs: https://github.com/pi3d/pi3d_demos
Source code: https://github.com/tipam/pi3d
Book: http://paddywwoof.github.io/pi3d_book/
Changelog: https://github.com/tipam/pi3d/blob/master/ChangeLog.txt

%package -n python3-pi3d
Summary:	pi3d OpenGLES2 3D graphics library
Provides:	python-pi3d
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pi3d
pi3d is a Python module that aims to greatly simplify writing 3D in Python
whilst giving access to the power of the Raspberry Pi GPU. It enables both
3D and 2D rendering and aims to provide a host of exciting commands to load
in textured/animated models, create fractal landscapes, shaders and much more.
The pi3d module runs on platforms other than the Raspberry Pi (On Windows
using pygame, on linux using the X server directly and on Android using
python-for-android) and runs with python 3 as well as 2.
The OpenGLES2.0 functionality of the Raspberry Pi or Android is used directly
or via mesa or ANGLE on 'big' machines. This makes it generally *faster*
and opens up the world of *shaders* that allow effects such as normal and 
reflection maps, blurring and many others. It has various demos of built-in
shapes, landscapes, model loading, walk-about camera and much more! See the demos
on github.com/pi3d/pi3d_demos and experiment with them ..
Documentation (instalation instructions): https://pi3d.github.io/html/ReadMe.html
FAQ: https://pi3d.github.io/html/FAQ.html
Demo programs: https://github.com/pi3d/pi3d_demos
Source code: https://github.com/tipam/pi3d
Book: http://paddywwoof.github.io/pi3d_book/
Changelog: https://github.com/tipam/pi3d/blob/master/ChangeLog.txt

%package help
Summary:	Development documents and examples for pi3d
Provides:	python3-pi3d-doc
%description help
pi3d is a Python module that aims to greatly simplify writing 3D in Python
whilst giving access to the power of the Raspberry Pi GPU. It enables both
3D and 2D rendering and aims to provide a host of exciting commands to load
in textured/animated models, create fractal landscapes, shaders and much more.
The pi3d module runs on platforms other than the Raspberry Pi (On Windows
using pygame, on linux using the X server directly and on Android using
python-for-android) and runs with python 3 as well as 2.
The OpenGLES2.0 functionality of the Raspberry Pi or Android is used directly
or via mesa or ANGLE on 'big' machines. This makes it generally *faster*
and opens up the world of *shaders* that allow effects such as normal and 
reflection maps, blurring and many others. It has various demos of built-in
shapes, landscapes, model loading, walk-about camera and much more! See the demos
on github.com/pi3d/pi3d_demos and experiment with them ..
Documentation (instalation instructions): https://pi3d.github.io/html/ReadMe.html
FAQ: https://pi3d.github.io/html/FAQ.html
Demo programs: https://github.com/pi3d/pi3d_demos
Source code: https://github.com/tipam/pi3d
Book: http://paddywwoof.github.io/pi3d_book/
Changelog: https://github.com/tipam/pi3d/blob/master/ChangeLog.txt

%prep
%autosetup -n pi3d-2.49

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pi3d -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 2.49-1
- Package Spec generated