%global _empty_manifest_terminate_build 0
Name:		python-expetator
Version:	0.3.20
Release:	1
Summary:	A framework for monitoring HPC applications using DVFS
License:	GNU General Public License v3 or later (GPLv3+)
URL:		https://gitlab.irit.fr/sepia-pub/expetator
Source0:	https://mirrors.aliyun.com/pypi/web/packages/69/66/570e2a695dcf0f35d2375e2571034678c37e0e1306929c35d94de8efa1ab/expetator-0.3.20.tar.gz
BuildArch:	noarch

Requires:	python3-execo
Requires:	python3-requests

%description
# expetator

A tool for running HPC benchmarks using several type of leverages (DVFS) and low-level monitoring (hardware performance counters, RAPL) mostly on Grid5000.

Documentation is available here: https://expetator.readthedocs.io/

Source code is available here: https://gitlab.irit.fr/sepia-pub/expetator

To install expetator:

	pip3 install expetator




%package -n python3-expetator
Summary:	A framework for monitoring HPC applications using DVFS
Provides:	python-expetator
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-expetator
# expetator

A tool for running HPC benchmarks using several type of leverages (DVFS) and low-level monitoring (hardware performance counters, RAPL) mostly on Grid5000.

Documentation is available here: https://expetator.readthedocs.io/

Source code is available here: https://gitlab.irit.fr/sepia-pub/expetator

To install expetator:

	pip3 install expetator




%package help
Summary:	Development documents and examples for expetator
Provides:	python3-expetator-doc
%description help
# expetator

A tool for running HPC benchmarks using several type of leverages (DVFS) and low-level monitoring (hardware performance counters, RAPL) mostly on Grid5000.

Documentation is available here: https://expetator.readthedocs.io/

Source code is available here: https://gitlab.irit.fr/sepia-pub/expetator

To install expetator:

	pip3 install expetator




%prep
%autosetup -n expetator-0.3.20

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-expetator -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.20-1
- Package Spec generated