%global _empty_manifest_terminate_build 0
Name:		python-sysaudit
Version:	0.3.0
Release:	1
Summary:	Backport module for sys.audit and sys.addaudithook from Python 3.8
License:	MIT
URL:		https://sysaudit.readthedocs.io/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/9b/5b/0d1d45c27928039b524c90ef5c204e3b1ac955267f0203a7b1ed0ef5435c/sysaudit-0.3.0.tar.gz
BuildArch:	noarch


%description
Backport module of `sys.audit <https://docs.python.org/3.8/library/sys.html#sys.audit>`_
and `sys.addaudithook <https://docs.python.org/3.8/library/sys.html#sys.addaudithook>`_
from Python 3.8.
**Note:** This module does *not* backport any of the built-in
`audit events <https://docs.python.org/3.8/library/audit_events.html#audit-events>`_.

%package -n python3-sysaudit
Summary:	Backport module for sys.audit and sys.addaudithook from Python 3.8
Provides:	python-sysaudit
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sysaudit
Backport module of `sys.audit <https://docs.python.org/3.8/library/sys.html#sys.audit>`_
and `sys.addaudithook <https://docs.python.org/3.8/library/sys.html#sys.addaudithook>`_
from Python 3.8.
**Note:** This module does *not* backport any of the built-in
`audit events <https://docs.python.org/3.8/library/audit_events.html#audit-events>`_.

%package help
Summary:	Development documents and examples for sysaudit
Provides:	python3-sysaudit-doc
%description help
Backport module of `sys.audit <https://docs.python.org/3.8/library/sys.html#sys.audit>`_
and `sys.addaudithook <https://docs.python.org/3.8/library/sys.html#sys.addaudithook>`_
from Python 3.8.
**Note:** This module does *not* backport any of the built-in
`audit events <https://docs.python.org/3.8/library/audit_events.html#audit-events>`_.

%prep
%autosetup -n sysaudit-0.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sysaudit -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
- Package Spec generated