%global _empty_manifest_terminate_build 0
Name: python-opal-server
Version: 0.7.0
Release: 1
Summary: OPAL is an administration layer for Open Policy Agent (OPA), detecting changes to both policy and data and pushing live updates to your agents. The opal-server creates a pub/sub channel clients can subscribe to (i.e: acts as coordinator). The server also tracks a git repository (via webhook) for updates to policy (or static data) and accepts continuous data update notifications via REST api, which are then pushed to clients.
License: Apache 2.0
URL: https://github.com/permitio/opal
Source0: https://mirrors.aliyun.com/pypi/web/packages/e8/6d/f873224e2377bd68fcc7c49e921744e99b52f092f70c1b2b161cbf04722d/opal-server-0.7.0.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-permit-broadcaster[kafka,postgres,redis]
Requires: python3-gitpython
Requires: python3-pyjwt[crypto]
Requires: python3-websockets
Requires: python3-ddtrace
Requires: python3-slowapi
Requires: python3-aioredis
Requires: python3-pygit2
Requires: python3-asgiref
Requires: python3-redis
Requires: python3-opal-common
Requires: python3-charset-normalizer
Requires: python3-idna
Requires: python3-typer
Requires: python3-fastapi
Requires: python3-fastapi-websocket-pubsub
Requires: python3-fastapi-websocket-rpc
Requires: python3-gunicorn
Requires: python3-pydantic[email]
Requires: python3-uvicorn[standard]
Requires: python3-fastapi-utils
Requires: python3-setuptools
Requires: python3-typing-extensions
%description
β‘OPALβ‘
Open Policy Administration Layer
## What is OPAL?
OPAL is an administration layer for Open Policy Agent (OPA), detecting changes to both policy and policy data in realtime and pushing live updates to your agents. OPAL brings open-policy up to the speed needed by live applications.
As your application state changes (whether it's via your APIs, DBs, git, S3 or 3rd-party SaaS services), OPAL will make sure your services are always in sync with the authorization data and policy they need (and only those they need).
Check out our main site at OPAL.ac, this video briefly explaining OPAL and how it works with OPA, and a deeper dive into it at [this OWASP DevSlop talk](https://www.youtube.com/watch?v=1_Iz0tRQCH4).
## Why use OPAL?
OPAL is the easiest way to keep your solution's authorization layer up-to-date in realtime. It aggregates policy and data from across the field and integrates them seamlessly into the authorization layer, and is microservices and cloud-native.
## OPA + OPAL = π
While OPA (Open Policy Agent) decouples policy from code in a highly-performant and elegant way, the challenge of keeping policy agents up-to-date remains.
This is especially true in applications, where each user interaction or API call may affect access-control decisions.
OPAL runs in the background, supercharging policy-agents, keeping them in sync with events in realtime.
## Documentation
- π [Full documentation is available here](https://docs.opal.ac)
- π‘ [Intro to OPAL](https://docs.opal.ac/getting-started/intro)
- π Getting Started:
OPAL is available both as **python packages** with a built-in CLI as well as pre-built **docker images** ready-to-go.
- [Play with a live playground environment in docker-compose](https://docs.opal.ac/getting-started/quickstart/opal-playground/overview)
- [Try the getting started guide for containers](https://docs.opal.ac/getting-started/running-opal/overview)
- [Check out the Helm Chart for Kubernetes](https://github.com/permitio/opal-helm-chart)
- A video demo of OPAL is available [here](https://www.youtube.com/watch?v=IkR6EGY3QfM)
- You can also check out this webinar and Q&A about OPAL [on our YouTube channel](https://www.youtube.com/watch?v=A5adHlkmdC0&t=1s)
- πͺ TL;DR - This one command will download and run a working configuration of OPAL server and OPAL client on your machine:
```
curl -L https://raw.githubusercontent.com/permitio/opal/master/docker/docker-compose-example.yml \
> docker-compose.yml && docker-compose up
```
- π§ "How-To"s
- [How to get started with OPAL (Packages and CLI)](https://docs.opal.ac/getting-started/running-opal/as-python-package/overview)
- [How to get started with OPAL (Container Images)](https://docs.opal.ac/getting-started/running-opal/overview)
- [How to trigger Data Updates via OPAL](https://docs.opal.ac/tutorials/trigger_data_updates)
- [How to extend OPAL to fetch data from your sources with FetchProviders](https://docs.opal.ac/tutorials/write_your_own_fetch_provider)
- [How to configure OPAL (basic concepts)](https://docs.opal.ac/tutorials/configure_opal)
- π¨ [Key concepts and design](https://docs.opal.ac/overview/design)
- ποΈ [Architecture](https://docs.opal.ac/overview/architecture)
OPAL uses a client-server stateless architecture. OPAL-Servers publish policy and data updates over a lightweight (websocket) PubSub Channel, which OPAL-clients subscribe to via topics. Upon updates each client fetches data directly (from source) to load it in to its managed OPA instance.
- π For further reading check out our [Blog](https://bit.ly/opal_blog).
## Community
Come talk to us about OPAL, or authorization in general - we would love to hear from you β€οΈ
You can raise questions and ask for features to be added to the road-map in our [**Github discussions**](https://github.com/permitio/opal/discussions), report issues in [**Github issues**](https://github.com/permitio/opal/issues), follow us on Twitter to get the latest OPAL updates, and join our Slack community to chat about authorization, open-source, realtime communication, tech, or anything else!
If you are using our project, please consider giving us a βοΈ
[![Button][join-slack-link]][badge-slack-link] [![Button][follow-twitter-link]][badge-twitter-link]
## Contributing to OPAL
- Pull requests are welcome! (please make sure to include _passing_ tests and docs)
- Prior to submitting a PR - open an issue on GitHub, or make sure your PR addresses an existing issue well.
[join-slack-link]: https://i.ibb.co/wzrGHQL/Group-749.png
[badge-slack-link]: https://io.permit.io/join_community
[follow-twitter-link]: https://i.ibb.co/k4x55Lr/Group-750.png
[badge-twitter-link]: https://twitter.com/opal_ac
## There's more!
- Check out [OPToggles](https://github.com/permitio/OPToggles), which enables you to create user targeted feature flags/toggles based on Open Policy managed authorization rules!
%package -n python3-opal-server
Summary: OPAL is an administration layer for Open Policy Agent (OPA), detecting changes to both policy and data and pushing live updates to your agents. The opal-server creates a pub/sub channel clients can subscribe to (i.e: acts as coordinator). The server also tracks a git repository (via webhook) for updates to policy (or static data) and accepts continuous data update notifications via REST api, which are then pushed to clients.
Provides: python-opal-server
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-opal-server
β‘OPALβ‘
Open Policy Administration Layer
## What is OPAL?
OPAL is an administration layer for Open Policy Agent (OPA), detecting changes to both policy and policy data in realtime and pushing live updates to your agents. OPAL brings open-policy up to the speed needed by live applications.
As your application state changes (whether it's via your APIs, DBs, git, S3 or 3rd-party SaaS services), OPAL will make sure your services are always in sync with the authorization data and policy they need (and only those they need).
Check out our main site at OPAL.ac, this video briefly explaining OPAL and how it works with OPA, and a deeper dive into it at [this OWASP DevSlop talk](https://www.youtube.com/watch?v=1_Iz0tRQCH4).
## Why use OPAL?
OPAL is the easiest way to keep your solution's authorization layer up-to-date in realtime. It aggregates policy and data from across the field and integrates them seamlessly into the authorization layer, and is microservices and cloud-native.
## OPA + OPAL = π
While OPA (Open Policy Agent) decouples policy from code in a highly-performant and elegant way, the challenge of keeping policy agents up-to-date remains.
This is especially true in applications, where each user interaction or API call may affect access-control decisions.
OPAL runs in the background, supercharging policy-agents, keeping them in sync with events in realtime.
## Documentation
- π [Full documentation is available here](https://docs.opal.ac)
- π‘ [Intro to OPAL](https://docs.opal.ac/getting-started/intro)
- π Getting Started:
OPAL is available both as **python packages** with a built-in CLI as well as pre-built **docker images** ready-to-go.
- [Play with a live playground environment in docker-compose](https://docs.opal.ac/getting-started/quickstart/opal-playground/overview)
- [Try the getting started guide for containers](https://docs.opal.ac/getting-started/running-opal/overview)
- [Check out the Helm Chart for Kubernetes](https://github.com/permitio/opal-helm-chart)
- A video demo of OPAL is available [here](https://www.youtube.com/watch?v=IkR6EGY3QfM)
- You can also check out this webinar and Q&A about OPAL [on our YouTube channel](https://www.youtube.com/watch?v=A5adHlkmdC0&t=1s)
- πͺ TL;DR - This one command will download and run a working configuration of OPAL server and OPAL client on your machine:
```
curl -L https://raw.githubusercontent.com/permitio/opal/master/docker/docker-compose-example.yml \
> docker-compose.yml && docker-compose up
```
- π§ "How-To"s
- [How to get started with OPAL (Packages and CLI)](https://docs.opal.ac/getting-started/running-opal/as-python-package/overview)
- [How to get started with OPAL (Container Images)](https://docs.opal.ac/getting-started/running-opal/overview)
- [How to trigger Data Updates via OPAL](https://docs.opal.ac/tutorials/trigger_data_updates)
- [How to extend OPAL to fetch data from your sources with FetchProviders](https://docs.opal.ac/tutorials/write_your_own_fetch_provider)
- [How to configure OPAL (basic concepts)](https://docs.opal.ac/tutorials/configure_opal)
- π¨ [Key concepts and design](https://docs.opal.ac/overview/design)
- ποΈ [Architecture](https://docs.opal.ac/overview/architecture)
OPAL uses a client-server stateless architecture. OPAL-Servers publish policy and data updates over a lightweight (websocket) PubSub Channel, which OPAL-clients subscribe to via topics. Upon updates each client fetches data directly (from source) to load it in to its managed OPA instance.
- π For further reading check out our [Blog](https://bit.ly/opal_blog).
## Community
Come talk to us about OPAL, or authorization in general - we would love to hear from you β€οΈ
You can raise questions and ask for features to be added to the road-map in our [**Github discussions**](https://github.com/permitio/opal/discussions), report issues in [**Github issues**](https://github.com/permitio/opal/issues), follow us on Twitter to get the latest OPAL updates, and join our Slack community to chat about authorization, open-source, realtime communication, tech, or anything else!
If you are using our project, please consider giving us a βοΈ
[![Button][join-slack-link]][badge-slack-link] [![Button][follow-twitter-link]][badge-twitter-link]
## Contributing to OPAL
- Pull requests are welcome! (please make sure to include _passing_ tests and docs)
- Prior to submitting a PR - open an issue on GitHub, or make sure your PR addresses an existing issue well.
[join-slack-link]: https://i.ibb.co/wzrGHQL/Group-749.png
[badge-slack-link]: https://io.permit.io/join_community
[follow-twitter-link]: https://i.ibb.co/k4x55Lr/Group-750.png
[badge-twitter-link]: https://twitter.com/opal_ac
## There's more!
- Check out [OPToggles](https://github.com/permitio/OPToggles), which enables you to create user targeted feature flags/toggles based on Open Policy managed authorization rules!
%package help
Summary: Development documents and examples for opal-server
Provides: python3-opal-server-doc
%description help
β‘OPALβ‘
Open Policy Administration Layer
## What is OPAL?
OPAL is an administration layer for Open Policy Agent (OPA), detecting changes to both policy and policy data in realtime and pushing live updates to your agents. OPAL brings open-policy up to the speed needed by live applications.
As your application state changes (whether it's via your APIs, DBs, git, S3 or 3rd-party SaaS services), OPAL will make sure your services are always in sync with the authorization data and policy they need (and only those they need).
Check out our main site at OPAL.ac, this video briefly explaining OPAL and how it works with OPA, and a deeper dive into it at [this OWASP DevSlop talk](https://www.youtube.com/watch?v=1_Iz0tRQCH4).
## Why use OPAL?
OPAL is the easiest way to keep your solution's authorization layer up-to-date in realtime. It aggregates policy and data from across the field and integrates them seamlessly into the authorization layer, and is microservices and cloud-native.
## OPA + OPAL = π
While OPA (Open Policy Agent) decouples policy from code in a highly-performant and elegant way, the challenge of keeping policy agents up-to-date remains.
This is especially true in applications, where each user interaction or API call may affect access-control decisions.
OPAL runs in the background, supercharging policy-agents, keeping them in sync with events in realtime.
## Documentation
- π [Full documentation is available here](https://docs.opal.ac)
- π‘ [Intro to OPAL](https://docs.opal.ac/getting-started/intro)
- π Getting Started:
OPAL is available both as **python packages** with a built-in CLI as well as pre-built **docker images** ready-to-go.
- [Play with a live playground environment in docker-compose](https://docs.opal.ac/getting-started/quickstart/opal-playground/overview)
- [Try the getting started guide for containers](https://docs.opal.ac/getting-started/running-opal/overview)
- [Check out the Helm Chart for Kubernetes](https://github.com/permitio/opal-helm-chart)
- A video demo of OPAL is available [here](https://www.youtube.com/watch?v=IkR6EGY3QfM)
- You can also check out this webinar and Q&A about OPAL [on our YouTube channel](https://www.youtube.com/watch?v=A5adHlkmdC0&t=1s)
- πͺ TL;DR - This one command will download and run a working configuration of OPAL server and OPAL client on your machine:
```
curl -L https://raw.githubusercontent.com/permitio/opal/master/docker/docker-compose-example.yml \
> docker-compose.yml && docker-compose up
```
- π§ "How-To"s
- [How to get started with OPAL (Packages and CLI)](https://docs.opal.ac/getting-started/running-opal/as-python-package/overview)
- [How to get started with OPAL (Container Images)](https://docs.opal.ac/getting-started/running-opal/overview)
- [How to trigger Data Updates via OPAL](https://docs.opal.ac/tutorials/trigger_data_updates)
- [How to extend OPAL to fetch data from your sources with FetchProviders](https://docs.opal.ac/tutorials/write_your_own_fetch_provider)
- [How to configure OPAL (basic concepts)](https://docs.opal.ac/tutorials/configure_opal)
- π¨ [Key concepts and design](https://docs.opal.ac/overview/design)
- ποΈ [Architecture](https://docs.opal.ac/overview/architecture)
OPAL uses a client-server stateless architecture. OPAL-Servers publish policy and data updates over a lightweight (websocket) PubSub Channel, which OPAL-clients subscribe to via topics. Upon updates each client fetches data directly (from source) to load it in to its managed OPA instance.
- π For further reading check out our [Blog](https://bit.ly/opal_blog).
## Community
Come talk to us about OPAL, or authorization in general - we would love to hear from you β€οΈ
You can raise questions and ask for features to be added to the road-map in our [**Github discussions**](https://github.com/permitio/opal/discussions), report issues in [**Github issues**](https://github.com/permitio/opal/issues), follow us on Twitter to get the latest OPAL updates, and join our Slack community to chat about authorization, open-source, realtime communication, tech, or anything else!
If you are using our project, please consider giving us a βοΈ
[![Button][join-slack-link]][badge-slack-link] [![Button][follow-twitter-link]][badge-twitter-link]
## Contributing to OPAL
- Pull requests are welcome! (please make sure to include _passing_ tests and docs)
- Prior to submitting a PR - open an issue on GitHub, or make sure your PR addresses an existing issue well.
[join-slack-link]: https://i.ibb.co/wzrGHQL/Group-749.png
[badge-slack-link]: https://io.permit.io/join_community
[follow-twitter-link]: https://i.ibb.co/k4x55Lr/Group-750.png
[badge-twitter-link]: https://twitter.com/opal_ac
## There's more!
- Check out [OPToggles](https://github.com/permitio/OPToggles), which enables you to create user targeted feature flags/toggles based on Open Policy managed authorization rules!
%prep
%autosetup -n opal-server-0.7.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-opal-server -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.7.0-1
- Package Spec generated