%global _empty_manifest_terminate_build 0
Name: python-aquacrop
Version: 2.2.3
Release: 1
Summary: Soil-Crop-Water model based on AquaCrop-OS.
License: MIT License
URL: https://github.com/aquacropos/aquacrop
Source0: https://mirrors.aliyun.com/pypi/web/packages/93/27/fc01bb039fe105382bf89fb486e8a030d0607c78e73218cc4a81edfb10ee/aquacrop-2.2.3.tar.gz
BuildArch: noarch
Requires: python3-numba
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-tqdm
Requires: python3-cffi
%description
# AquaCrop-OSPy
Soil-Crop-Water model based on AquaCrop-OS.
![checks](https://badgen.net/github/checks/aquacropos/aquacrop)
![release](https://badgen.net/github/release/aquacropos/aquacrop)
![last-commit](https://badgen.net/github/last-commit/aquacropos/aquacrop)
![license](https://badgen.net/pypi/license/aquacrop)
![python-version](https://badgen.net/pypi/python/aquacrop)
[![image](https://pepy.tech/badge/aquacrop)](https://pepy.tech/project/aquacrop)
[![Downloads](https://pepy.tech/badge/aquacrop/month)](https://pepy.tech/project/aquacrop)
```python
from aquacrop import AquaCropModel, Soil, Crop, InitialWaterContent
from aquacrop.utils import prepare_weather, get_filepath
weather_file_path = get_filepath('tunis_climate.txt')
model_os = AquaCropModel(
sim_start_time=f"{1979}/10/01",
sim_end_time=f"{1985}/05/30",
weather_df=prepare_weather(weather_file_path),
soil=Soil(soil_type='SandyLoam'),
crop=Crop('Wheat', planting_date='10/01'),
initial_water_content=InitialWaterContent(value=['FC']),
)
model_os.run_model(till_termination=True)
model_results = model_os.get_simulation_results().head()
print(model_results)
```
## About
AquaCrop-OSPy is a python implementation of the popular crop-water model AquaCrop, built from the AquaCrop-OS source code.
AquaCrop-OS, an open source version of FAO’s multi-crop model, was released in August 2016 and is the result of collaboration between researchers at the University of Manchester, Water for Food Global Institute, U.N. Food and Agriculture Organization, and Imperial College London.
AquaCrop-OSPy has been designed in way that users can conduct cutting edge research with only basic python experience. In particular for the design and testing of irrigation stratgeies.
Open access journal article here
It is built upon the AquaCropOS crop-growth model written in Matlab ( paper , webpage ) which itself itself is based on the FAO AquaCrop model Webpage . Comparisons to both base models are shown here.
A forum has also been created so that users of AquaCrop-OSPy and AquaCrop-OS can discuss research, bugs and future development.
There is also an extensive documentation for the model
## Install
```bash
pip install aquacrop
```
## Quickstart
A number of tutorials has been created (more to be added in future) to help users jump straight in and run their first simulation. Run these tutorials instantly on Google Colab:
1. Running an AquaCrop-OSPy model
2. Estimation of irrigation water demands
3. Optimisation of irrigation management strategies
4. Projection of climate change impacts
## AquaPlan
The latest development is a streamlit-based web application AquaPlan, a powerful crop management tool that enables farmers, businesses, and governments to make more informed decisions about water management, irrigation investments, and climate risks.
You can access AquaPlan using the following link: https://tinyurl.com/aquaplan.
More information, including screenshots and gifs, can be found at The University of Manchester's [article](https://www.manchester.ac.uk/discover/news/manchester-scientists-launch-new-interactive-tool-for-agricultural-water-management-and-climate-risk-assessment/), Tim Foster's medium [post](https://medium.com/@agwater/aquaplan-a-new-interactive-tool-for-agricultural-water-management-and-climate-risk-assessment-82c50cb10144), or twitter [thread](https://twitter.com/tim_foster_88/status/1557728807758737408).
A seperate [category](https://github.com/aquacropos/aquacrop/discussions/categories/aquaplan) inside the AquaCrop-OSPy forum has been created to discuss
AquaPlan, including any issues, questions, or suggestions.
%package -n python3-aquacrop
Summary: Soil-Crop-Water model based on AquaCrop-OS.
Provides: python-aquacrop
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-aquacrop
# AquaCrop-OSPy
Soil-Crop-Water model based on AquaCrop-OS.
![checks](https://badgen.net/github/checks/aquacropos/aquacrop)
![release](https://badgen.net/github/release/aquacropos/aquacrop)
![last-commit](https://badgen.net/github/last-commit/aquacropos/aquacrop)
![license](https://badgen.net/pypi/license/aquacrop)
![python-version](https://badgen.net/pypi/python/aquacrop)
[![image](https://pepy.tech/badge/aquacrop)](https://pepy.tech/project/aquacrop)
[![Downloads](https://pepy.tech/badge/aquacrop/month)](https://pepy.tech/project/aquacrop)
```python
from aquacrop import AquaCropModel, Soil, Crop, InitialWaterContent
from aquacrop.utils import prepare_weather, get_filepath
weather_file_path = get_filepath('tunis_climate.txt')
model_os = AquaCropModel(
sim_start_time=f"{1979}/10/01",
sim_end_time=f"{1985}/05/30",
weather_df=prepare_weather(weather_file_path),
soil=Soil(soil_type='SandyLoam'),
crop=Crop('Wheat', planting_date='10/01'),
initial_water_content=InitialWaterContent(value=['FC']),
)
model_os.run_model(till_termination=True)
model_results = model_os.get_simulation_results().head()
print(model_results)
```
## About
AquaCrop-OSPy is a python implementation of the popular crop-water model AquaCrop, built from the AquaCrop-OS source code.
AquaCrop-OS, an open source version of FAO’s multi-crop model, was released in August 2016 and is the result of collaboration between researchers at the University of Manchester, Water for Food Global Institute, U.N. Food and Agriculture Organization, and Imperial College London.
AquaCrop-OSPy has been designed in way that users can conduct cutting edge research with only basic python experience. In particular for the design and testing of irrigation stratgeies.
Open access journal article here
It is built upon the AquaCropOS crop-growth model written in Matlab ( paper , webpage ) which itself itself is based on the FAO AquaCrop model Webpage . Comparisons to both base models are shown here.
A forum has also been created so that users of AquaCrop-OSPy and AquaCrop-OS can discuss research, bugs and future development.
There is also an extensive documentation for the model
## Install
```bash
pip install aquacrop
```
## Quickstart
A number of tutorials has been created (more to be added in future) to help users jump straight in and run their first simulation. Run these tutorials instantly on Google Colab:
1. Running an AquaCrop-OSPy model
2. Estimation of irrigation water demands
3. Optimisation of irrigation management strategies
4. Projection of climate change impacts
## AquaPlan
The latest development is a streamlit-based web application AquaPlan, a powerful crop management tool that enables farmers, businesses, and governments to make more informed decisions about water management, irrigation investments, and climate risks.
You can access AquaPlan using the following link: https://tinyurl.com/aquaplan.
More information, including screenshots and gifs, can be found at The University of Manchester's [article](https://www.manchester.ac.uk/discover/news/manchester-scientists-launch-new-interactive-tool-for-agricultural-water-management-and-climate-risk-assessment/), Tim Foster's medium [post](https://medium.com/@agwater/aquaplan-a-new-interactive-tool-for-agricultural-water-management-and-climate-risk-assessment-82c50cb10144), or twitter [thread](https://twitter.com/tim_foster_88/status/1557728807758737408).
A seperate [category](https://github.com/aquacropos/aquacrop/discussions/categories/aquaplan) inside the AquaCrop-OSPy forum has been created to discuss
AquaPlan, including any issues, questions, or suggestions.
%package help
Summary: Development documents and examples for aquacrop
Provides: python3-aquacrop-doc
%description help
# AquaCrop-OSPy
Soil-Crop-Water model based on AquaCrop-OS.
![checks](https://badgen.net/github/checks/aquacropos/aquacrop)
![release](https://badgen.net/github/release/aquacropos/aquacrop)
![last-commit](https://badgen.net/github/last-commit/aquacropos/aquacrop)
![license](https://badgen.net/pypi/license/aquacrop)
![python-version](https://badgen.net/pypi/python/aquacrop)
[![image](https://pepy.tech/badge/aquacrop)](https://pepy.tech/project/aquacrop)
[![Downloads](https://pepy.tech/badge/aquacrop/month)](https://pepy.tech/project/aquacrop)
```python
from aquacrop import AquaCropModel, Soil, Crop, InitialWaterContent
from aquacrop.utils import prepare_weather, get_filepath
weather_file_path = get_filepath('tunis_climate.txt')
model_os = AquaCropModel(
sim_start_time=f"{1979}/10/01",
sim_end_time=f"{1985}/05/30",
weather_df=prepare_weather(weather_file_path),
soil=Soil(soil_type='SandyLoam'),
crop=Crop('Wheat', planting_date='10/01'),
initial_water_content=InitialWaterContent(value=['FC']),
)
model_os.run_model(till_termination=True)
model_results = model_os.get_simulation_results().head()
print(model_results)
```
## About
AquaCrop-OSPy is a python implementation of the popular crop-water model AquaCrop, built from the AquaCrop-OS source code.
AquaCrop-OS, an open source version of FAO’s multi-crop model, was released in August 2016 and is the result of collaboration between researchers at the University of Manchester, Water for Food Global Institute, U.N. Food and Agriculture Organization, and Imperial College London.
AquaCrop-OSPy has been designed in way that users can conduct cutting edge research with only basic python experience. In particular for the design and testing of irrigation stratgeies.
Open access journal article here
It is built upon the AquaCropOS crop-growth model written in Matlab ( paper , webpage ) which itself itself is based on the FAO AquaCrop model Webpage . Comparisons to both base models are shown here.
A forum has also been created so that users of AquaCrop-OSPy and AquaCrop-OS can discuss research, bugs and future development.
There is also an extensive documentation for the model
## Install
```bash
pip install aquacrop
```
## Quickstart
A number of tutorials has been created (more to be added in future) to help users jump straight in and run their first simulation. Run these tutorials instantly on Google Colab:
1. Running an AquaCrop-OSPy model
2. Estimation of irrigation water demands
3. Optimisation of irrigation management strategies
4. Projection of climate change impacts
## AquaPlan
The latest development is a streamlit-based web application AquaPlan, a powerful crop management tool that enables farmers, businesses, and governments to make more informed decisions about water management, irrigation investments, and climate risks.
You can access AquaPlan using the following link: https://tinyurl.com/aquaplan.
More information, including screenshots and gifs, can be found at The University of Manchester's [article](https://www.manchester.ac.uk/discover/news/manchester-scientists-launch-new-interactive-tool-for-agricultural-water-management-and-climate-risk-assessment/), Tim Foster's medium [post](https://medium.com/@agwater/aquaplan-a-new-interactive-tool-for-agricultural-water-management-and-climate-risk-assessment-82c50cb10144), or twitter [thread](https://twitter.com/tim_foster_88/status/1557728807758737408).
A seperate [category](https://github.com/aquacropos/aquacrop/discussions/categories/aquaplan) inside the AquaCrop-OSPy forum has been created to discuss
AquaPlan, including any issues, questions, or suggestions.
%prep
%autosetup -n aquacrop-2.2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-aquacrop -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.2.3-1
- Package Spec generated