%global _empty_manifest_terminate_build 0
Name:		python-ydb
Version:	3.3.4
Release:	1
Summary:	YDB Python SDK
License:	Apache 2.0
URL:		http://github.com/ydb-platform/ydb-python-sdk
Source0:	https://mirrors.aliyun.com/pypi/web/packages/b3/1d/8ee28470484f9f84af2a15aea9688bbbb49e7438df6a64413421249def66/ydb-3.3.4.tar.gz
BuildArch:	noarch

Requires:	python3-grpcio
Requires:	python3-packaging
Requires:	python3-protobuf
Requires:	python3-aiohttp
Requires:	python3-yandexcloud

%description
[![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://github.com/ydb-platform/ydb/blob/main/LICENSE)
[![PyPI version](https://badge.fury.io/py/ydb.svg)](https://badge.fury.io/py/ydb)
[![Functional tests](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/tests.yaml/badge.svg)](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/tests.yaml)
[![Style checks](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/style.yaml/badge.svg)](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/style.yaml)
Officially supported Python client for YDB.
## Quickstart
### Prerequisites
- Python 3.8 or higher
- `pip` version 9.0.1 or higher
If necessary, upgrade your version of `pip`:
```sh
$ python -m pip install --upgrade pip
```
If you cannot upgrade `pip` due to a system-owned installation, you can
run the example in a virtualenv:
```sh
$ python -m pip install virtualenv
$ virtualenv venv
$ source venv/bin/activate
$ python -m pip install --upgrade pip
```
Install YDB python sdk:
```sh
$ python -m pip install ydb
```

%package -n python3-ydb
Summary:	YDB Python SDK
Provides:	python-ydb
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ydb
[![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://github.com/ydb-platform/ydb/blob/main/LICENSE)
[![PyPI version](https://badge.fury.io/py/ydb.svg)](https://badge.fury.io/py/ydb)
[![Functional tests](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/tests.yaml/badge.svg)](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/tests.yaml)
[![Style checks](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/style.yaml/badge.svg)](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/style.yaml)
Officially supported Python client for YDB.
## Quickstart
### Prerequisites
- Python 3.8 or higher
- `pip` version 9.0.1 or higher
If necessary, upgrade your version of `pip`:
```sh
$ python -m pip install --upgrade pip
```
If you cannot upgrade `pip` due to a system-owned installation, you can
run the example in a virtualenv:
```sh
$ python -m pip install virtualenv
$ virtualenv venv
$ source venv/bin/activate
$ python -m pip install --upgrade pip
```
Install YDB python sdk:
```sh
$ python -m pip install ydb
```

%package help
Summary:	Development documents and examples for ydb
Provides:	python3-ydb-doc
%description help
[![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://github.com/ydb-platform/ydb/blob/main/LICENSE)
[![PyPI version](https://badge.fury.io/py/ydb.svg)](https://badge.fury.io/py/ydb)
[![Functional tests](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/tests.yaml/badge.svg)](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/tests.yaml)
[![Style checks](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/style.yaml/badge.svg)](https://github.com/ydb-platform/ydb-python-sdk/actions/workflows/style.yaml)
Officially supported Python client for YDB.
## Quickstart
### Prerequisites
- Python 3.8 or higher
- `pip` version 9.0.1 or higher
If necessary, upgrade your version of `pip`:
```sh
$ python -m pip install --upgrade pip
```
If you cannot upgrade `pip` due to a system-owned installation, you can
run the example in a virtualenv:
```sh
$ python -m pip install virtualenv
$ virtualenv venv
$ source venv/bin/activate
$ python -m pip install --upgrade pip
```
Install YDB python sdk:
```sh
$ python -m pip install ydb
```

%prep
%autosetup -n ydb-3.3.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ydb -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 3.3.4-1
- Package Spec generated