%global _empty_manifest_terminate_build 0
Name:		python-django-autoconfig
Version:	0.8.0
Release:	1
Summary:	Automatic configuration of Django projects based on the application requirements.
License:	GNU General Public License v3 or later (GPLv3+)
URL:		https://github.com/mikebryant/django-autoconfig
Source0:	https://mirrors.aliyun.com/pypi/web/packages/1f/34/a1500b9d125111fa62b8eea58b2dad6b32713b3e5c466fe30f13cb77b4b9/django-autoconfig-0.8.0.tar.gz
BuildArch:	noarch

Requires:	python3-django

%description


%package -n python3-django-autoconfig
Summary:	Automatic configuration of Django projects based on the application requirements.
Provides:	python-django-autoconfig
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-autoconfig


%package help
Summary:	Development documents and examples for django-autoconfig
Provides:	python3-django-autoconfig-doc
%description help


%prep
%autosetup -n django-autoconfig-0.8.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-autoconfig -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.0-1
- Package Spec generated