%global _empty_manifest_terminate_build 0
Name:		python-snmp
Version:	0.5.0
Release:	1
Summary:	A user-friendly SNMP library
License:	MIT
URL:		https://github.com/charlestolley/python-snmp
Source0:	https://mirrors.aliyun.com/pypi/web/packages/f9/93/4351f64402baa47ca6051f2fc6ae84015207821abc2a872faffd7b78b1cd/snmp-0.5.0.tar.gz

Requires:	python3-cffi

%description
## Installation
This library is available in PyPi under the name `snmp`. Installation is as simple as

    pip install snmp

If you are having trouble importing the snmp.security.usm.priv module, see [this section](https://python-snmp.readthedocs.io/en/latest/installation.html#integration-with-openssl) of the documentation.

## Documentation
Documentation for this library, including a simple tutorial and a library reference, is available in [ReadTheDocs](https://python-snmp.readthedocs.io).


%package -n python3-snmp
Summary:	A user-friendly SNMP library
Provides:	python-snmp
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-snmp
## Installation
This library is available in PyPi under the name `snmp`. Installation is as simple as

    pip install snmp

If you are having trouble importing the snmp.security.usm.priv module, see [this section](https://python-snmp.readthedocs.io/en/latest/installation.html#integration-with-openssl) of the documentation.

## Documentation
Documentation for this library, including a simple tutorial and a library reference, is available in [ReadTheDocs](https://python-snmp.readthedocs.io).


%package help
Summary:	Development documents and examples for snmp
Provides:	python3-snmp-doc
%description help
## Installation
This library is available in PyPi under the name `snmp`. Installation is as simple as

    pip install snmp

If you are having trouble importing the snmp.security.usm.priv module, see [this section](https://python-snmp.readthedocs.io/en/latest/installation.html#integration-with-openssl) of the documentation.

## Documentation
Documentation for this library, including a simple tutorial and a library reference, is available in [ReadTheDocs](https://python-snmp.readthedocs.io).


%prep
%autosetup -n snmp-0.5.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-snmp -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.0-1
- Package Spec generated