%global _empty_manifest_terminate_build 0
Name:		python-trytond-stock-supply-production
Version:	6.8.0
Release:	1
Summary:	Tryton module for stock supply of production
License:	GPL-3
URL:		http://www.tryton.org/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/ba/53/7b2ef623c8bfa691ba1521d049dd7fa1e6d0464fd63167d998eb6653fa83/trytond_stock_supply_production-6.8.0.tar.gz
BuildArch:	noarch

Requires:	python3-trytond-product
Requires:	python3-trytond-production
Requires:	python3-trytond-stock
Requires:	python3-trytond-stock-supply
Requires:	python3-trytond
Requires:	python3-proteus

%description
Stock Supply Production Module
##############################

The Stock Supply Production module adds automatic supply mechanisms via
production request.

Production Request
******************

A production request is a production in the state request. It defines the need
to produce a product.


Order Point
***********

It adds a new type of Order Point:

* Production

  A Production order point is defined on a warehouse location. If the minimal
  quantity is reached at any time on the warehouse it will result in a
  production request.

The production requests are created by the supply wizard with respect to stock
levels and existing requests. The stock levels are computed on the supply
period define in the production configuration.


%package -n python3-trytond-stock-supply-production
Summary:	Tryton module for stock supply of production
Provides:	python-trytond-stock-supply-production
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-trytond-stock-supply-production
Stock Supply Production Module
##############################

The Stock Supply Production module adds automatic supply mechanisms via
production request.

Production Request
******************

A production request is a production in the state request. It defines the need
to produce a product.


Order Point
***********

It adds a new type of Order Point:

* Production

  A Production order point is defined on a warehouse location. If the minimal
  quantity is reached at any time on the warehouse it will result in a
  production request.

The production requests are created by the supply wizard with respect to stock
levels and existing requests. The stock levels are computed on the supply
period define in the production configuration.


%package help
Summary:	Development documents and examples for trytond-stock-supply-production
Provides:	python3-trytond-stock-supply-production-doc
%description help
Stock Supply Production Module
##############################

The Stock Supply Production module adds automatic supply mechanisms via
production request.

Production Request
******************

A production request is a production in the state request. It defines the need
to produce a product.


Order Point
***********

It adds a new type of Order Point:

* Production

  A Production order point is defined on a warehouse location. If the minimal
  quantity is reached at any time on the warehouse it will result in a
  production request.

The production requests are created by the supply wizard with respect to stock
levels and existing requests. The stock levels are computed on the supply
period define in the production configuration.


%prep
%autosetup -n trytond_stock_supply_production-6.8.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-trytond-stock-supply-production -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 6.8.0-1
- Package Spec generated