%global _empty_manifest_terminate_build 0
Name: python-seatable-api
Version: 2.6.4
Release: 1
Summary: Python client for SeaTable web api
License: Apache Licence
URL: https://github.com/seatable/seatable-api-python
Source0: https://mirrors.aliyun.com/pypi/web/packages/de/20/070cbca657403ac0af1a45ca5aa6f5da406bc1c22780eed7e8c364b213e9/seatable-api-2.6.4.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-socketio
Requires: python3-ply
Requires: python3-dateutil
%description
# seatable-api-python
Python client for SeaTable web api
English document:
Chinese document:
pypi:
github:
%package -n python3-seatable-api
Summary: Python client for SeaTable web api
Provides: python-seatable-api
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-seatable-api
# seatable-api-python
Python client for SeaTable web api
English document:
Chinese document:
pypi:
github:
%package help
Summary: Development documents and examples for seatable-api
Provides: python3-seatable-api-doc
%description help
# seatable-api-python
Python client for SeaTable web api
English document:
Chinese document:
pypi:
github:
%prep
%autosetup -n seatable-api-2.6.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-seatable-api -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.6.4-1
- Package Spec generated