%global _empty_manifest_terminate_build 0
Name:		python-Pyostie
Version:	2.6.2
Release:	1
Summary:	A python package to OCR data and extract text with insights too.
License:	MIT License
URL:		https://github.com/anirudhpnbb/Pyostie
Source0:	https://mirrors.aliyun.com/pypi/web/packages/82/bb/650b021840f92b096c6697c89d3392699da4da407ed0d47044c99fe75626/Pyostie-2.6.2.tar.gz
BuildArch:	noarch

Requires:	python3-opencv-python
Requires:	python3-numpy
Requires:	python3-pandas
Requires:	python3-PyPDF2
Requires:	python3-pdfplumber
Requires:	python3-xlrd
Requires:	python3-docx2txt
Requires:	python3-pytesseract
Requires:	python3-Pillow
Requires:	python3-SpeechRecognition

%description
https://anirudhpnbb.github.io/Pyostie




%package -n python3-Pyostie
Summary:	A python package to OCR data and extract text with insights too.
Provides:	python-Pyostie
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Pyostie
https://anirudhpnbb.github.io/Pyostie




%package help
Summary:	Development documents and examples for Pyostie
Provides:	python3-Pyostie-doc
%description help
https://anirudhpnbb.github.io/Pyostie




%prep
%autosetup -n Pyostie-2.6.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Pyostie -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 2.6.2-1
- Package Spec generated