%global _empty_manifest_terminate_build 0
Name:		python-scalr-ctl
Version:	7.16.2
Release:	1
Summary:	Scalr-ctl is a command-line interface to your Scalr account
License:	Apache-2
URL:		https://scalr.net
Source0:	https://mirrors.aliyun.com/pypi/web/packages/9a/3e/0c448ee93434d19b09e93b2893c69c488186f87c9c4abc9ef6f50167115a/scalr-ctl-7.16.2.tar.gz
BuildArch:	noarch


%description
  scalr-ctl is a command-line interface to your Scalr account


  Version 1.0 works with the new Scalr JSON API.

Install:

  $ pip install scalr-ctl


Configure:

  $ scalr-ctl configure


Use:

  $ scalr-ctl --help

  $ scalr-ctl <tab> <tab>


Update:

  $ pip install --upgrade scalr-ctl

  $ scalr-ctl update

%package -n python3-scalr-ctl
Summary:	Scalr-ctl is a command-line interface to your Scalr account
Provides:	python-scalr-ctl
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-scalr-ctl
  scalr-ctl is a command-line interface to your Scalr account


  Version 1.0 works with the new Scalr JSON API.

Install:

  $ pip install scalr-ctl


Configure:

  $ scalr-ctl configure


Use:

  $ scalr-ctl --help

  $ scalr-ctl <tab> <tab>


Update:

  $ pip install --upgrade scalr-ctl

  $ scalr-ctl update

%package help
Summary:	Development documents and examples for scalr-ctl
Provides:	python3-scalr-ctl-doc
%description help
  scalr-ctl is a command-line interface to your Scalr account


  Version 1.0 works with the new Scalr JSON API.

Install:

  $ pip install scalr-ctl


Configure:

  $ scalr-ctl configure


Use:

  $ scalr-ctl --help

  $ scalr-ctl <tab> <tab>


Update:

  $ pip install --upgrade scalr-ctl

  $ scalr-ctl update

%prep
%autosetup -n scalr-ctl-7.16.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-scalr-ctl -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 7.16.2-1
- Package Spec generated