%global _empty_manifest_terminate_build 0
Name:		python-HTTPolice
Version:	0.9.0
Release:	1
Summary:	Validator for HTTP
License:	MIT
URL:		https://github.com/vfaronov/httpolice
Source0:	https://mirrors.aliyun.com/pypi/web/packages/b8/7b/07a3583482e951019952dc7d183eb04ea7b23e4eac9ef2a04b4f83e57065/HTTPolice-0.9.0.tar.gz
BuildArch:	noarch

Requires:	python3-lxml
Requires:	python3-bitstring
Requires:	python3-dominate
Requires:	python3-defusedxml
Requires:	python3-Brotli

%description
HTTPolice is a **validator or “linter” for HTTP requests and responses**.
It can spot bad header syntax, inappropriate status codes, and other potential
problems in your HTTP server or client.
See `example report`__.
__ https://httpolice.readthedocs.io/page/showcase.html
As a command-line tool, it can read `HAR files`__ or raw HTTP/1.x TCP streams.
It can `integrate with mitmproxy`__ for TLS-encrypted and HTTP/2 traffic.
Or you can use it as a Python (3.4+) library.
There is a `Django integration`__ package and a third-party `Chrome extension`__.
__ https://en.wikipedia.org/wiki/.har
__ https://github.com/vfaronov/mitmproxy-httpolice
__ https://github.com/vfaronov/django-httpolice
__ https://chrome.google.com/webstore/detail/httpolice-devtool/hnlnhebgfcfemjaphgbeokdnfpgbnhgn
Start with the `quickstart`__.
__ https://httpolice.readthedocs.io/page/quickstart.html
A full `user manual`__ is available.
Also, a `list of all problems`__ HTTPolice can detect.
__ https://httpolice.readthedocs.io/
__ https://httpolice.readthedocs.io/page/notices.html
HTTPolice was partly inspired by `REDbot`__, another QA tool for the Web.
But the approach is different: instead of actively testing your server,
HTTPolice just analyzes anything you feed into it.
Thus, it can be used on requests and responses captured
from a real process or test suite.
__ https://redbot.org/
HTTPolice is hosted `on GitHub`__
and released under the MIT license (see ``LICENSE.txt``).
If you want to hack on HTTPolice, check out ``HACKING.rst``.
__ https://github.com/vfaronov/httpolice
`BrowserStack`__ kindly provide a free subscription for testing HTTPolice.
__ https://www.browserstack.com/

%package -n python3-HTTPolice
Summary:	Validator for HTTP
Provides:	python-HTTPolice
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-HTTPolice
HTTPolice is a **validator or “linter” for HTTP requests and responses**.
It can spot bad header syntax, inappropriate status codes, and other potential
problems in your HTTP server or client.
See `example report`__.
__ https://httpolice.readthedocs.io/page/showcase.html
As a command-line tool, it can read `HAR files`__ or raw HTTP/1.x TCP streams.
It can `integrate with mitmproxy`__ for TLS-encrypted and HTTP/2 traffic.
Or you can use it as a Python (3.4+) library.
There is a `Django integration`__ package and a third-party `Chrome extension`__.
__ https://en.wikipedia.org/wiki/.har
__ https://github.com/vfaronov/mitmproxy-httpolice
__ https://github.com/vfaronov/django-httpolice
__ https://chrome.google.com/webstore/detail/httpolice-devtool/hnlnhebgfcfemjaphgbeokdnfpgbnhgn
Start with the `quickstart`__.
__ https://httpolice.readthedocs.io/page/quickstart.html
A full `user manual`__ is available.
Also, a `list of all problems`__ HTTPolice can detect.
__ https://httpolice.readthedocs.io/
__ https://httpolice.readthedocs.io/page/notices.html
HTTPolice was partly inspired by `REDbot`__, another QA tool for the Web.
But the approach is different: instead of actively testing your server,
HTTPolice just analyzes anything you feed into it.
Thus, it can be used on requests and responses captured
from a real process or test suite.
__ https://redbot.org/
HTTPolice is hosted `on GitHub`__
and released under the MIT license (see ``LICENSE.txt``).
If you want to hack on HTTPolice, check out ``HACKING.rst``.
__ https://github.com/vfaronov/httpolice
`BrowserStack`__ kindly provide a free subscription for testing HTTPolice.
__ https://www.browserstack.com/

%package help
Summary:	Development documents and examples for HTTPolice
Provides:	python3-HTTPolice-doc
%description help
HTTPolice is a **validator or “linter” for HTTP requests and responses**.
It can spot bad header syntax, inappropriate status codes, and other potential
problems in your HTTP server or client.
See `example report`__.
__ https://httpolice.readthedocs.io/page/showcase.html
As a command-line tool, it can read `HAR files`__ or raw HTTP/1.x TCP streams.
It can `integrate with mitmproxy`__ for TLS-encrypted and HTTP/2 traffic.
Or you can use it as a Python (3.4+) library.
There is a `Django integration`__ package and a third-party `Chrome extension`__.
__ https://en.wikipedia.org/wiki/.har
__ https://github.com/vfaronov/mitmproxy-httpolice
__ https://github.com/vfaronov/django-httpolice
__ https://chrome.google.com/webstore/detail/httpolice-devtool/hnlnhebgfcfemjaphgbeokdnfpgbnhgn
Start with the `quickstart`__.
__ https://httpolice.readthedocs.io/page/quickstart.html
A full `user manual`__ is available.
Also, a `list of all problems`__ HTTPolice can detect.
__ https://httpolice.readthedocs.io/
__ https://httpolice.readthedocs.io/page/notices.html
HTTPolice was partly inspired by `REDbot`__, another QA tool for the Web.
But the approach is different: instead of actively testing your server,
HTTPolice just analyzes anything you feed into it.
Thus, it can be used on requests and responses captured
from a real process or test suite.
__ https://redbot.org/
HTTPolice is hosted `on GitHub`__
and released under the MIT license (see ``LICENSE.txt``).
If you want to hack on HTTPolice, check out ``HACKING.rst``.
__ https://github.com/vfaronov/httpolice
`BrowserStack`__ kindly provide a free subscription for testing HTTPolice.
__ https://www.browserstack.com/

%prep
%autosetup -n HTTPolice-0.9.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-HTTPolice -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.0-1
- Package Spec generated