%global _empty_manifest_terminate_build 0
Name: python-Facebooker
Version: 1.3.1
Release: 1
Summary: An un official facebook api
License: MIT License
URL: https://github.com/gpwork4u/Facebooker
Source0: https://mirrors.aliyun.com/pypi/web/packages/95/04/2bc0cf41570165c2895d8b819024ae752df64eaa36f6cc48f3ed7a4ad699/Facebooker-1.3.1.tar.gz
BuildArch: noarch
Requires: python3-lxml
Requires: python3-beautifulsoup4
Requires: python3-requests
Requires: python3-requests-toolbelt
%description
# Facebooker
An unofficial facebook api
## Requirement
- [ ] python3.6
## Dependencies
- [ ] lxml
- [ ] requests
- [ ] bs4
- [ ] requests_toolbelt
### Install
```
$ pip install Facebooker
```
## Document
see [doc.md](https://github.com/gpwork4u/Facebooker/blob/master/doc.md)
%package -n python3-Facebooker
Summary: An un official facebook api
Provides: python-Facebooker
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Facebooker
# Facebooker
An unofficial facebook api
## Requirement
- [ ] python3.6
## Dependencies
- [ ] lxml
- [ ] requests
- [ ] bs4
- [ ] requests_toolbelt
### Install
```
$ pip install Facebooker
```
## Document
see [doc.md](https://github.com/gpwork4u/Facebooker/blob/master/doc.md)
%package help
Summary: Development documents and examples for Facebooker
Provides: python3-Facebooker-doc
%description help
# Facebooker
An unofficial facebook api
## Requirement
- [ ] python3.6
## Dependencies
- [ ] lxml
- [ ] requests
- [ ] bs4
- [ ] requests_toolbelt
### Install
```
$ pip install Facebooker
```
## Document
see [doc.md](https://github.com/gpwork4u/Facebooker/blob/master/doc.md)
%prep
%autosetup -n Facebooker-1.3.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Facebooker -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.3.1-1
- Package Spec generated