%global _empty_manifest_terminate_build 0
Name:		python-presto
Version:	0.7.1
Release:	1
Summary:	A bioinformatics toolkit for processing high-throughput lymphocyte receptor sequencing data.
License:	GNU Affero General Public License 3 (AGPL-3)
URL:		http://presto.readthedocs.io
Source0:	https://mirrors.aliyun.com/pypi/web/packages/ca/12/09123b431758827082924054e03277207067853c6af19803f67d1ad1dea9/presto-0.7.1.tar.gz
BuildArch:	noarch


%description
pRESTO is a toolkit for processing raw reads from high-throughput sequencing of
B cell and T cell repertoires.
Dramatic improvements in high-throughput sequencing technologies now enable
large-scale characterization of lymphocyte repertoires, defined as the
collection of trans-membrane antigen-receptor proteins located on the surface of
B cells and T cells. The REpertoire Sequencing TOolkit (pRESTO) is composed of a
suite of utilities to handle all stages of sequence processing prior to germline
segment assignment. pRESTO is designed to handle either single reads or
paired-end reads. It includes features for quality control, primer masking,
annotation of reads with sequence embedded barcodes, generation of
unique molecular identifier (UMI) consensus sequences, assembly of paired-end 
reads and identification of duplicate sequences. Numerous options for sequence 
sorting, sampling and conversion operations are also included.

%package -n python3-presto
Summary:	A bioinformatics toolkit for processing high-throughput lymphocyte receptor sequencing data.
Provides:	python-presto
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-presto
pRESTO is a toolkit for processing raw reads from high-throughput sequencing of
B cell and T cell repertoires.
Dramatic improvements in high-throughput sequencing technologies now enable
large-scale characterization of lymphocyte repertoires, defined as the
collection of trans-membrane antigen-receptor proteins located on the surface of
B cells and T cells. The REpertoire Sequencing TOolkit (pRESTO) is composed of a
suite of utilities to handle all stages of sequence processing prior to germline
segment assignment. pRESTO is designed to handle either single reads or
paired-end reads. It includes features for quality control, primer masking,
annotation of reads with sequence embedded barcodes, generation of
unique molecular identifier (UMI) consensus sequences, assembly of paired-end 
reads and identification of duplicate sequences. Numerous options for sequence 
sorting, sampling and conversion operations are also included.

%package help
Summary:	Development documents and examples for presto
Provides:	python3-presto-doc
%description help
pRESTO is a toolkit for processing raw reads from high-throughput sequencing of
B cell and T cell repertoires.
Dramatic improvements in high-throughput sequencing technologies now enable
large-scale characterization of lymphocyte repertoires, defined as the
collection of trans-membrane antigen-receptor proteins located on the surface of
B cells and T cells. The REpertoire Sequencing TOolkit (pRESTO) is composed of a
suite of utilities to handle all stages of sequence processing prior to germline
segment assignment. pRESTO is designed to handle either single reads or
paired-end reads. It includes features for quality control, primer masking,
annotation of reads with sequence embedded barcodes, generation of
unique molecular identifier (UMI) consensus sequences, assembly of paired-end 
reads and identification of duplicate sequences. Numerous options for sequence 
sorting, sampling and conversion operations are also included.

%prep
%autosetup -n presto-0.7.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-presto -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.1-1
- Package Spec generated