%global _empty_manifest_terminate_build 0
Name: python-starknet-devnet
Version: 0.5.3
Release: 1
Summary: A local testnet for Starknet
License: MIT
URL: https://github.com/0xSpaceShard/starknet-devnet
Source0: https://mirrors.aliyun.com/pypi/web/packages/7c/50/454efc04fab966429d3763fb54abd2d3eb86ca83b015412aca514e4e2e6b/starknet_devnet-0.5.3.tar.gz
BuildArch: noarch
Requires: python3-flask-cors
Requires: python3-cairo-lang
Requires: python3-Werkzeug
Requires: python3-Flask[async]
Requires: python3-cloudpickle
Requires: python3-crypto-cpp-py
Requires: python3-marshmallow
Requires: python3-typing-extensions
Requires: python3-gunicorn
Requires: python3-marshmallow-dataclass
Requires: python3-jsonschema
Requires: python3-web3
Requires: python3-poseidon-py
%description
Starknet Devnet
A Flask wrapper of Starknet state. Similar in purpose to Ganache.
Aims to mimic Starknet's Alpha testnet, but with simplified functionality.
## 🌐 Docs
On the following links you can find the documentation of:
- [the latest official release](https://0xspaceshard.github.io/starknet-devnet/)
- [the latest master commit (not officially released)](https://github.com/0xSpaceShard/starknet-devnet/tree/master/page/docs)
## ✏️ Contributing
We ❤️ and encourage all contributions!
[Click here](https://0xspaceshard.github.io/starknet-devnet/docs/guide/development) for the development guide.
## 🙌 Special Thanks
Special thanks to all the [contributors](https://github.com/0xSpaceShard/starknet-devnet/graphs/contributors)!
%package -n python3-starknet-devnet
Summary: A local testnet for Starknet
Provides: python-starknet-devnet
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-starknet-devnet
Starknet Devnet
A Flask wrapper of Starknet state. Similar in purpose to Ganache.
Aims to mimic Starknet's Alpha testnet, but with simplified functionality.
## 🌐 Docs
On the following links you can find the documentation of:
- [the latest official release](https://0xspaceshard.github.io/starknet-devnet/)
- [the latest master commit (not officially released)](https://github.com/0xSpaceShard/starknet-devnet/tree/master/page/docs)
## ✏️ Contributing
We ❤️ and encourage all contributions!
[Click here](https://0xspaceshard.github.io/starknet-devnet/docs/guide/development) for the development guide.
## 🙌 Special Thanks
Special thanks to all the [contributors](https://github.com/0xSpaceShard/starknet-devnet/graphs/contributors)!
%package help
Summary: Development documents and examples for starknet-devnet
Provides: python3-starknet-devnet-doc
%description help
Starknet Devnet
A Flask wrapper of Starknet state. Similar in purpose to Ganache.
Aims to mimic Starknet's Alpha testnet, but with simplified functionality.
## 🌐 Docs
On the following links you can find the documentation of:
- [the latest official release](https://0xspaceshard.github.io/starknet-devnet/)
- [the latest master commit (not officially released)](https://github.com/0xSpaceShard/starknet-devnet/tree/master/page/docs)
## ✏️ Contributing
We ❤️ and encourage all contributions!
[Click here](https://0xspaceshard.github.io/starknet-devnet/docs/guide/development) for the development guide.
## 🙌 Special Thanks
Special thanks to all the [contributors](https://github.com/0xSpaceShard/starknet-devnet/graphs/contributors)!
%prep
%autosetup -n starknet_devnet-0.5.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-starknet-devnet -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.5.3-1
- Package Spec generated