%global _empty_manifest_terminate_build 0
Name:		python-kuiper
Version:	0.8.15
Release:	1
Summary:	A terminal-based dating application for UTD students
License:	GPL-3.0-only
URL:		https://github.com/CharlesAverill/kuiper
Source0:	https://mirrors.aliyun.com/pypi/web/packages/70/36/055f2ea03453d128bf9ab87fd24c8e84f84d156f38017e651487111141af/kuiper-0.8.15.tar.gz
BuildArch:	noarch

Requires:	python3-email-validator
Requires:	python3-PyYAML
Requires:	python3-sqlalchemy
Requires:	python3-update-checker
Requires:	python3-websockets
Requires:	python3-werkzeug

%description
# Kuiper

A terminal-based dating application for UTD students, built with the `curses` API.

## Installation

Unfamiliar with terminal stuff? Here's what you need to start using Kuiper:

1. [Install Python](https://www.python.org/downloads/release/python-379/)
2. Open up your terminal or command line
3. Type in `python3 -m pip install kuiper`. You may receive some nasty output, that's alright. Mac users might need to install XCode tools
4. Now you're ready to use Kuiper! Just type `kuiper` into your command line, and the TUI should boot.

## Usage
```bash
$ kuiper                       # Start the TUI
$ kuiper -c USERNAME PASSWORD  # Login with credentials
$ kuiper -d                    # Print configs
$ kuiper -i                    # Initialize the database
$ kuiper -h                    # View the help menu
$ kuiper -l new_configs.yaml   # Update server configs
$ kuiper --local_server        # Connect to localhost server
$ kuiper -q                    # Suppress server output
$ kuiper -s                    # Start server
```

Menu navigation is controlled by the up and down arrow keys.

When filling out a form field, the string in the bottom-right corner is the current buffer. 
Hit "Enter" to save the form field.

## Configs

The follow are the configuration options supported by Kuiper. 

To modify Kuiper's configs, create a `config.yaml` file with the keys and values you'd like to overwrite, 
and call `kuiper -l config.yaml`

| Config | Default Value | Description |
| --- | --- | --- |
| bind_host | "127.0.0.1" | The address on which the server will be hosted via `kuiper -s` |
| port | 8000 | The port on which the server will be hosted via `kuiper -s`
| access_host | "35.172.42.184" | The address to the server the client will ping. The defualt value is the static IP address of Kuiper's main server |
| db_path | "kuiper.db" | The path to the server's user and post database |
| required_email_suffix | "@utdallas.edu" | The email suffix required during registration. For no requirement, set to `""` |
| org_name | "UTD" | The organization name to be displayed at login and registration |
| server_email_username/password | None/None | The login information for the email the server will use to send email verification codes |
| server_email_smtp_addr/port | "smtp.gmail.com"/465 | The SMTP address/port used to send emails |
| text_editor | "vim" | The text editor called via the `subprocess` module to write posts and comments |


## Inspiration
[UTD Bruh Moments IG Post](https://www.instagram.com/p/CRCJhEmpbI0/)

[Original Reddit Post](https://www.reddit.com/r/utdallas/comments/od9roi/how_easy_is_it_to_find_men_above_the_age_of_23_at/)


%package -n python3-kuiper
Summary:	A terminal-based dating application for UTD students
Provides:	python-kuiper
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-kuiper
# Kuiper

A terminal-based dating application for UTD students, built with the `curses` API.

## Installation

Unfamiliar with terminal stuff? Here's what you need to start using Kuiper:

1. [Install Python](https://www.python.org/downloads/release/python-379/)
2. Open up your terminal or command line
3. Type in `python3 -m pip install kuiper`. You may receive some nasty output, that's alright. Mac users might need to install XCode tools
4. Now you're ready to use Kuiper! Just type `kuiper` into your command line, and the TUI should boot.

## Usage
```bash
$ kuiper                       # Start the TUI
$ kuiper -c USERNAME PASSWORD  # Login with credentials
$ kuiper -d                    # Print configs
$ kuiper -i                    # Initialize the database
$ kuiper -h                    # View the help menu
$ kuiper -l new_configs.yaml   # Update server configs
$ kuiper --local_server        # Connect to localhost server
$ kuiper -q                    # Suppress server output
$ kuiper -s                    # Start server
```

Menu navigation is controlled by the up and down arrow keys.

When filling out a form field, the string in the bottom-right corner is the current buffer. 
Hit "Enter" to save the form field.

## Configs

The follow are the configuration options supported by Kuiper. 

To modify Kuiper's configs, create a `config.yaml` file with the keys and values you'd like to overwrite, 
and call `kuiper -l config.yaml`

| Config | Default Value | Description |
| --- | --- | --- |
| bind_host | "127.0.0.1" | The address on which the server will be hosted via `kuiper -s` |
| port | 8000 | The port on which the server will be hosted via `kuiper -s`
| access_host | "35.172.42.184" | The address to the server the client will ping. The defualt value is the static IP address of Kuiper's main server |
| db_path | "kuiper.db" | The path to the server's user and post database |
| required_email_suffix | "@utdallas.edu" | The email suffix required during registration. For no requirement, set to `""` |
| org_name | "UTD" | The organization name to be displayed at login and registration |
| server_email_username/password | None/None | The login information for the email the server will use to send email verification codes |
| server_email_smtp_addr/port | "smtp.gmail.com"/465 | The SMTP address/port used to send emails |
| text_editor | "vim" | The text editor called via the `subprocess` module to write posts and comments |


## Inspiration
[UTD Bruh Moments IG Post](https://www.instagram.com/p/CRCJhEmpbI0/)

[Original Reddit Post](https://www.reddit.com/r/utdallas/comments/od9roi/how_easy_is_it_to_find_men_above_the_age_of_23_at/)


%package help
Summary:	Development documents and examples for kuiper
Provides:	python3-kuiper-doc
%description help
# Kuiper

A terminal-based dating application for UTD students, built with the `curses` API.

## Installation

Unfamiliar with terminal stuff? Here's what you need to start using Kuiper:

1. [Install Python](https://www.python.org/downloads/release/python-379/)
2. Open up your terminal or command line
3. Type in `python3 -m pip install kuiper`. You may receive some nasty output, that's alright. Mac users might need to install XCode tools
4. Now you're ready to use Kuiper! Just type `kuiper` into your command line, and the TUI should boot.

## Usage
```bash
$ kuiper                       # Start the TUI
$ kuiper -c USERNAME PASSWORD  # Login with credentials
$ kuiper -d                    # Print configs
$ kuiper -i                    # Initialize the database
$ kuiper -h                    # View the help menu
$ kuiper -l new_configs.yaml   # Update server configs
$ kuiper --local_server        # Connect to localhost server
$ kuiper -q                    # Suppress server output
$ kuiper -s                    # Start server
```

Menu navigation is controlled by the up and down arrow keys.

When filling out a form field, the string in the bottom-right corner is the current buffer. 
Hit "Enter" to save the form field.

## Configs

The follow are the configuration options supported by Kuiper. 

To modify Kuiper's configs, create a `config.yaml` file with the keys and values you'd like to overwrite, 
and call `kuiper -l config.yaml`

| Config | Default Value | Description |
| --- | --- | --- |
| bind_host | "127.0.0.1" | The address on which the server will be hosted via `kuiper -s` |
| port | 8000 | The port on which the server will be hosted via `kuiper -s`
| access_host | "35.172.42.184" | The address to the server the client will ping. The defualt value is the static IP address of Kuiper's main server |
| db_path | "kuiper.db" | The path to the server's user and post database |
| required_email_suffix | "@utdallas.edu" | The email suffix required during registration. For no requirement, set to `""` |
| org_name | "UTD" | The organization name to be displayed at login and registration |
| server_email_username/password | None/None | The login information for the email the server will use to send email verification codes |
| server_email_smtp_addr/port | "smtp.gmail.com"/465 | The SMTP address/port used to send emails |
| text_editor | "vim" | The text editor called via the `subprocess` module to write posts and comments |


## Inspiration
[UTD Bruh Moments IG Post](https://www.instagram.com/p/CRCJhEmpbI0/)

[Original Reddit Post](https://www.reddit.com/r/utdallas/comments/od9roi/how_easy_is_it_to_find_men_above_the_age_of_23_at/)


%prep
%autosetup -n kuiper-0.8.15

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-kuiper -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.15-1
- Package Spec generated