%global _empty_manifest_terminate_build 0
Name: python-librelingo-json-export
Version: 0.10.1
Release: 1
Summary: Export LibreLingo courses in the JSON format used by the web app
License: AGPLv3
URL: https://pypi.org/project/librelingo-json-export/
Source0: https://mirrors.aliyun.com/pypi/web/packages/df/04/89b2f522747fe05cfba9f54f6121234332c3a091095d6ef925bfff6f791b/librelingo_json_export-0.10.1.tar.gz
BuildArch: noarch
Requires: python3-librelingo-types
Requires: python3-librelingo-utils
Requires: python3-slugify
Requires: python3-editdistance
Requires: python3-hunspell
Requires: python3-click
Requires: python3-librelingo-yaml-loader
%description
# librelingo\_json\_export.export
#### export\_course
```python
export_course(export_path: str, course: Course, settings=None)
```
Writes the course to JSON files in the specified path.
### Usage example:
```python
from librelingo_yaml_loader import load_course
from librelingo_json_export.export import export_course
course = load_course("./courses/french-from-english")
export_course("./apps/web/src/courses/french-from-english", course)
```
%package -n python3-librelingo-json-export
Summary: Export LibreLingo courses in the JSON format used by the web app
Provides: python-librelingo-json-export
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-librelingo-json-export
# librelingo\_json\_export.export
#### export\_course
```python
export_course(export_path: str, course: Course, settings=None)
```
Writes the course to JSON files in the specified path.
### Usage example:
```python
from librelingo_yaml_loader import load_course
from librelingo_json_export.export import export_course
course = load_course("./courses/french-from-english")
export_course("./apps/web/src/courses/french-from-english", course)
```
%package help
Summary: Development documents and examples for librelingo-json-export
Provides: python3-librelingo-json-export-doc
%description help
# librelingo\_json\_export.export
#### export\_course
```python
export_course(export_path: str, course: Course, settings=None)
```
Writes the course to JSON files in the specified path.
### Usage example:
```python
from librelingo_yaml_loader import load_course
from librelingo_json_export.export import export_course
course = load_course("./courses/french-from-english")
export_course("./apps/web/src/courses/french-from-english", course)
```
%prep
%autosetup -n librelingo_json_export-0.10.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-librelingo-json-export -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.10.1-1
- Package Spec generated