%global _empty_manifest_terminate_build 0
Name: python-gevent_inotifyx
Version: 0.2
Release: 1
Summary: gevent compatibility for inotifyx
License: MIT
URL: https://github.com/trendels/gevent_inotifyx
Source0: https://mirrors.aliyun.com/pypi/web/packages/0b/11/cfd16b1cb00114806b94d5e800bcbca319ae78022d00439e63d3011be6f7/gevent_inotifyx-0.2.tar.gz
BuildArch: noarch
%description
|build-status-img|
Gevent-compatible low-level inotify bindings based on
`inotifyx `__.
- Python 2 and 3 compatible
- Exposes a low-level
`inotify(7) `__
API
- Allows to wait for events in a non-blocking way when using
`gevent `__.
%package -n python3-gevent_inotifyx
Summary: gevent compatibility for inotifyx
Provides: python-gevent_inotifyx
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-gevent_inotifyx
|build-status-img|
Gevent-compatible low-level inotify bindings based on
`inotifyx `__.
- Python 2 and 3 compatible
- Exposes a low-level
`inotify(7) `__
API
- Allows to wait for events in a non-blocking way when using
`gevent `__.
%package help
Summary: Development documents and examples for gevent_inotifyx
Provides: python3-gevent_inotifyx-doc
%description help
|build-status-img|
Gevent-compatible low-level inotify bindings based on
`inotifyx `__.
- Python 2 and 3 compatible
- Exposes a low-level
`inotify(7) `__
API
- Allows to wait for events in a non-blocking way when using
`gevent `__.
%prep
%autosetup -n gevent_inotifyx-0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-gevent_inotifyx -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.2-1
- Package Spec generated