%global _empty_manifest_terminate_build 0
Name:		python-py-spec
Version:	3.3.2
Release:	1
Summary:	SPEC(Stepped-Pressure Equilibrium Code) python utilities
License:	GNU 3.0
URL:		https://princetonuniversity.github.io/SPEC/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/06/ef/ed591570b15f0453610c48915b8515704eb24041e511a1d3ca6bec79ec65/py_spec-3.3.2.tar.gz
BuildArch:	noarch


%description
This is the Python package for SPEC.
`py_spec` uses the [black](https://black.readthedocs.io/en/stable/index.html) code style.

%package -n python3-py-spec
Summary:	SPEC(Stepped-Pressure Equilibrium Code) python utilities
Provides:	python-py-spec
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-py-spec
This is the Python package for SPEC.
`py_spec` uses the [black](https://black.readthedocs.io/en/stable/index.html) code style.

%package help
Summary:	Development documents and examples for py-spec
Provides:	python3-py-spec-doc
%description help
This is the Python package for SPEC.
`py_spec` uses the [black](https://black.readthedocs.io/en/stable/index.html) code style.

%prep
%autosetup -n py_spec-3.3.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-py-spec -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 3.3.2-1
- Package Spec generated