%global _empty_manifest_terminate_build 0
Name: python-BinanceTrApi
Version: 0.1.1
Release: 1
Summary: TRbinance API implementation in python.
License: MIT License
URL: https://pypi.org/project/BinanceTrApi/
Source0: https://mirrors.aliyun.com/pypi/web/packages/fe/9f/5fa904374cca19b8fe3d015e8987aaf486502563c07fcaa32f302b9d43bb/BinanceTrApi-0.1.1.tar.gz
BuildArch: noarch
%description
Tr Binance API
## Table of Contents
* [About the Project](#about-the-project)
* [Getting Started](#getting-started)
* [Prerequisites](#prerequisites)
* [Installation](#installation)
* [License](#license)
* [Contact](#developers)
## About The Project
BinanceTR borsasında, alım-satım yapmak veya piyasa verilerini çekmek için geliştirilen kullanımı kolay ve pratik bir python kütüphanesidir.
Binance TR'nin herkese açık [API dokümanı](https://www.trbinance.com/apidocs/) referans alınarak python programlama dili ile Binance TR için özel uygulama geliştirmek isteyenler için geliştirilmiştir.
## Getting Started
Kurulum yönergesi için aşağıdaki adımlar takip edilebilir.
### Prerequisites
- python3
- pip
### Installation
- #### Firstly Install python 3 and pip.
#### Install From Repo
Clone the repo
```shell
git clone https://github.com/futuristicexchanger/BinanceTrApi
```
In project directory run
```shell
pip install .
```
or
```shell
python setup.py install
```
#### Install via pip
```shell
pip install BinanceTrApi
```
## License
Distributed under the MIT License. See `LICENSE` for more information.
## Developers
[Ali Çakıcı](https://www.linkedin.com/in/ali-cakici-developer/) - a.cakici2020@gtu.edu.tr
[Haldun Meriç Erbay](https://www.linkedin.com/in/haldunerbay/) - haldunerbay@gmail.com
[Yiğit Bozkurt](https://www.linkedin.com/in/ygtbzkrt/) - ygt.bozkurt@gmail.com
Project Link: [https://pypi.org/project/BinanceTrApi/](https://pypi.org/project/BinanceTrApi/)
%package -n python3-BinanceTrApi
Summary: TRbinance API implementation in python.
Provides: python-BinanceTrApi
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-BinanceTrApi
Tr Binance API
## Table of Contents
* [About the Project](#about-the-project)
* [Getting Started](#getting-started)
* [Prerequisites](#prerequisites)
* [Installation](#installation)
* [License](#license)
* [Contact](#developers)
## About The Project
BinanceTR borsasında, alım-satım yapmak veya piyasa verilerini çekmek için geliştirilen kullanımı kolay ve pratik bir python kütüphanesidir.
Binance TR'nin herkese açık [API dokümanı](https://www.trbinance.com/apidocs/) referans alınarak python programlama dili ile Binance TR için özel uygulama geliştirmek isteyenler için geliştirilmiştir.
## Getting Started
Kurulum yönergesi için aşağıdaki adımlar takip edilebilir.
### Prerequisites
- python3
- pip
### Installation
- #### Firstly Install python 3 and pip.
#### Install From Repo
Clone the repo
```shell
git clone https://github.com/futuristicexchanger/BinanceTrApi
```
In project directory run
```shell
pip install .
```
or
```shell
python setup.py install
```
#### Install via pip
```shell
pip install BinanceTrApi
```
## License
Distributed under the MIT License. See `LICENSE` for more information.
## Developers
[Ali Çakıcı](https://www.linkedin.com/in/ali-cakici-developer/) - a.cakici2020@gtu.edu.tr
[Haldun Meriç Erbay](https://www.linkedin.com/in/haldunerbay/) - haldunerbay@gmail.com
[Yiğit Bozkurt](https://www.linkedin.com/in/ygtbzkrt/) - ygt.bozkurt@gmail.com
Project Link: [https://pypi.org/project/BinanceTrApi/](https://pypi.org/project/BinanceTrApi/)
%package help
Summary: Development documents and examples for BinanceTrApi
Provides: python3-BinanceTrApi-doc
%description help
Tr Binance API
## Table of Contents
* [About the Project](#about-the-project)
* [Getting Started](#getting-started)
* [Prerequisites](#prerequisites)
* [Installation](#installation)
* [License](#license)
* [Contact](#developers)
## About The Project
BinanceTR borsasında, alım-satım yapmak veya piyasa verilerini çekmek için geliştirilen kullanımı kolay ve pratik bir python kütüphanesidir.
Binance TR'nin herkese açık [API dokümanı](https://www.trbinance.com/apidocs/) referans alınarak python programlama dili ile Binance TR için özel uygulama geliştirmek isteyenler için geliştirilmiştir.
## Getting Started
Kurulum yönergesi için aşağıdaki adımlar takip edilebilir.
### Prerequisites
- python3
- pip
### Installation
- #### Firstly Install python 3 and pip.
#### Install From Repo
Clone the repo
```shell
git clone https://github.com/futuristicexchanger/BinanceTrApi
```
In project directory run
```shell
pip install .
```
or
```shell
python setup.py install
```
#### Install via pip
```shell
pip install BinanceTrApi
```
## License
Distributed under the MIT License. See `LICENSE` for more information.
## Developers
[Ali Çakıcı](https://www.linkedin.com/in/ali-cakici-developer/) - a.cakici2020@gtu.edu.tr
[Haldun Meriç Erbay](https://www.linkedin.com/in/haldunerbay/) - haldunerbay@gmail.com
[Yiğit Bozkurt](https://www.linkedin.com/in/ygtbzkrt/) - ygt.bozkurt@gmail.com
Project Link: [https://pypi.org/project/BinanceTrApi/](https://pypi.org/project/BinanceTrApi/)
%prep
%autosetup -n BinanceTrApi-0.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-BinanceTrApi -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.1.1-1
- Package Spec generated